summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-09-26 17:27:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-09-26 17:27:00 +0000
commitd7a73c0b45fae5beadbfe46bee137a370533d700 (patch)
treeb67e938d6ecf6027e1c1a68538db5abed1cd9462 /games-action/clanbomber
parentMaking games last on inherit line. (diff)
downloadgentoo-2-d7a73c0b45fae5beadbfe46bee137a370533d700.tar.gz
gentoo-2-d7a73c0b45fae5beadbfe46bee137a370533d700.tar.bz2
gentoo-2-d7a73c0b45fae5beadbfe46bee137a370533d700.zip
tidy
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-action/clanbomber')
-rw-r--r--games-action/clanbomber/clanbomber-1.05.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/games-action/clanbomber/clanbomber-1.05.ebuild b/games-action/clanbomber/clanbomber-1.05.ebuild
index 02a3aa49619f..ce1a818eb360 100644
--- a/games-action/clanbomber/clanbomber-1.05.ebuild
+++ b/games-action/clanbomber/clanbomber-1.05.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/clanbomber/clanbomber-1.05.ebuild,v 1.5 2005/09/26 17:12:40 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/clanbomber/clanbomber-1.05.ebuild,v 1.6 2005/09/26 17:27:00 mr_bones_ Exp $
inherit eutils flag-o-matic games
@@ -10,24 +10,22 @@ SRC_URI="mirror://sourceforge/clanbomber/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 amd64"
+KEYWORDS="amd64 x86"
IUSE=""
-RDEPEND="sys-libs/zlib
+DEPEND="sys-libs/zlib
media-libs/hermes
=dev-games/clanlib-0.6.5*"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -i \
-e 's:\(@datadir@/clanbomber/\):$(DESTDIR)\1:' \
clanbomber/{,*/}Makefile.in \
|| die "sed failed"
- epatch "${FILESDIR}/${PV}-no-display.patch"
- epatch "${FILESDIR}/${PV}-gcc34.patch"
+ epatch "${FILESDIR}/${PV}-no-display.patch" \
+ "${FILESDIR}/${PV}-gcc34.patch"
}
src_compile() {