summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-27 11:29:22 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-27 11:29:22 +0000
commit51cbcf230a81c3c01f8dcd438356f849939f67fe (patch)
tree031bf0f1f8af98c1f0769a6b0c2d0e97e7a99c27 /games-action/descent3
parentRemove unfunctional sed -line for restoring support for older compilers wrt #... (diff)
downloadgentoo-2-51cbcf230a81c3c01f8dcd438356f849939f67fe.tar.gz
gentoo-2-51cbcf230a81c3c01f8dcd438356f849939f67fe.tar.bz2
gentoo-2-51cbcf230a81c3c01f8dcd438356f849939f67fe.zip
Support multilib packages in dependencies. Update/fix dependencies.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-action/descent3')
-rw-r--r--games-action/descent3/ChangeLog9
-rw-r--r--games-action/descent3/descent3-1.4.0b-r2.ebuild113
2 files changed, 120 insertions, 2 deletions
diff --git a/games-action/descent3/ChangeLog b/games-action/descent3/ChangeLog
index 5ee2c5611a32..cd343bdcae35 100644
--- a/games-action/descent3/ChangeLog
+++ b/games-action/descent3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/descent3
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/descent3/ChangeLog,v 1.31 2013/08/14 11:27:41 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/descent3/ChangeLog,v 1.32 2014/06/27 11:29:22 mgorny Exp $
+
+*descent3-1.4.0b-r2 (27 Jun 2014)
+
+ 27 Jun 2014; Michał Górny <mgorny@gentoo.org> +descent3-1.4.0b-r2.ebuild:
+ Support multilib packages in dependencies. Update/fix dependencies.
14 Aug 2013; Patrick Lauer <patrick@gentoo.org> descent3-1.4.0b-r1.ebuild:
Whitespace / syntax fix
diff --git a/games-action/descent3/descent3-1.4.0b-r2.ebuild b/games-action/descent3/descent3-1.4.0b-r2.ebuild
new file mode 100644
index 000000000000..0c5600117264
--- /dev/null
+++ b/games-action/descent3/descent3-1.4.0b-r2.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/descent3/descent3-1.4.0b-r2.ebuild,v 1.1 2014/06/27 11:29:22 mgorny Exp $
+
+EAPI=5
+
+inherit eutils unpacker cdrom multilib games
+
+IUSE="nocd videos"
+DESCRIPTION="Descent 3 - 3-Dimensional indoor/outdoor spaceship combat"
+HOMEPAGE="http://www.lokigames.com/products/descent3/"
+SRC_URI="mirror://lokigames/${PN}/${PN}-1.4.0a-x86.run
+ mirror://lokigames/${PN}/${P}-x86.run"
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip"
+
+DEPEND=""
+RDEPEND="sys-libs/glibc
+ || (
+ (
+ media-libs/libsdl[abi_x86_32(-)]
+ media-libs/smpeg[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ )
+ amd64? (
+ app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ )
+ )"
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+pkg_setup() {
+ games_pkg_setup
+ if use videos ; then
+ ewarn "The installed game takes about 1.2GB of space!"
+ elif use nocd ; then
+ ewarn "The installed game takes about 510MB of space!"
+ else
+ ewarn "The installed game takes about 220MB of space!"
+ fi
+}
+
+src_unpack() {
+ if use videos ; then
+ cdrom_get_cds missions/d3.mn3 movies/level1.mve
+ else
+ cdrom_get_cds missions/d3.mn3
+ fi
+ mkdir -p "${S}"/{a,b} || die
+ cd "${S}"/a || die
+ unpack_makeself ${PN}-1.4.0a-x86.run
+ cd "${S}"/b || die
+ unpack_makeself ${P}-x86.run
+}
+
+src_install() {
+ einfo "Copying files... this may take a while..."
+ exeinto "${dir}"
+ doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/{${PN},nettest}
+ insinto "${dir}"
+ doins ${CDROM_ROOT}/{FAQ.txt,README{,.mercenary},d3.hog,icon.{bmp,xpm}}
+
+ cd "${Ddir}" || die
+ # TODO: move this to src_unpack where it belongs
+ tar xzf ${CDROM_ROOT}/data.tar.gz || die "uncompressing data"
+ tar xzf ${CDROM_ROOT}/shared.tar.gz || die "uncompressing shared"
+
+ if use nocd; then
+ doins -r ${CDROM_ROOT}/missions
+ fi
+
+ if use videos ; then
+ cdrom_load_next_cd
+ doins -r ${CDROM_ROOT}/movies
+ fi
+
+ cd "${S}"/a || die
+ bin/Linux/x86/loki_patch --verify patch.dat || die
+ bin/Linux/x86/loki_patch patch.dat "${Ddir}" >& /dev/null || die "patching a"
+ cd "${S}"/b || die
+ bin/Linux/x86/loki_patch --verify patch.dat || die
+ bin/Linux/x86/loki_patch patch.dat "${Ddir}" >& /dev/null || die "patching b"
+
+ # now, since these files are coming off a cd, the times/sizes/md5sums wont
+ # be different ... that means portage will try to unmerge some files (!)
+ # we run touch on ${D} so as to make sure portage doesnt do any such thing
+ find "${Ddir}" -exec touch '{}' +
+
+ games_make_wrapper descent3 ./descent3.dynamic "${dir}" "${dir}"
+ newicon ${CDROM_ROOT}/icon.xpm ${PN}.xpm
+
+ # Fix for 2.6 kernel crash
+ cd "${Ddir}" || die
+ ln -sf ppics.hog PPics.Hog
+
+ prepgamesdirs
+ make_desktop_entry ${PN} "Descent 3" ${PN}
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "To play the game run:"
+ elog " descent3"
+ echo
+}