summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-25 13:28:11 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-25 13:28:11 +0000
commit33f12074c0d0a1c332e325a1a0a6f228e5267933 (patch)
tree1f9a9174602d6b029e35966142e2e77b1b13d6f5 /games-action/swordandsworcery
parentSupport multilib dependencies aside to emul-linux-x86. (diff)
downloadgentoo-2-33f12074c0d0a1c332e325a1a0a6f228e5267933.tar.gz
gentoo-2-33f12074c0d0a1c332e325a1a0a6f228e5267933.tar.bz2
gentoo-2-33f12074c0d0a1c332e325a1a0a6f228e5267933.zip
Support multilib dependencies aside to emul-linux-x86.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-action/swordandsworcery')
-rw-r--r--games-action/swordandsworcery/ChangeLog5
-rw-r--r--games-action/swordandsworcery/swordandsworcery-1.02.ebuild55
2 files changed, 53 insertions, 7 deletions
diff --git a/games-action/swordandsworcery/ChangeLog b/games-action/swordandsworcery/ChangeLog
index 58b424a54278..e24c17d1ef85 100644
--- a/games-action/swordandsworcery/ChangeLog
+++ b/games-action/swordandsworcery/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/swordandsworcery
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/swordandsworcery/ChangeLog,v 1.3 2014/05/15 16:25:05 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/swordandsworcery/ChangeLog,v 1.4 2014/06/25 13:28:11 mgorny Exp $
+
+ 25 Jun 2014; Michał Górny <mgorny@gentoo.org> swordandsworcery-1.02.ebuild:
+ Support multilib dependencies aside to emul-linux-x86.
15 May 2014; Ulrich Müller <ulm@gentoo.org> swordandsworcery-1.02.ebuild:
Fix USE dependency on media-libs/libsdl, "audio" USE flag was renamed to
diff --git a/games-action/swordandsworcery/swordandsworcery-1.02.ebuild b/games-action/swordandsworcery/swordandsworcery-1.02.ebuild
index 9d4f4490a6b4..0d0f18d7c4e1 100644
--- a/games-action/swordandsworcery/swordandsworcery-1.02.ebuild
+++ b/games-action/swordandsworcery/swordandsworcery-1.02.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/swordandsworcery/swordandsworcery-1.02.ebuild,v 1.4 2014/05/15 16:25:05 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/swordandsworcery/swordandsworcery-1.02.ebuild,v 1.5 2014/06/25 13:28:11 mgorny Exp $
# TODO: unbundle liblua-5.1 when available for multilib
@@ -26,11 +26,54 @@ QA_PREBUILT="${MYGAMEDIR#/}/bin/*
RDEPEND="
virtual/opengl
amd64? (
- app-emulation/emul-linux-x86-baselibs
- app-emulation/emul-linux-x86-opengl
- app-emulation/emul-linux-x86-sdl
- app-emulation/emul-linux-x86-soundlibs[alsa]
- app-emulation/emul-linux-x86-xlibs
+ || (
+ app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ (
+ dev-libs/openssl[abi_x86_32(-)]
+ sys-libs/zlib[abi_x86_32(-)]
+ !bundled-libs? (
+ net-misc/curl[abi_x86_32(-)]
+ )
+ )
+ )
+ || (
+ app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)]
+ (
+ virtual/glu[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ )
+ )
+ !bundled-libs? (
+ || (
+ app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
+ media-libs/libsdl[X,sound,video,opengl,joystick,abi_x86_32(-)]
+ )
+ )
+ || (
+ app-emulation/emul-linux-x86-soundlibs[alsa,-abi_x86_32(-)]
+ (
+ media-libs/alsa-lib[abi_x86_32(-)]
+ media-libs/flac[abi_x86_32(-)]
+ media-libs/libogg[abi_x86_32(-)]
+ media-libs/libsndfile[abi_x86_32(-)]
+ media-libs/libvorbis[abi_x86_32(-)]
+ media-sound/pulseaudio[abi_x86_32(-)]
+ )
+ )
+ || (
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ (
+ x11-libs/libICE[abi_x86_32(-)]
+ x11-libs/libSM[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libxcb[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libXi[abi_x86_32(-)]
+ x11-libs/libXtst[abi_x86_32(-)]
+ )
+ )
)
x86? (
dev-libs/openssl