summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-09-08 12:32:30 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-09-08 12:32:30 +0000
commitb8857fb7f2025923426786ce119e2571b8d42b36 (patch)
tree26e2cf7a49b6afd434f34623c14071b5d9273fba /games-action/teeworlds
parentUpdate for new KAVERI firmware, bug #484056. (diff)
downloadgentoo-2-b8857fb7f2025923426786ce119e2571b8d42b36.tar.gz
gentoo-2-b8857fb7f2025923426786ce119e2571b8d42b36.tar.bz2
gentoo-2-b8857fb7f2025923426786ce119e2571b8d42b36.zip
respect CC/CXX, make build log verbose, fix dedicated useflag wrt #477658
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-action/teeworlds')
-rw-r--r--games-action/teeworlds/ChangeLog9
-rw-r--r--games-action/teeworlds/files/0.6.2/04-dedicated.patch15
-rw-r--r--games-action/teeworlds/files/0.6.2/05-cc-cflags.patch18
-rw-r--r--games-action/teeworlds/teeworlds-0.6.2-r1.ebuild (renamed from games-action/teeworlds/teeworlds-0.6.2.ebuild)10
4 files changed, 46 insertions, 6 deletions
diff --git a/games-action/teeworlds/ChangeLog b/games-action/teeworlds/ChangeLog
index fd5acf371eb5..859a9b48aa71 100644
--- a/games-action/teeworlds/ChangeLog
+++ b/games-action/teeworlds/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-action/teeworlds
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/teeworlds/ChangeLog,v 1.11 2013/09/05 18:37:31 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/teeworlds/ChangeLog,v 1.12 2013/09/08 12:32:29 hasufell Exp $
+
+*teeworlds-0.6.2-r1 (08 Sep 2013)
+
+ 08 Sep 2013; Julian Ospald <hasufell@gentoo.org>
+ +files/0.6.2/04-dedicated.patch, +files/0.6.2/05-cc-cflags.patch,
+ -teeworlds-0.6.2.ebuild, +teeworlds-0.6.2-r1.ebuild:
+ respect CC/CXX, make build log verbose, fix dedicated useflag wrt #477658
*teeworlds-0.6.2 (05 Sep 2013)
diff --git a/games-action/teeworlds/files/0.6.2/04-dedicated.patch b/games-action/teeworlds/files/0.6.2/04-dedicated.patch
new file mode 100644
index 000000000000..fc61b71283b6
--- /dev/null
+++ b/games-action/teeworlds/files/0.6.2/04-dedicated.patch
@@ -0,0 +1,15 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Sep 8 11:05:26 UTC 2013
+Subject: fix DATADIR detection for minimal setups
+
+--- a/src/engine/shared/storage.cpp
++++ b/src/engine/shared/storage.cpp
+@@ -208,7 +208,7 @@
+ for (i = 0; i < DirsCount; i++)
+ {
+ char aBuf[128];
+- str_format(aBuf, sizeof(aBuf), "%s/mapres", aDirs[i]);
++ str_format(aBuf, sizeof(aBuf), "%s/maps", aDirs[i]);
+ if(fs_is_dir(aBuf))
+ {
+ str_copy(m_aDatadir, aDirs[i], sizeof(m_aDatadir));
diff --git a/games-action/teeworlds/files/0.6.2/05-cc-cflags.patch b/games-action/teeworlds/files/0.6.2/05-cc-cflags.patch
new file mode 100644
index 000000000000..dec6b8d306fc
--- /dev/null
+++ b/games-action/teeworlds/files/0.6.2/05-cc-cflags.patch
@@ -0,0 +1,18 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Sep 8 12:25:19 UTC 2013
+Subject: respect our gentoo settings
+
+ this has to be at this place or later
+ otherwise some of our settings would be overwritten
+
+--- a/bam.lua
++++ b/bam.lua
+@@ -168,6 +168,8 @@
+ -- set some platform specific settings
+ settings.cc.includes:Add("src")
+
++ dofile("gentoo.lua") addSettings(settings)
++
+ if family == "unix" then
+ if platform == "macosx" then
+ settings.link.frameworks:Add("Carbon")
diff --git a/games-action/teeworlds/teeworlds-0.6.2.ebuild b/games-action/teeworlds/teeworlds-0.6.2-r1.ebuild
index cf415f1b7768..535226135f55 100644
--- a/games-action/teeworlds/teeworlds-0.6.2.ebuild
+++ b/games-action/teeworlds/teeworlds-0.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/teeworlds/teeworlds-0.6.2.ebuild,v 1.1 2013/09/05 18:37:31 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/teeworlds/teeworlds-0.6.2-r1.ebuild,v 1.1 2013/09/08 12:32:29 hasufell Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -59,12 +59,12 @@ src_prepare() {
__EOF__
sed -i \
- -e '/^function build(settings)/a dofile("gentoo.lua") addSettings(settings)' \
- bam.lua || die
+ -e "s#/usr/share/games/teeworlds/data#${GAMES_DATADIR}/${PN}/data#" \
+ src/engine/shared/storage.cpp || die
}
src_configure() {
- bam config || die
+ bam -v config || die
}
src_compile() {
@@ -83,7 +83,7 @@ src_compile() {
fi
fi
- bam -a -j $(makeopts_jobs) ${myopt} || die
+ bam -v -a -j $(makeopts_jobs) ${myopt} || die
}
src_install() {