summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-10-14 04:40:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-10-14 04:40:47 +0000
commitd984bfd97c1fc27610ea593cd968dc65bc4d1f68 (patch)
treeb76df47688e077994a5652d3c1ae215562e239a0 /games-action/trackballs
parentold (diff)
downloadgentoo-2-d984bfd97c1fc27610ea593cd968dc65bc4d1f68.tar.gz
gentoo-2-d984bfd97c1fc27610ea593cd968dc65bc4d1f68.tar.bz2
gentoo-2-d984bfd97c1fc27610ea593cd968dc65bc4d1f68.zip
add sed patches from Kevin Pyle for bug #340909
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-action/trackballs')
-rw-r--r--games-action/trackballs/ChangeLog8
-rw-r--r--games-action/trackballs/trackballs-1.1.4.ebuild16
2 files changed, 20 insertions, 4 deletions
diff --git a/games-action/trackballs/ChangeLog b/games-action/trackballs/ChangeLog
index 1a66ea3ae438..427312a64753 100644
--- a/games-action/trackballs/ChangeLog
+++ b/games-action/trackballs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/trackballs
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/trackballs/ChangeLog,v 1.25 2009/11/07 18:39:22 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/trackballs/ChangeLog,v 1.26 2010/10/14 04:40:47 mr_bones_ Exp $
+
+ 14 Oct 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ trackballs-1.1.4.ebuild:
+ add sed patches from Kevin Pyle for bug #340909
07 Nov 2009; Michael Sterrett <mr_bones_@gentoo.org>
trackballs-1.1.4.ebuild:
diff --git a/games-action/trackballs/trackballs-1.1.4.ebuild b/games-action/trackballs/trackballs-1.1.4.ebuild
index f3d83ab7d5dc..71022eff6a20 100644
--- a/games-action/trackballs/trackballs-1.1.4.ebuild
+++ b/games-action/trackballs/trackballs-1.1.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/trackballs/trackballs-1.1.4.ebuild,v 1.6 2009/11/07 18:39:22 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/trackballs/trackballs-1.1.4.ebuild,v 1.7 2010/10/14 04:40:47 mr_bones_ Exp $
EAPI=2
inherit eutils games
@@ -35,6 +35,18 @@ src_prepare() {
src/Makefile.in \
po/Makefile.in.in \
|| die "sed failed"
+ # Fix _FORTIFY_SOURCE buffer overflow due to wrong sizeof
+ sed -i \
+ -e 's/\(snprintf(\(name\),sizeof\)(str)/\1(\2)/' \
+ src/enterHighScoreMode.cc || die
+ # Fix -Wformat-security warning due to non-literal with no format arguments
+ sed -i \
+ -e 's/\(snprintf(levelname,sizeof(levelname),\)\(name)\)/\1 "%s", \2/' \
+ -e 's/\(snprintf(Settings::settings->specialLevel,sizeof(Settings::settings->specialLevel),\)\(levelname)\)/\1 "%s", \2/' \
+ src/editMode.cc || die
+ sed -i \
+ -e 's/\(snprintf(\(textureName\),\)63\(,textureNames\[i\])\)/\1 sizeof(\2), "%s"\3/' \
+ src/map.cc || die
}
src_configure() {