summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-03-31 00:48:37 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-03-31 00:48:37 +0000
commit3bf4afdcd80f47e32c387e8a17f90abda1d2702f (patch)
tree208f0e3eaf35c5298523b5f337c4642366e8c746 /games-action/trine-bin
parentEAPI=5 (diff)
downloadgentoo-2-3bf4afdcd80f47e32c387e8a17f90abda1d2702f.tar.gz
gentoo-2-3bf4afdcd80f47e32c387e8a17f90abda1d2702f.tar.bz2
gentoo-2-3bf4afdcd80f47e32c387e8a17f90abda1d2702f.zip
EAPI=5
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-action/trine-bin')
-rw-r--r--games-action/trine-bin/ChangeLog7
-rw-r--r--games-action/trine-bin/trine-bin-1.08.ebuild17
2 files changed, 14 insertions, 10 deletions
diff --git a/games-action/trine-bin/ChangeLog b/games-action/trine-bin/ChangeLog
index 8bb4a34887b2..5e1b756fff9b 100644
--- a/games-action/trine-bin/ChangeLog
+++ b/games-action/trine-bin/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/trine-bin
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/trine-bin/ChangeLog,v 1.3 2013/03/29 15:45:51 hasufell Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/trine-bin/ChangeLog,v 1.4 2015/03/31 00:48:37 mr_bones_ Exp $
+
+ 31 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org> trine-bin-1.08.ebuild:
+ EAPI=5
29 Mar 2013; Julian Ospald <hasufell@gentoo.org> trine-bin-1.08.ebuild:
use unpack_zip from unpacker.eclass instead of unzip
diff --git a/games-action/trine-bin/trine-bin-1.08.ebuild b/games-action/trine-bin/trine-bin-1.08.ebuild
index 7edb66eb778a..ba149b43caec 100644
--- a/games-action/trine-bin/trine-bin-1.08.ebuild
+++ b/games-action/trine-bin/trine-bin-1.08.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/trine-bin/trine-bin-1.08.ebuild,v 1.5 2013/03/29 15:48:19 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/trine-bin/trine-bin-1.08.ebuild,v 1.6 2015/03/31 00:48:37 mr_bones_ Exp $
# these are ELFs that include a ZIP (504b0304) appended to it
# dd if=Trine.64.run of=Trine.64.zip ibs=$((0x342a8)) skip=1
@@ -8,6 +8,7 @@
# but `unzip` will skip the ELF at the start. both ELFs contain
# the same zip appended, so only need to hash one of them.
+EAPI=5
inherit unpacker games eutils
DESCRIPTION="a physics-based action game where diff characters allow diff solutions to challenges"
@@ -28,7 +29,7 @@ RDEPEND=">=sys-libs/glibc-2.4
S=${WORKDIR}
-d="${GAMES_PREFIX_OPT}/${PN}"
+d=${GAMES_PREFIX_OPT}/${PN}
QA_PRESTRIPPED="${d#/}/trine-launcher ${d#/}/trine-bin ${d#/}/lib*/lib*.so*"
QA_TEXTRELS_x86="`echo ${d#/}/lib32/lib{avcodec.so.51,avformat.so.52,avutil.so.49,FLAC.so.8}`"
@@ -47,20 +48,20 @@ src_install() {
local b bb
local sfx=$(use x86 && echo 32 || echo 64)
- doicon Trine.xpm || die
+ doicon Trine.xpm
for b in bin launcher ; do
bb="trine-${b}"
exeinto ${d}
- newexe ${bb}${sfx} ${bb} || die
- games_make_wrapper ${bb} "./${bb}" "${d}" || die
+ newexe ${bb}${sfx} ${bb}
+ games_make_wrapper ${bb} "./${bb}" "${d}"
make_desktop_entry ${bb} "Trine ${b}" Trine
done
exeinto ${d}/lib${sfx}
- doexe lib${sfx}/* || die
+ doexe lib${sfx}/*
insinto ${d}
- doins -r binds config data dev profiles *.fbz *.glade trine-logo.png || die
+ doins -r binds config data dev profiles *.fbz *.glade trine-logo.png
dodoc Trine_Manual_linux.pdf Trine_updates.txt