summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2015-01-02 11:13:01 +0000
committerAlfredo Tupone <tupone@gentoo.org>2015-01-02 11:13:01 +0000
commit0d34b1c15779453d0a48a603dbd78cfee76ab966 (patch)
tree98841edbd8e238d35e6aa588756dc496daf2b78b /games-action
parentEAPI 4 (diff)
downloadgentoo-2-0d34b1c15779453d0a48a603dbd78cfee76ab966.tar.gz
gentoo-2-0d34b1c15779453d0a48a603dbd78cfee76ab966.tar.bz2
gentoo-2-0d34b1c15779453d0a48a603dbd78cfee76ab966.zip
EAPI 4
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/xblast/ChangeLog7
-rw-r--r--games-action/xblast/xblast-2.10.4.ebuild19
2 files changed, 13 insertions, 13 deletions
diff --git a/games-action/xblast/ChangeLog b/games-action/xblast/ChangeLog
index 60b4f2048772..8fbb02dfdc1d 100644
--- a/games-action/xblast/ChangeLog
+++ b/games-action/xblast/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/xblast
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xblast/ChangeLog,v 1.16 2009/04/15 22:00:30 nyhm Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/xblast/ChangeLog,v 1.17 2015/01/02 11:13:01 tupone Exp $
+
+ 02 Jan 2015; Tupone Alfredo <tupone@gentoo.org> xblast-2.10.4.ebuild:
+ EAPI 4
15 Apr 2009; Tristan Heaven <nyhm@gentoo.org> xblast-2.10.4.ebuild:
Run eautoreconf, bug #255857
diff --git a/games-action/xblast/xblast-2.10.4.ebuild b/games-action/xblast/xblast-2.10.4.ebuild
index bc8919e384ba..52354e0e749d 100644
--- a/games-action/xblast/xblast-2.10.4.ebuild
+++ b/games-action/xblast/xblast-2.10.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xblast/xblast-2.10.4.ebuild,v 1.5 2009/04/15 22:00:30 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/xblast/xblast-2.10.4.ebuild,v 1.6 2015/01/02 11:13:01 tupone Exp $
-EAPI=2
+EAPI=4
inherit autotools games
# Change these as releases changes
@@ -39,15 +39,13 @@ src_prepare() {
src_configure() {
egamesconf \
--with-otherdatadir="${GAMES_DATADIR}"/${PN} \
- --enable-sound \
- || die
+ --enable-sound
}
src_install() {
local IMAGE_INSTALL_DIR="${GAMES_DATADIR}/${PN}/image"
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README
+ default
# Images
dodir "${IMAGE_INSTALL_DIR}"
@@ -56,16 +54,15 @@ src_install() {
# Levels
insinto "${GAMES_DATADIR}/xblast/level"
- doins "${WORKDIR}/${LEVELS}"/* || die "doins failed"
+ doins "${WORKDIR}/${LEVELS}"/*
# Models
insinto "${GAMES_DATADIR}/xblast/image/sprite"
- doins "${WORKDIR}/${MODELS}"/* || die "doins failed"
+ doins "${WORKDIR}/${MODELS}"/*
# Music and sound
insinto "${GAMES_DATADIR}/xblast/sounds"
- doins "${WORKDIR}/${MUSICS}"/* "${WORKDIR}/${SOUNDS}"/* \
- || die "doins failed"
+ doins "${WORKDIR}/${MUSICS}"/* "${WORKDIR}/${SOUNDS}"/*
# Cleanup
find "${D}" -name Imakefile -exec rm \{\} \;