summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-06-05 07:08:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-06-05 07:08:00 +0000
commit190783b40493e7f53f849c6ef9dec834ff7aefce (patch)
treeb2b00131a5a9788b0aa6dee57e64f96ceb69cf0b /games-action
parentVersion Bump, bug #532312; thanks Adam Jones and Alessandro Molari for the eb... (diff)
downloadgentoo-2-190783b40493e7f53f849c6ef9dec834ff7aefce.tar.gz
gentoo-2-190783b40493e7f53f849c6ef9dec834ff7aefce.tar.bz2
gentoo-2-190783b40493e7f53f849c6ef9dec834ff7aefce.zip
add patch to work with newer cmake (bug #551260)
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/supertuxkart/ChangeLog11
-rw-r--r--games-action/supertuxkart/files/supertuxkart-0.8.1-cmake.patch12
-rw-r--r--games-action/supertuxkart/files/supertuxkart-0.8.1-gentoo.patch2
-rw-r--r--games-action/supertuxkart/files/supertuxkart-0.8.1-icon-dest.patch2
-rw-r--r--games-action/supertuxkart/files/supertuxkart-0.8.1-jpeg9.patch4
-rw-r--r--games-action/supertuxkart/supertuxkart-0.8.1.ebuild4
6 files changed, 26 insertions, 9 deletions
diff --git a/games-action/supertuxkart/ChangeLog b/games-action/supertuxkart/ChangeLog
index 750da0adb5f3..675b5bd3fd18 100644
--- a/games-action/supertuxkart/ChangeLog
+++ b/games-action/supertuxkart/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for games-action/supertuxkart
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/ChangeLog,v 1.45 2015/06/01 22:10:22 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/ChangeLog,v 1.46 2015/06/05 07:08:00 mr_bones_ Exp $
+
+ 05 Jun 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/supertuxkart-0.8.1-cmake.patch,
+ files/supertuxkart-0.8.1-desktopfile.patch,
+ files/supertuxkart-0.8.1-gentoo.patch,
+ files/supertuxkart-0.8.1-icon-dest.patch,
+ files/supertuxkart-0.8.1-irrlicht.patch, files/supertuxkart-0.8.1-jpeg9.patch,
+ files/supertuxkart-0.8.1-mesa-10.x.patch, supertuxkart-0.8.1.ebuild:
+ add patch to work with newer cmake (bug #551260)
01 Jun 2015; Michael Sterrett <mr_bones_@gentoo.org>
supertuxkart-0.8.1.ebuild:
diff --git a/games-action/supertuxkart/files/supertuxkart-0.8.1-cmake.patch b/games-action/supertuxkart/files/supertuxkart-0.8.1-cmake.patch
new file mode 100644
index 000000000000..d5c038a5f922
--- /dev/null
+++ b/games-action/supertuxkart/files/supertuxkart-0.8.1-cmake.patch
@@ -0,0 +1,12 @@
+--- CMakeLists.txt.orig
++++ CMakeLists.txt
+@@ -128,6 +128,9 @@
+ find_package(OpenGL REQUIRED)
+ include_directories(${OPENGL_INCLUDE_DIR})
+
++find_package(X11 REQUIRED)
++include_directories(${X11_INCLUDE_DIR})
++
+ if(UNIX AND NOT APPLE)
+ find_library(IRRLICHT_XF86VM_LIBRARY Xxf86vm)
+ mark_as_advanced(IRRLICHT_XF86VM_LIBRARY)
diff --git a/games-action/supertuxkart/files/supertuxkart-0.8.1-gentoo.patch b/games-action/supertuxkart/files/supertuxkart-0.8.1-gentoo.patch
index 071c1b053f7a..647c52245dab 100644
--- a/games-action/supertuxkart/files/supertuxkart-0.8.1-gentoo.patch
+++ b/games-action/supertuxkart/files/supertuxkart-0.8.1-gentoo.patch
@@ -1,8 +1,6 @@
gentoo specific hacks because we unbundle the
deps of irrlicht
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 09edd58..1f51a30 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,7 +45,6 @@ add_subdirectory("${PROJECT_SOURCE_DIR}/lib/enet")
diff --git a/games-action/supertuxkart/files/supertuxkart-0.8.1-icon-dest.patch b/games-action/supertuxkart/files/supertuxkart-0.8.1-icon-dest.patch
index f9a5a04d676a..5ce3fff0dd39 100644
--- a/games-action/supertuxkart/files/supertuxkart-0.8.1-icon-dest.patch
+++ b/games-action/supertuxkart/files/supertuxkart-0.8.1-icon-dest.patch
@@ -4,8 +4,6 @@ Date: Tue Nov 26 22:13:21 2013 +0100
fix icon install dest
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 1f51a30..9c07659 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -304,7 +304,9 @@ endif()
diff --git a/games-action/supertuxkart/files/supertuxkart-0.8.1-jpeg9.patch b/games-action/supertuxkart/files/supertuxkart-0.8.1-jpeg9.patch
index 3c120c9b22e2..b1bae371b71d 100644
--- a/games-action/supertuxkart/files/supertuxkart-0.8.1-jpeg9.patch
+++ b/games-action/supertuxkart/files/supertuxkart-0.8.1-jpeg9.patch
@@ -1,5 +1,5 @@
---- lib/irrlicht/source/Irrlicht/CImageLoaderJPG.cpp.old 2014-09-25 06:56:46.911153643 +0200
-+++ lib/irrlicht/source/Irrlicht/CImageLoaderJPG.cpp 2014-09-25 06:55:52.817175916 +0200
+--- lib/irrlicht/source/Irrlicht/CImageLoaderJPG.cpp.old
++++ lib/irrlicht/source/Irrlicht/CImageLoaderJPG.cpp
@@ -66,7 +66,7 @@
boolean CImageLoaderJPG::fill_input_buffer (j_decompress_ptr cinfo)
{
diff --git a/games-action/supertuxkart/supertuxkart-0.8.1.ebuild b/games-action/supertuxkart/supertuxkart-0.8.1.ebuild
index 0fdec1ea828e..28d466c171e9 100644
--- a/games-action/supertuxkart/supertuxkart-0.8.1.ebuild
+++ b/games-action/supertuxkart/supertuxkart-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/supertuxkart-0.8.1.ebuild,v 1.7 2015/06/01 22:10:22 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/supertuxkart-0.8.1.ebuild,v 1.8 2015/06/05 07:08:00 mr_bones_ Exp $
EAPI=5
inherit gnome2-utils cmake-utils eutils games
@@ -41,7 +41,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/SuperTuxKart-${PV}
src_prepare() {
- epatch "${FILESDIR}"/${P}-{gentoo,icon-dest,irrlicht,desktopfile,mesa-10.x,jpeg9}.patch
+ epatch "${FILESDIR}"/${P}-{gentoo,icon-dest,irrlicht,desktopfile,mesa-10.x,jpeg9,cmake}.patch
# inconsistent handling of debug definition
# avoid using Debug build type