summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-02-15 18:27:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-02-15 18:27:52 +0000
commit1ab8b842f1e423ac6eb474a0ff4542ce77737689 (patch)
treeae4d88f14f2198041d9d919a2554190700be49cd /games-action
parentVersion bump to 9.7.3 (diff)
downloadgentoo-2-1ab8b842f1e423ac6eb474a0ff4542ce77737689.tar.gz
gentoo-2-1ab8b842f1e423ac6eb474a0ff4542ce77737689.tar.bz2
gentoo-2-1ab8b842f1e423ac6eb474a0ff4542ce77737689.zip
version bump
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/chromium/ChangeLog10
-rw-r--r--games-action/chromium/chromium-0.9.15.ebuild69
2 files changed, 77 insertions, 2 deletions
diff --git a/games-action/chromium/ChangeLog b/games-action/chromium/ChangeLog
index 1789679bfea1..58d1dd650c90 100644
--- a/games-action/chromium/ChangeLog
+++ b/games-action/chromium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/chromium
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/ChangeLog,v 1.44 2010/10/22 14:37:45 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/ChangeLog,v 1.45 2011/02/15 18:27:52 mr_bones_ Exp $
+
+*chromium-0.9.15 (15 Feb 2011)
+
+ 15 Feb 2011; Michael Sterrett <mr_bones_@gentoo.org>
+ +chromium-0.9.15.ebuild:
+ version bump
22 Oct 2010; Christian Faulhammer <fauli@gentoo.org>
chromium-0.9.14.1.ebuild:
diff --git a/games-action/chromium/chromium-0.9.15.ebuild b/games-action/chromium/chromium-0.9.15.ebuild
new file mode 100644
index 000000000000..379edb163dd3
--- /dev/null
+++ b/games-action/chromium/chromium-0.9.15.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/chromium-0.9.15.ebuild,v 1.1 2011/02/15 18:27:52 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+MY_P="${PN}-bsu-${PV}"
+DESCRIPTION="Chromium B.S.U. - an arcade game"
+HOMEPAGE="http://chromium-bsu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/chromium-bsu/${MY_P}.tar.gz"
+
+LICENSE="Clarified-Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mixer nls +sdl"
+
+RDEPEND="media-fonts/dejavu
+ media-libs/quesoglc
+ media-libs/glpng
+ virtual/opengl
+ virtual/glu
+ x11-libs/libXmu
+ mixer? ( media-libs/sdl-mixer )
+ !mixer? (
+ media-libs/freealut
+ media-libs/openal
+ )
+ nls? ( virtual/libintl )
+ sdl? (
+ media-libs/libsdl[X]
+ media-libs/sdl-image[png]
+ )
+ !sdl? ( media-libs/freeglut )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-ftgl \
+ --enable-glc \
+ $(use_enable mixer sdlmixer) \
+ $(use_enable !mixer openal) \
+ $(use_enable nls) \
+ $(use_enable sdl) \
+ $(use_enable sdl sdlimage) \
+ $(use_enable !sdl glut)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # remove installed /usr/games/share stuff
+ rm -rf "${D}"/"${GAMES_PREFIX}"/share/
+ newicon misc/${PN}-bsu.png ${PN}.png || die "doicon failed"
+ make_desktop_entry ${PN}-bsu "Chromium B.S.U"
+
+ # install documentation
+ dodoc AUTHORS README NEWS || die "dodoc failed"
+ dohtml "${S}"/data/doc/*.htm || die "dohtml failed"
+ cd "${S}"/data/doc/images
+ insinto /usr/share/doc/${PF}/html/images
+ doins *.jpg || die "doins failed"
+
+ prepgamesdirs
+}