summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-16 16:03:39 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-16 16:03:39 +0000
commit3d34be3a8705162b7d0790440a15352f60519711 (patch)
treeeb6e69774bf480ce014aadbbe575edac24bbc502 /games-action
parentThere is no TODO. (Manifest recommit) (diff)
downloadgentoo-2-3d34be3a8705162b7d0790440a15352f60519711.tar.gz
gentoo-2-3d34be3a8705162b7d0790440a15352f60519711.tar.bz2
gentoo-2-3d34be3a8705162b7d0790440a15352f60519711.zip
ppc support
Diffstat (limited to 'games-action')
-rw-r--r--games-action/bomberclone/bomberclone-0.11.2.ebuild8
-rw-r--r--games-action/koth/koth-0.8.0.ebuild6
-rw-r--r--games-action/poopmup/poopmup-1.2.ebuild4
-rw-r--r--games-action/powermanga/powermanga-0.78.ebuild18
4 files changed, 17 insertions, 19 deletions
diff --git a/games-action/bomberclone/bomberclone-0.11.2.ebuild b/games-action/bomberclone/bomberclone-0.11.2.ebuild
index 33f3263b49eb..cdee4d34b5d1 100644
--- a/games-action/bomberclone/bomberclone-0.11.2.ebuild
+++ b/games-action/bomberclone/bomberclone-0.11.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bomberclone/bomberclone-0.11.2.ebuild,v 1.1 2004/02/09 09:19:50 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/bomberclone/bomberclone-0.11.2.ebuild,v 1.2 2004/03/16 16:03:39 vapier Exp $
inherit games
@@ -8,9 +8,9 @@ DESCRIPTION="BomberMan clone with network game support"
HOMEPAGE="http://www.bomberclone.de/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-KEYWORDS="x86 ppc"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 ppc"
IUSE=""
RDEPEND="virtual/x11
@@ -24,7 +24,7 @@ src_compile() {
egamesconf --datadir="${GAMES_DATADIR_BASE}" || die
sed -i \
-e "/PACKAGE_DATA_DIR/ s:/usr/games/share/games/:${GAMES_DATADIR}/:" \
- config.h || die "sed config.h failed"
+ config.h || die "sed config.h failed"
emake || die "emake failed"
}
@@ -35,6 +35,6 @@ src_install() {
cp -R data/{gfx,maps,player,tileset}/ ${D}/${GAMES_DATADIR}/${PN} \
|| die "cp failed"
- dodoc AUTHORS ChangeLog README TODO || die "dodoc failed"
+ dodoc AUTHORS ChangeLog README TODO
prepgamesdirs
}
diff --git a/games-action/koth/koth-0.8.0.ebuild b/games-action/koth/koth-0.8.0.ebuild
index e594c3303e64..eb7c3ad437da 100644
--- a/games-action/koth/koth-0.8.0.ebuild
+++ b/games-action/koth/koth-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc. and Arcady Genkin <agenkin@thpoon.com>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/koth/koth-0.8.0.ebuild,v 1.2 2004/02/03 01:21:14 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/koth/koth-0.8.0.ebuild,v 1.3 2004/03/16 16:03:39 vapier Exp $
inherit eutils
@@ -8,13 +8,13 @@ DESCRIPTION="Multiplayer, networked game of little tanks with really big weapons
HOMEPAGE="http://www.nongnu.org/koth/"
SRC_URI="http://savannah.nongnu.org/download/${PN}/default.pkg/${PV}/${P}.tar.bz2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-LICENSE="GPL-2"
DEPEND="media-libs/libggi"
-src_install () {
+src_install() {
dodir /usr/bin
make DESTDIR=${D} install || die "make install failed"
insinto /etc/koth
diff --git a/games-action/poopmup/poopmup-1.2.ebuild b/games-action/poopmup/poopmup-1.2.ebuild
index d9c960b4655e..e6c5a12a5088 100644
--- a/games-action/poopmup/poopmup-1.2.ebuild
+++ b/games-action/poopmup/poopmup-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/poopmup/poopmup-1.2.ebuild,v 1.3 2004/03/02 14:26:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/poopmup/poopmup-1.2.ebuild,v 1.4 2004/03/16 16:03:39 vapier Exp $
inherit games gcc
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="x86 ppc"
DEPEND="virtual/glut
virtual/x11
diff --git a/games-action/powermanga/powermanga-0.78.ebuild b/games-action/powermanga/powermanga-0.78.ebuild
index 382a2ce19579..9a6e54289b31 100644
--- a/games-action/powermanga/powermanga-0.78.ebuild
+++ b/games-action/powermanga/powermanga-0.78.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/powermanga-0.78.ebuild,v 1.2 2004/02/10 06:14:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/powermanga-0.78.ebuild,v 1.3 2004/03/16 16:03:39 vapier Exp $
inherit games
@@ -8,9 +8,9 @@ DESCRIPTION="An arcade 2D shoot-em-up game"
HOMEPAGE="http://linux.tlk.fr/"
SRC_URI="http://www.tlk.fr/lesjeux/${P}.tar.gz"
-KEYWORDS="x86"
LICENSE="GPL-2"
-SLOT=0
+SLOT="0"
+KEYWORDS="x86 ppc"
IUSE=""
DEPEND="virtual/glibc
@@ -25,9 +25,9 @@ src_compile() {
src_install() {
local f
- dogamesbin powermanga || die "dogamesbin failed"
- doman powermanga.6 || die "doman failed"
- dodoc AUTHORS CHANGES README || die "dodoc failed"
+ dogamesbin powermanga || die "dogamesbin failed"
+ doman powermanga.6
+ dodoc AUTHORS CHANGES README
insinto ${GAMES_DATADIR}/powermanga/sounds
doins sounds/*
@@ -38,10 +38,8 @@ src_install() {
insinto /var/games
for f in powermanga.hi-easy powermanga.hi powermanga.hi-hard
do
- touch ${D}/var/games/${f} || \
- die "touch ${f} failed"
- fperms 664 /var/games/${f} || \
- die "fperms ${f} failed"
+ touch ${D}/var/games/${f} || die "touch ${f} failed"
+ fperms 660 /var/games/${f} || die "fperms ${f} failed"
done
prepgamesdirs