summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-06-24 04:53:45 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-06-24 04:53:45 +0000
commit5539d4bf586eda40acbe5d6a277a7e8105874373 (patch)
treec66ffbc7e463ec91692fc3c2904aefd6c8590158 /games-action
parentUSE flag change qt->qt3/qt4 bug #137785 (diff)
downloadgentoo-2-5539d4bf586eda40acbe5d6a277a7e8105874373.tar.gz
gentoo-2-5539d4bf586eda40acbe5d6a277a7e8105874373.tar.bz2
gentoo-2-5539d4bf586eda40acbe5d6a277a7e8105874373.zip
USE flag change qt->qt3/qt4 bug #137785
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/chromium/ChangeLog6
-rw-r--r--games-action/chromium/chromium-0.9.12-r5.ebuild10
-rw-r--r--games-action/chromium/chromium-0.9.12-r6.ebuild10
3 files changed, 15 insertions, 11 deletions
diff --git a/games-action/chromium/ChangeLog b/games-action/chromium/ChangeLog
index f8272c781c9a..a4703b562fc5 100644
--- a/games-action/chromium/ChangeLog
+++ b/games-action/chromium/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/chromium
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/ChangeLog,v 1.17 2006/05/20 00:16:01 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/ChangeLog,v 1.18 2006/06/24 04:53:45 cardoe Exp $
+
+ 24 Jun 2006; Doug Goldstein <cardoe@gentoo.org> chromium-0.9.12-r5.ebuild,
+ chromium-0.9.12-r6.ebuild:
+ USE flag change qt->qt3/qt4 bug #137785
*chromium-0.9.12-r6 (20 May 2006)
diff --git a/games-action/chromium/chromium-0.9.12-r5.ebuild b/games-action/chromium/chromium-0.9.12-r5.ebuild
index a499fb939dc6..ba4cf831e17c 100644
--- a/games-action/chromium/chromium-0.9.12-r5.ebuild
+++ b/games-action/chromium/chromium-0.9.12-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/chromium-0.9.12-r5.ebuild,v 1.16 2006/05/20 00:16:01 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/chromium-0.9.12-r5.ebuild,v 1.17 2006/06/24 04:53:45 cardoe Exp $
inherit flag-o-matic eutils games
@@ -12,7 +12,7 @@ SRC_URI="http://www.reptilelabour.com/software/files/chromium/chromium-src-${PV}
LICENSE="Artistic"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
-IUSE="vorbis qt sdl"
+IUSE="vorbis qt3 sdl"
DEPEND="|| ( x11-libs/libXext virtual/x11 )
|| (
@@ -21,7 +21,7 @@ DEPEND="|| ( x11-libs/libXext virtual/x11 )
virtual/glut
)
vorbis? ( media-libs/libvorbis )
- qt? ( =x11-libs/qt-3* )
+ qt3? ( =x11-libs/qt-3* )
media-libs/openal"
S=${WORKDIR}/Chromium-0.9
@@ -33,7 +33,7 @@ src_unpack() {
epatch \
"${FILESDIR}"/${PV}-gcc3-gentoo.patch \
"${FILESDIR}"/${PV}-proper-options.patch
- if use qt ; then
+ if use qt3 ; then
epatch "${FILESDIR}/${PV}-qt3.patch"
fi
append-flags -DPKGDATADIR="'\"${GAMES_DATADIR}/${PN}\"'"
@@ -61,7 +61,7 @@ src_compile() {
use vorbis \
&& export ENABLE_VORBIS="yes" \
|| export ENABLE_VORBIS="no"
- if use qt ; then
+ if use qt3 ; then
export ENABLE_SETUP="yes"
export QTDIR=/usr/qt/3
else
diff --git a/games-action/chromium/chromium-0.9.12-r6.ebuild b/games-action/chromium/chromium-0.9.12-r6.ebuild
index b7f13de09e6e..bf65d65abe48 100644
--- a/games-action/chromium/chromium-0.9.12-r6.ebuild
+++ b/games-action/chromium/chromium-0.9.12-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/chromium-0.9.12-r6.ebuild,v 1.1 2006/05/20 00:16:01 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/chromium-0.9.12-r6.ebuild,v 1.2 2006/06/24 04:53:45 cardoe Exp $
inherit flag-o-matic eutils games
@@ -12,7 +12,7 @@ SRC_URI="http://www.reptilelabour.com/software/files/chromium/chromium-src-${PV}
LICENSE="Artistic"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="vorbis qt sdl"
+IUSE="vorbis qt3 sdl"
DEPEND="|| ( x11-libs/libXext virtual/x11 )
|| (
@@ -21,7 +21,7 @@ DEPEND="|| ( x11-libs/libXext virtual/x11 )
virtual/glut
)
vorbis? ( media-libs/libvorbis )
- qt? ( =x11-libs/qt-3* )
+ qt3? ( =x11-libs/qt-3* )
~media-libs/openal-0.0.8
media-libs/freealut"
@@ -35,7 +35,7 @@ src_unpack() {
"${FILESDIR}"/${PV}-gcc3-gentoo.patch \
"${FILESDIR}"/${PV}-freealut.patch \
"${FILESDIR}"/${PV}-configure.patch
- if use qt ; then
+ if use qt3 ; then
epatch "${FILESDIR}/${PV}-qt3.patch"
fi
append-flags -DPKGDATADIR="'\"${GAMES_DATADIR}/${PN}\"'"
@@ -63,7 +63,7 @@ src_compile() {
use vorbis \
&& export ENABLE_VORBIS="yes" \
|| export ENABLE_VORBIS="no"
- if use qt ; then
+ if use qt3 ; then
export ENABLE_SETUP="yes"
export QTDIR=/usr/qt/3
else