summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-11-07 16:37:12 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-11-07 16:37:12 +0000
commitad3964443e1d4850711a371a070f5e11e1f39951 (patch)
treef099b0dce1b770606454ccc70a893e5ac12efb69 /games-action
parentRemove old (diff)
downloadgentoo-2-ad3964443e1d4850711a371a070f5e11e1f39951.tar.gz
gentoo-2-ad3964443e1d4850711a371a070f5e11e1f39951.tar.bz2
gentoo-2-ad3964443e1d4850711a371a070f5e11e1f39951.zip
version bump (bug #439256)
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/openastromenace/ChangeLog11
-rw-r--r--games-action/openastromenace/openastromenace-1.3.0.ebuild76
2 files changed, 84 insertions, 3 deletions
diff --git a/games-action/openastromenace/ChangeLog b/games-action/openastromenace/ChangeLog
index 406f7dd13a86..0c32c208d73c 100644
--- a/games-action/openastromenace/ChangeLog
+++ b/games-action/openastromenace/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/openastromenace
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/openastromenace/ChangeLog,v 1.10 2011/07/07 02:41:31 mr_bones_ Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/openastromenace/ChangeLog,v 1.11 2012/11/07 16:37:12 mr_bones_ Exp $
+
+*openastromenace-1.3.0 (07 Nov 2012)
+
+ 07 Nov 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ +openastromenace-1.3.0.ebuild:
+ version bump (bug #439256)
07 Jul 2011; Michael Sterrett <mr_bones_@gentoo.org>
openastromenace-1.2.0.ebuild:
@@ -43,4 +49,3 @@
08 May 2008; Tristan Heaven <nyhm@gentoo.org> +metadata.xml,
+openastromenace-1.2.0.ebuild:
Initial commit, bug #204530
-
diff --git a/games-action/openastromenace/openastromenace-1.3.0.ebuild b/games-action/openastromenace/openastromenace-1.3.0.ebuild
new file mode 100644
index 000000000000..d224f8730487
--- /dev/null
+++ b/games-action/openastromenace/openastromenace-1.3.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/openastromenace/openastromenace-1.3.0.ebuild,v 1.1 2012/11/07 16:37:12 mr_bones_ Exp $
+
+EAPI=4
+inherit gnome2-utils cmake-utils eutils games
+
+DESCRIPTION="Modern 3D space shooter with spaceship upgrade possibilities"
+HOMEPAGE="http://sourceforge.net/projects/openastromenace/"
+SRC_URI="mirror://sourceforge/openastromenace/${PN}-src-${PV}.tar.bz2"
+
+LICENSE="GPL-3 UbuntuFontLicense-1.0 OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl[joystick,video,X]
+ media-libs/openal
+ media-libs/freealut
+ media-libs/freetype:2
+ media-libs/libogg
+ media-libs/libvorbis
+ x11-libs/libXinerama
+ virtual/jpeg"
+
+S=${WORKDIR}/AstroMenace
+
+src_prepare() {
+ # no messing with CXXFLAGS please.
+ sed -i -e '/ADD_DEFINITIONS.*O3/d' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs="-DDATADIR=${GAMES_DATADIR}/${PN}"
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ "${CMAKE_BUILD_DIR}"/AstroMenace --pack \
+ --rawdata="${S}"/RAW_VFS_DATA \
+ --dir=$(dirname "${CMAKE_BUILD_DIR}") || die
+}
+
+src_install() {
+ newgamesbin "${CMAKE_BUILD_DIR}"/AstroMenace "${PN}"
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins ../*.vfs
+
+ newicon -s 128 astromenace_128.png ${PN}.png
+ newicon -s 64 astromenace_64.png ${PN}.png
+
+ dodoc ChangeLog.txt ReadMe.txt
+
+ make_desktop_entry "${PN}" OpenAstroMenace
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}