summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-09-24 21:51:04 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-09-24 21:51:04 +0000
commitc9d0b84d60cc807c5514014af77cc04b340d9895 (patch)
tree0d0b778858e7caecc717990fb7fa2d4f0658d5ea /games-action
parentSecurity fixes from Debian, bug #191484 (diff)
downloadgentoo-2-c9d0b84d60cc807c5514014af77cc04b340d9895.tar.gz
gentoo-2-c9d0b84d60cc807c5514014af77cc04b340d9895.tar.bz2
gentoo-2-c9d0b84d60cc807c5514014af77cc04b340d9895.zip
Crash fix by Charles Clément, bug #193343
(Portage version: 2.1.3.9)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/glaxium/ChangeLog8
-rw-r--r--games-action/glaxium/files/digest-glaxium-0.5-r13
-rw-r--r--games-action/glaxium/files/glaxium-0.5-freeglut.patch13
-rw-r--r--games-action/glaxium/glaxium-0.5-r1.ebuild43
4 files changed, 66 insertions, 1 deletions
diff --git a/games-action/glaxium/ChangeLog b/games-action/glaxium/ChangeLog
index 11d4ecd6e8c9..1765c1b334ba 100644
--- a/games-action/glaxium/ChangeLog
+++ b/games-action/glaxium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/glaxium
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/ChangeLog,v 1.15 2007/09/21 13:48:27 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/ChangeLog,v 1.16 2007/09/24 21:51:04 nyhm Exp $
+
+*glaxium-0.5-r1 (24 Sep 2007)
+
+ 24 Sep 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/glaxium-0.5-freeglut.patch, +glaxium-0.5-r1.ebuild:
+ Crash fix by Charles Clément, bug #193343
21 Sep 2007; Tristan Heaven <nyhm@gentoo.org> glaxium-0.5.ebuild:
Remove check for x11-drivers/nvidia-legacy-drivers, bug #193304
diff --git a/games-action/glaxium/files/digest-glaxium-0.5-r1 b/games-action/glaxium/files/digest-glaxium-0.5-r1
new file mode 100644
index 000000000000..0a4cbb8d38a6
--- /dev/null
+++ b/games-action/glaxium/files/digest-glaxium-0.5-r1
@@ -0,0 +1,3 @@
+MD5 ea6d6f8b4ebb7c73b74af64d83f45cb7 glaxium_0.5.tar.gz 1692219
+RMD160 5c988c53d4205ac80e0011a893a80daecf096c1f glaxium_0.5.tar.gz 1692219
+SHA256 78f5a9e1785e9e39f6dcb32134a3bd224372f572f191e7ed77bf50b109afb5f7 glaxium_0.5.tar.gz 1692219
diff --git a/games-action/glaxium/files/glaxium-0.5-freeglut.patch b/games-action/glaxium/files/glaxium-0.5-freeglut.patch
new file mode 100644
index 000000000000..4c2348d5f4ef
--- /dev/null
+++ b/games-action/glaxium/files/glaxium-0.5-freeglut.patch
@@ -0,0 +1,13 @@
+Index: glaxium_0.5/main.cpp
+===================================================================
+--- glaxium_0.5.orig/main.cpp
++++ glaxium_0.5/main.cpp
+@@ -143,7 +143,7 @@ int main( int argc, char *argv[] )
+ signal(SIGINT, exit);
+ signal(SIGTERM, exit);
+ */
+-// glutInit(&argc, argv);
++ glutInit(&argc, argv);
+
+ SDL_GL_SetAttribute(SDL_GL_STENCIL_SIZE,8);
+
diff --git a/games-action/glaxium/glaxium-0.5-r1.ebuild b/games-action/glaxium/glaxium-0.5-r1.ebuild
new file mode 100644
index 000000000000..6394b0599072
--- /dev/null
+++ b/games-action/glaxium/glaxium-0.5-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/glaxium-0.5-r1.ebuild,v 1.1 2007/09/24 21:51:04 nyhm Exp $
+
+inherit autotools eutils games
+
+DESCRIPTION="OpenGL-based space-ship shoot-em-up style game"
+HOMEPAGE="http://xhosxe.free.fr/glaxium/"
+SRC_URI="http://xhosxe.free.fr/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-mixer
+ virtual/opengl
+ virtual/glu
+ virtual/glut
+ media-libs/libpng"
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if has_version x11-drivers/nvidia-drivers ; then
+ epatch "${FILESDIR}"/${P}-glx.patch
+ fi
+ epatch \
+ "${FILESDIR}"/${PV}-rc.patch \
+ "${FILESDIR}"/${P}-gcc41.patch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-freeglut.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt CHANGES.txt
+ prepgamesdirs
+}