summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-02-19 05:31:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-02-19 05:31:47 +0000
commit8b52a922bbc7857d292077024d641a0a55699f81 (patch)
tree0fe79614379828061c7f8d3d5d9c8649a384ede6 /games-arcade/conveysdl
parentChanged make to emake for Mr_Bones. (diff)
downloadgentoo-2-8b52a922bbc7857d292077024d641a0a55699f81.tar.gz
gentoo-2-8b52a922bbc7857d292077024d641a0a55699f81.tar.bz2
gentoo-2-8b52a922bbc7857d292077024d641a0a55699f81.zip
initial commit - ebuild submitted by Alexandru Toma via bug #81635
(Portage version: 2.0.51-r15)
Diffstat (limited to 'games-arcade/conveysdl')
-rw-r--r--games-arcade/conveysdl/ChangeLog10
-rw-r--r--games-arcade/conveysdl/Manifest2
-rw-r--r--games-arcade/conveysdl/conveysdl-1.ebuild55
-rw-r--r--games-arcade/conveysdl/files/digest-conveysdl-11
-rw-r--r--games-arcade/conveysdl/metadata.xml5
5 files changed, 73 insertions, 0 deletions
diff --git a/games-arcade/conveysdl/ChangeLog b/games-arcade/conveysdl/ChangeLog
new file mode 100644
index 000000000000..094d6c935543
--- /dev/null
+++ b/games-arcade/conveysdl/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-arcade/conveysdl
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/conveysdl/ChangeLog,v 1.1 2005/02/19 05:31:47 mr_bones_ Exp $
+
+*conveysdl-1 (19 Feb 2005)
+
+ 19 Feb 2005; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+ +conveysdl-1.ebuild:
+ initial commit - ebuild submitted by Alexandru Toma via bug #81635
+
diff --git a/games-arcade/conveysdl/Manifest b/games-arcade/conveysdl/Manifest
new file mode 100644
index 000000000000..85ca7ce79c59
--- /dev/null
+++ b/games-arcade/conveysdl/Manifest
@@ -0,0 +1,2 @@
+MD5 ecddec994e264e7c7a3457a88cc1e911 conveysdl-1.ebuild 1249
+MD5 0b6b9daa99d6ce8e2f4f40b1e4594417 files/digest-conveysdl-1 63
diff --git a/games-arcade/conveysdl/conveysdl-1.ebuild b/games-arcade/conveysdl/conveysdl-1.ebuild
new file mode 100644
index 000000000000..48bad489eda9
--- /dev/null
+++ b/games-arcade/conveysdl/conveysdl-1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/conveysdl/conveysdl-1.ebuild,v 1.1 2005/02/19 05:31:47 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Guide the blob along the conveyer belt collecting the red blobs, if you miss any you go round again"
+HOMEPAGE="http://www.cloudsprinter.com/software/conveysdl/"
+# No upstream version
+#SRC_URI="http://www.cloudsprinter.com/software/conveysdl/${PN}.tar"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ >=media-libs/sdl-mixer-1.2.5"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ find gfx sounds levels -type f -exec chmod a-x \{\} \;
+
+ # Patch paths and use our CFLAGS
+ sed -i \
+ -e "s:\"\":\"\$(datadir)/\":" \
+ -e "s:-Wall:-Wall ${CFLAGS}:" \
+ Makefile || die "sed Makefile failed"
+
+ # Incomplete readme
+ sed -i \
+ -e 's:I k:use -nosound to disable sound\n\nI k:' \
+ readme || die "sed readme failed"
+
+ sed -i \
+ -e 's:SDL_Mi:SDL_mi:' \
+ src/main.c || die "sed main.c failed"
+}
+
+src_compile() {
+ emake datadir="${GAMES_DATADIR}/${PN}" || die "emake failed"
+}
+
+src_install() {
+ dogamesbin conveysdl || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r gfx sounds levels "${D}${GAMES_DATADIR}/${PN}" || die "cp failed"
+ dodoc readme
+ prepgamesdirs
+}
diff --git a/games-arcade/conveysdl/files/digest-conveysdl-1 b/games-arcade/conveysdl/files/digest-conveysdl-1
new file mode 100644
index 000000000000..93685d7c20b4
--- /dev/null
+++ b/games-arcade/conveysdl/files/digest-conveysdl-1
@@ -0,0 +1 @@
+MD5 e563d8f0659e1a555e2bd9f4dfcaa61c conveysdl-1.tar.bz2 51789
diff --git a/games-arcade/conveysdl/metadata.xml b/games-arcade/conveysdl/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/conveysdl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>