summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-04-30 22:01:07 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-04-30 22:01:07 +0000
commit3ea5daa8ec182e9ebbb174f7ea979ad8efee722e (patch)
tree7a25df0a01354d6ec140130ba039504f878c3dbd /games-arcade/gav/gav-0.9.0.ebuild
parentFix building with gcc-4.3 (diff)
downloadgentoo-2-3ea5daa8ec182e9ebbb174f7ea979ad8efee722e.tar.gz
gentoo-2-3ea5daa8ec182e9ebbb174f7ea979ad8efee722e.tar.bz2
gentoo-2-3ea5daa8ec182e9ebbb174f7ea979ad8efee722e.zip
Fix building with gcc-4.3
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'games-arcade/gav/gav-0.9.0.ebuild')
-rw-r--r--games-arcade/gav/gav-0.9.0.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/games-arcade/gav/gav-0.9.0.ebuild b/games-arcade/gav/gav-0.9.0.ebuild
index 07d6ac2e7e78..8b1680588e36 100644
--- a/games-arcade/gav/gav-0.9.0.ebuild
+++ b/games-arcade/gav/gav-0.9.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/gav/gav-0.9.0.ebuild,v 1.2 2007/04/24 14:40:37 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gav/gav-0.9.0.ebuild,v 1.3 2008/04/30 22:01:06 nyhm Exp $
inherit eutils games
@@ -35,6 +35,7 @@ src_unpack() {
cp ${d}/Makefile.Linux ${d}/Makefile || die "cp ${d}/Makefile failed"
done
+ epatch "${FILESDIR}"/${P}-gcc43.patch
sed -i \
-e "s:/usr/bin:${GAMES_BINDIR}:" \
-e "/strip/d" \
@@ -65,8 +66,9 @@ src_compile() {
src_install() {
dodir "${GAMES_BINDIR}"
- make ROOT="${D}" install || die "make install failed"
- cp -r sounds/ "${D}${GAMES_DATADIR}/${PN}" || die "cp failed"
+ emake ROOT="${D}" install || die "emake install failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r sounds || die "doins failed"
dodoc CHANGELOG README
prepgamesdirs
}