summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-07-27 19:09:51 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-07-27 19:09:51 +0000
commit21babbcf74a626a17a86f240a5d30be6387a2ac3 (patch)
tree9424932e7391e1a8f1e1e75663d36823dc91781e /games-arcade/holotz-castle
parentFix (kind of harmless) typo in haskell-cabal eclass. $CABAL_UNKNONW -> $CABAL... (diff)
downloadgentoo-2-21babbcf74a626a17a86f240a5d30be6387a2ac3.tar.gz
gentoo-2-21babbcf74a626a17a86f240a5d30be6387a2ac3.tar.bz2
gentoo-2-21babbcf74a626a17a86f240a5d30be6387a2ac3.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade/holotz-castle')
-rw-r--r--games-arcade/holotz-castle/ChangeLog9
-rw-r--r--games-arcade/holotz-castle/files/holotz-castle-1.3.14-build.patch71
-rw-r--r--games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc44.patch11
-rw-r--r--games-arcade/holotz-castle/holotz-castle-1.3.14.ebuild49
4 files changed, 139 insertions, 1 deletions
diff --git a/games-arcade/holotz-castle/ChangeLog b/games-arcade/holotz-castle/ChangeLog
index 00dda9423595..7b03190d7741 100644
--- a/games-arcade/holotz-castle/ChangeLog
+++ b/games-arcade/holotz-castle/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-arcade/holotz-castle
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/holotz-castle/ChangeLog,v 1.10 2009/07/27 18:04:51 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/holotz-castle/ChangeLog,v 1.11 2009/07/27 19:09:51 nyhm Exp $
+
+*holotz-castle-1.3.14 (27 Jul 2009)
+
+ 27 Jul 2009; Tristan Heaven <nyhm@gentoo.org>
+ +holotz-castle-1.3.14.ebuild, +files/holotz-castle-1.3.14-build.patch,
+ +files/holotz-castle-1.3.14-gcc44.patch:
+ Version bump
27 Jul 2009; Tristan Heaven <nyhm@gentoo.org> holotz-castle-1.3.10.ebuild,
+files/holotz-castle-1.3.10-gcc44.patch:
diff --git a/games-arcade/holotz-castle/files/holotz-castle-1.3.14-build.patch b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-build.patch
new file mode 100644
index 000000000000..bb834656601d
--- /dev/null
+++ b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-build.patch
@@ -0,0 +1,71 @@
+--- JLib/Makefile
++++ JLib/Makefile
+@@ -19,7 +19,7 @@
+ endif
+
+ # Define -D_JLIB_DEBUG to debug JLib. Compile the app to debug also with this flag
+-CFLAGS=-I. -I/usr/local/include/SDL -O3 -ffast-math -fPIC -Wall -Wshadow `$(SDL_CONFIG) --cflags`
++CXXFLAGS+=-I. -Wall -Wshadow `$(SDL_CONFIG) --cflags`
+
+ # Sample LDFLAGS for applications
+ # LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
+@@ -28,15 +28,14 @@
+
+ # JLib
+ libJLib: $(JLIB_OBJS)
+- g++-4.1 -shared -L/usr/lib -fPIC -o $@.so $? \
+- && ar rvus $@.a $? \
++ $(AR) rvus $@.a $?
+
+ $(GRAPHICS)/%.o: $(GRAPHICS)/%.cpp
+- g++-4.1 $(CFLAGS) -c -o $@ $<
++ $(CXX) $(CXXFLAGS) -c -o $@ $<
+ $(UTIL)/%.o: $(UTIL)/%.cpp
+- g++-4.1 $(CFLAGS) -c -o $@ $<
++ $(CXX) $(CXXFLAGS) -c -o $@ $<
+ $(MATH)/%.o: $(MATH)/%.cpp
+- g++-4.1 $(CFLAGS) -c -o $@ $<
++ $(CXX) $(CXXFLAGS) -c -o $@ $<
+
+ .PHONY: install
+ install:
+--- src/Makefile
++++ src/Makefile
+@@ -30,7 +30,7 @@
+
+ DEFINES = -DHC_DATA_DIR=\"$(HC_DATA)\" -DHCED_DATA_DIR=\"$(HCED_DATA)\"
+
+-all: JLib HC HCed
++all: HC HCed
+
+ HC_OBJ_MAIN=HolotzCastle.o
+ HC_OBJS=HCUtil.o HCTimer.o HCLoadSaveSlot.o HCPlaylist.o HCPreferences.o HCTheme.o HCText.o \
+@@ -42,23 +42,23 @@
+
+ # Definir -D_JLIB_DEBUG para debug con JLib. Ponerlo también en el Makefile de JLib.
+ # Define -D_JLIB_DEBUG for JLib debug mode. Put it also in JLib's Makefile.
+-CFLAGS=-fno-strict-aliasing -I. -I../JLib `$(SDL_CONFIG) --cflags` -I/usr/local/include/ -I/usr/local/include/SDL -O3 -Wall -Werror -Wshadow $(CPU_OPTS) -ffast-math -c
+-LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
++CXXFLAGS+=-fno-strict-aliasing -I. -I../JLib `$(SDL_CONFIG) --cflags` -Wall -Wshadow
++LDLIBS=-L. -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
+
+
+ JLib:
+ $(MAKE) -C ../JLib;
+
+ %.o: %.cpp %.h
+- g++ $(CFLAGS) $(DEFINES) $< -o $@
++ $(CXX) -c $(CXXFLAGS) $(DEFINES) $< -o $@
+
+ HC: $(HC_OBJS) $(HC_OBJ_MAIN) ../JLib/libJLib.a
+- g++ $(LDFLAGS) $? -o $@;\
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $? $(LDLIBS);\
+ mv HC ../holotz-castle
+
+ # HCed (Holotz's Castle editor).
+ HCed: $(HC_OBJS) $(HCED_OBJ_MAIN) ../JLib/libJLib.a
+- g++ $(LDFLAGS) $? -o $@;\
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $? $(LDLIBS);\
+ mv HCed ../holotz-castle-editor
+
+ install:
diff --git a/games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc44.patch b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc44.patch
new file mode 100644
index 000000000000..0c3af53591bf
--- /dev/null
+++ b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc44.patch
@@ -0,0 +1,11 @@
+--- JLib/JLib/Util/JFS.cpp
++++ JLib/JLib/Util/JFS.cpp
+@@ -887,7 +887,7 @@
+
+ // Si es un directorio lo importa recursivamente
+ struct dirent64 **namelist;
+- n = scandir64(filename, &namelist, 0, alphasort);
++ n = scandir64(filename, &namelist, 0, alphasort64);
+
+ if (n < 0)
+ {
diff --git a/games-arcade/holotz-castle/holotz-castle-1.3.14.ebuild b/games-arcade/holotz-castle/holotz-castle-1.3.14.ebuild
new file mode 100644
index 000000000000..ee149181adaa
--- /dev/null
+++ b/games-arcade/holotz-castle/holotz-castle-1.3.14.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/holotz-castle/holotz-castle-1.3.14.ebuild,v 1.1 2009/07/27 19:09:51 nyhm Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="2D platform game"
+HOMEPAGE="http://www.mainreactor.net/holotzcastle/en/index_en.html"
+SRC_URI="http://www.mainreactor.net/holotzcastle/download/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ media-libs/sdl-mixer
+ media-libs/libsdl
+ media-libs/sdl-ttf
+ media-libs/sdl-image"
+
+S=${WORKDIR}/${P}-src
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+)
+
+src_compile() {
+ tc-export AR
+ emake -C JLib || die "emake JLib failed"
+ emake -C src HC_BASE="${GAMES_DATADIR}"/${PN}/ || die "emake src failed"
+}
+
+src_install() {
+ dogamesbin holotz-castle holotz-castle-editor || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}/game
+ doins -r res/* || die "doins game failed"
+ insinto "${GAMES_DATADIR}"/${PN}/editor
+ doins -r HCedHome/res/* || die "doins editor failed"
+ newicon res/icon/icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} "Holotz's Castle" /usr/share/pixmaps/${PN}.bmp
+ make_desktop_entry ${PN}-editor "Holotz's Castle - Editor" \
+ /usr/share/pixmaps/${PN}.bmp
+ dodoc doc/MANUAL*.txt
+ doman man/*.6
+ prepgamesdirs
+}