summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-04-14 17:57:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-04-14 17:57:28 +0000
commitc39d6e56c83e4f0c25b18ab0bf8e51e23d956def (patch)
tree609db88741beb093a769e051e4327ca9d6c7abae /games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild
parentNew ebuild from nesyx, closes #79313 (diff)
downloadgentoo-2-c39d6e56c83e4f0c25b18ab0bf8e51e23d956def.tar.gz
gentoo-2-c39d6e56c83e4f0c25b18ab0bf8e51e23d956def.tar.bz2
gentoo-2-c39d6e56c83e4f0c25b18ab0bf8e51e23d956def.zip
version bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild')
-rw-r--r--games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild b/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild
new file mode 100644
index 000000000000..3748de3ebec4
--- /dev/null
+++ b/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild,v 1.1 2005/04/14 17:57:28 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Rework of Sasteroids using SDL"
+HOMEPAGE="http://sdlsas.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sdlsas/SDLSasteroids-${PV}.tar.gz"
+
+LICENSE="GPL-2 freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ virtual/opengl
+ >=media-libs/sdl-mixer-1.2.0
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-ttf"
+
+S=${WORKDIR}/SDLSasteroids-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #-e '34 d' \
+ sed -i \
+ -e 's/make /$(MAKE) /' Makefile \
+ || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake \
+ GAMEDIR="${GAMES_DATADIR}/${PN}" \
+ OPTS="${CXXFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/share/man/man6/
+ make \
+ GAMEDIR="${D}/${GAMES_DATADIR}/${PN}" \
+ BINDIR="${D}/${GAMES_BINDIR}" \
+ MANDIR="${D}/usr/share/man/" \
+ install || die "make install failed"
+ dodoc ChangeLog README README.xast TODO description
+ prepgamesdirs
+}