summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-31 01:32:34 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-31 01:32:34 +0000
commit825c47148ad67db3400fea33b889dc94d9d7bb7b (patch)
treec54aea6d4ec16019dca39764fe4ff0cebd5ddabb /games-arcade/tomatoes/tomatoes-1.55.ebuild
parentChanging driver and lib install location to be detected (Manifest recommit) (diff)
downloadgentoo-2-825c47148ad67db3400fea33b889dc94d9d7bb7b.tar.gz
gentoo-2-825c47148ad67db3400fea33b889dc94d9d7bb7b.tar.bz2
gentoo-2-825c47148ad67db3400fea33b889dc94d9d7bb7b.zip
Make sure sdl-mixer has USE=mikmod #76128.
Diffstat (limited to 'games-arcade/tomatoes/tomatoes-1.55.ebuild')
-rw-r--r--games-arcade/tomatoes/tomatoes-1.55.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/games-arcade/tomatoes/tomatoes-1.55.ebuild b/games-arcade/tomatoes/tomatoes-1.55.ebuild
index 92d3f564abfa..19805c4589c8 100644
--- a/games-arcade/tomatoes/tomatoes-1.55.ebuild
+++ b/games-arcade/tomatoes/tomatoes-1.55.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/tomatoes/tomatoes-1.55.ebuild,v 1.3 2004/12/28 10:21:16 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tomatoes/tomatoes-1.55.ebuild,v 1.4 2004/12/31 01:32:34 vapier Exp $
inherit eutils games
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/tomatoes/tomatoes-linux-src-${PV}.tar.bz2
LICENSE="ZLIB"
SLOT="0"
-KEYWORDS="~x86 ppc"
+KEYWORDS="ppc x86"
IUSE=""
DEPEND="virtual/opengl
@@ -21,6 +21,14 @@ DEPEND="virtual/opengl
>=media-libs/sdl-image-1.2.2
media-libs/sdl-mixer"
+pkg_setup() {
+ if ! built_with_use media-libs/sdl-mixer mikmod ; then
+ eerror "Tomatoes doesn't work properly if sdl-mixer"
+ eerror "is built with USE=-mikmod"
+ die "Please emerge sdl-mixer with USE=mikmod"
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"