summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-09-26 15:10:11 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-09-26 15:10:11 +0000
commit18ac1e182b9c21a8c510034ef021ca089acb9c4a (patch)
tree0b36a890024f0694594dfc1714c6890b6a73dfd4 /games-arcade
parentRemove dependency on ut2004 since this causes circular dependencies. Closing... (diff)
downloadgentoo-2-18ac1e182b9c21a8c510034ef021ca089acb9c4a.tar.gz
gentoo-2-18ac1e182b9c21a8c510034ef021ca089acb9c4a.tar.bz2
gentoo-2-18ac1e182b9c21a8c510034ef021ca089acb9c4a.zip
Added built_with_use to check that sdl-image was built with USE=gif for bug #148558.
(Portage version: 2.1.2_pre1-r2)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/project-starfighter/ChangeLog7
-rw-r--r--games-arcade/project-starfighter/project-starfighter-1.1.ebuild10
2 files changed, 15 insertions, 2 deletions
diff --git a/games-arcade/project-starfighter/ChangeLog b/games-arcade/project-starfighter/ChangeLog
index c09361ebcc43..c42c16bebe8d 100644
--- a/games-arcade/project-starfighter/ChangeLog
+++ b/games-arcade/project-starfighter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-arcade/project-starfighter
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/project-starfighter/ChangeLog,v 1.10 2006/09/20 16:48:48 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/project-starfighter/ChangeLog,v 1.11 2006/09/26 15:10:11 wolf31o2 Exp $
+
+ 26 Sep 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ project-starfighter-1.1.ebuild:
+ Added built_with_use to check that sdl-image was built with USE=gif for bug
+ #148558.
20 Sep 2006; <blubb@gentoo.org> project-starfighter-1.1.ebuild:
stable on amd64
diff --git a/games-arcade/project-starfighter/project-starfighter-1.1.ebuild b/games-arcade/project-starfighter/project-starfighter-1.1.ebuild
index 7fc3dbaa3e5d..4eff83d1d8bb 100644
--- a/games-arcade/project-starfighter/project-starfighter-1.1.ebuild
+++ b/games-arcade/project-starfighter/project-starfighter-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/project-starfighter/project-starfighter-1.1.ebuild,v 1.13 2006/09/20 16:48:48 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/project-starfighter/project-starfighter-1.1.ebuild,v 1.14 2006/09/26 15:10:11 wolf31o2 Exp $
inherit eutils games
@@ -21,6 +21,14 @@ DEPEND="media-libs/libsdl
S=${WORKDIR}/${MY_P}
+pkg_setup() {
+ games_pkg_setup
+ if ! built_with_use media-libs/sdl-image gif
+ then
+ die "You need to build media-libs/sdl-image with USE=gif!"
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"