summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-08-16 00:11:22 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-08-16 00:11:22 +0000
commit8830911b491ab42f7a976609da1b22c552205616 (patch)
treea888de7d6dce3c4a7d4759087f58d50709cd99f0 /games-arcade
parentVersion bump, security bug #481228. (diff)
downloadgentoo-2-8830911b491ab42f7a976609da1b22c552205616.tar.gz
gentoo-2-8830911b491ab42f7a976609da1b22c552205616.tar.bz2
gentoo-2-8830911b491ab42f7a976609da1b22c552205616.zip
version bump
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/commandergenius/ChangeLog8
-rw-r--r--games-arcade/commandergenius/commandergenius-1.6.0.ebuild71
-rw-r--r--games-arcade/commandergenius/files/commandergenius-1.6.0-build.patch23
3 files changed, 101 insertions, 1 deletions
diff --git a/games-arcade/commandergenius/ChangeLog b/games-arcade/commandergenius/ChangeLog
index fd732aa6f9b9..fc1a0fa34fe1 100644
--- a/games-arcade/commandergenius/ChangeLog
+++ b/games-arcade/commandergenius/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/commandergenius
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/commandergenius/ChangeLog,v 1.1 2013/05/09 12:29:33 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/commandergenius/ChangeLog,v 1.2 2013/08/16 00:11:22 hasufell Exp $
+
+*commandergenius-1.6.0 (16 Aug 2013)
+
+ 16 Aug 2013; Julian Ospald <hasufell@gentoo.org>
+ +commandergenius-1.6.0.ebuild, +files/commandergenius-1.6.0-build.patch:
+ version bump
*commandergenius-1.4.2 (09 May 2013)
diff --git a/games-arcade/commandergenius/commandergenius-1.6.0.ebuild b/games-arcade/commandergenius/commandergenius-1.6.0.ebuild
new file mode 100644
index 000000000000..ddee855a9937
--- /dev/null
+++ b/games-arcade/commandergenius/commandergenius-1.6.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/commandergenius/commandergenius-1.6.0.ebuild,v 1.1 2013/08/16 00:11:22 hasufell Exp $
+
+EAPI=5
+
+inherit cmake-utils eutils games
+
+MY_P=CGenius-${PV}-Release-Source
+DESCRIPTION="Open Source Commander Keen clone (needs original game files)"
+HOMEPAGE="http://clonekeenplus.sourceforge.net"
+SRC_URI="mirror://sourceforge/clonekeenplus/CGenius/V${PV:0:3}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="opengl tremor"
+RESTRICT="mirror" # tarball contains non-free data which we do not install
+
+RDEPEND="media-libs/libsdl[X,audio,opengl?,video]
+ media-libs/sdl-image
+ opengl? ( virtual/opengl )
+ tremor? ( media-libs/tremor )
+ !tremor? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ rm -r vfsroot || die "failed removing non-free game data"
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DAPPDIR="${GAMES_BINDIR}"
+ -DSHAREDIR="/usr/share"
+ -DGAMES_SHAREDIR="${GAMES_DATADIR}"
+ -DDOCDIR="/usr/share/doc/${PF}"
+ -DBUILD_TARGET="LINUX"
+ $(cmake-utils_use opengl OPENGL)
+ $(cmake-utils_use tremor TREMOR)
+ $(cmake-utils_use !tremor OGG)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ newicon CGLogo.png ${PN}.png
+ newgamesbin "${FILESDIR}"/commandergenius-wrapper commandergenius
+ make_desktop_entry commandergenius
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "Check your settings in ~/.CommanderGenius/cgenius.cfg"
+ elog "after you have started the game for the first time."
+ use opengl && elog "You may also want to set \"OpenGL = true\""
+ elog
+ elog "Run the game via:"
+ elog " 'commandergenius [path-to-keen-data]'"
+ elog "or add your keen data dir to the search paths in cgenius.cfg"
+}
diff --git a/games-arcade/commandergenius/files/commandergenius-1.6.0-build.patch b/games-arcade/commandergenius/files/commandergenius-1.6.0-build.patch
new file mode 100644
index 000000000000..46d2c1b1ad37
--- /dev/null
+++ b/games-arcade/commandergenius/files/commandergenius-1.6.0-build.patch
@@ -0,0 +1,23 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Thu May 9 11:51:38 UTC 2013
+Subject: fix build
+
+--- CGenius-1.4.2-Release-Source/install.cmake
++++ CGenius-1.4.2-Release-Source/install.cmake
+@@ -20,11 +20,13 @@
+ DESTINATION ${APPDIR})
+
+ # This will copy the resources files to the proper directory
+-INSTALL(DIRECTORY vfsroot/
+- DESTINATION ${DATADIR})
++IF(IS_DIRECTORY "${CMAKE_SOURCE_DIR}/vfsroot")
++ INSTALL(DIRECTORY vfsroot/
++ DESTINATION ${DATADIR})
++ENDIF(IS_DIRECTORY "${CMAKE_SOURCE_DIR}/vfsroot")
+
+ # This will copy the readme file.
+-INSTALL(FILES README
++INSTALL(FILES "${CMAKE_BINARY_DIR}/README"
+ DESTINATION ${DOCDIR})
+
+ # This will copy the readme file.