summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-06-26 18:38:03 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-06-26 18:38:03 +0000
commitb451ebfccfe1e71a3e01cbba80dcbbde6ff21e5b (patch)
treef1d1d32a8435d1dcdfff05d9ed5ddea182bfea36 /games-arcade
parentbumped EAPI to 5, converted deps to gx86-multilib, added missing deps (diff)
downloadgentoo-2-b451ebfccfe1e71a3e01cbba80dcbbde6ff21e5b.tar.gz
gentoo-2-b451ebfccfe1e71a3e01cbba80dcbbde6ff21e5b.tar.bz2
gentoo-2-b451ebfccfe1e71a3e01cbba80dcbbde6ff21e5b.zip
bumped version with new distfile, old distfile seems to no longer exist; install native 32bit / 64bit version instead of using gx86-multilib
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/gish-demo/ChangeLog8
-rw-r--r--games-arcade/gish-demo/gish-demo-1.6.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/games-arcade/gish-demo/ChangeLog b/games-arcade/gish-demo/ChangeLog
index 5571c234e5b7..a2eb69ba8743 100644
--- a/games-arcade/gish-demo/ChangeLog
+++ b/games-arcade/gish-demo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/gish-demo
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/gish-demo/ChangeLog,v 1.14 2014/05/06 16:18:43 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gish-demo/ChangeLog,v 1.15 2014/06/26 18:38:03 axs Exp $
+
+*gish-demo-1.6 (26 Jun 2014)
+
+ 26 Jun 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org> +gish-demo-1.6.ebuild:
+ bumped version with new distfile, old distfile seems to no longer exist;
+ install native 32bit / 64bit version instead of using gx86-multilib
06 May 2014; Ulrich Müller <ulm@gentoo.org> gish-demo-1.0.0.ebuild:
Fix LICENSE, add mirror and bindist restrictions, bug 505616.
diff --git a/games-arcade/gish-demo/gish-demo-1.6.ebuild b/games-arcade/gish-demo/gish-demo-1.6.ebuild
new file mode 100644
index 000000000000..ad008e40fe3c
--- /dev/null
+++ b/games-arcade/gish-demo/gish-demo-1.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gish-demo/gish-demo-1.6.ebuild,v 1.1 2014/06/26 18:38:03 axs Exp $
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Play as an amorphous ball of tar that rolls and squishes around"
+HOMEPAGE="http://www.chroniclogic.com/gish.htm"
+SRC_URI="http://s159260531.onlinehome.us/demos/gishdemo.tar.gz -> ${P}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror bindist strip"
+QA_PREBUILT="${GAMES_PREFIX_OPT:1}/${PN}/gish"
+
+RDEPEND="media-libs/libsdl
+ media-libs/libvorbis
+ virtual/opengl
+ x11-libs/libX11
+ >=media-libs/openal-1.6.372"
+
+S=${WORKDIR}/gishdemo
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ local gishbin=gishdemo
+ use amd64 && gishbin=gishdemo_64
+
+ insinto "${dir}"
+ doins -r *
+ fperms +x "${dir}"/${gishbin}
+ games_make_wrapper gish ./${gishbin} "${dir}"
+ prepgamesdirs
+}