summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-02-02 09:43:10 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-02-02 09:43:10 +0000
commitcc9a47ce3e4fce056797dcd37bcca0313b8047a8 (patch)
treef46f102155ab7dc8dff555a9512a72cafc161ffd /games-arcade
parentVersion bump. Fix: #256617 #210830 #240458 (diff)
downloadgentoo-2-cc9a47ce3e4fce056797dcd37bcca0313b8047a8.tar.gz
gentoo-2-cc9a47ce3e4fce056797dcd37bcca0313b8047a8.tar.bz2
gentoo-2-cc9a47ce3e4fce056797dcd37bcca0313b8047a8.zip
Fix --as-needed bug #247301
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 x86_64)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/holotz-castle/ChangeLog8
-rw-r--r--games-arcade/holotz-castle/files/holotz-castle-1.3.10-build.patch17
-rw-r--r--games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild9
3 files changed, 26 insertions, 8 deletions
diff --git a/games-arcade/holotz-castle/ChangeLog b/games-arcade/holotz-castle/ChangeLog
index 84aff338ccd8..d5397370f455 100644
--- a/games-arcade/holotz-castle/ChangeLog
+++ b/games-arcade/holotz-castle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/holotz-castle
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/holotz-castle/ChangeLog,v 1.8 2008/06/24 10:08:11 opfer Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/holotz-castle/ChangeLog,v 1.9 2009/02/02 09:43:10 tupone Exp $
+
+ 02 Feb 2009; Alfredo Tupone <tupone@gentoo.org>
+ files/holotz-castle-1.3.10-build.patch, holotz-castle-1.3.10.ebuild:
+ Fix --as-needed bug #247301 by flameeyes@gentoo.org
24 Jun 2008; Christian Faulhammer <opfer@gentoo.org>
holotz-castle-1.3.10.ebuild:
diff --git a/games-arcade/holotz-castle/files/holotz-castle-1.3.10-build.patch b/games-arcade/holotz-castle/files/holotz-castle-1.3.10-build.patch
index e556d76193e9..6e6136304b27 100644
--- a/games-arcade/holotz-castle/files/holotz-castle-1.3.10-build.patch
+++ b/games-arcade/holotz-castle/files/holotz-castle-1.3.10-build.patch
@@ -47,7 +47,22 @@
-CFLAGS=-I. -I../JLib -O3 -Wall -Werror -Wshadow $(CPU_OPTS) -ffast-math -c `$(SDL_CONFIG) --cflags`
-LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
+CFLAGS=-I. -I../JLib $(CPU_OPTS) -c `$(SDL_CONFIG) --cflags`
-+LDFLAGS=-L. -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
++LDLIBS=-L. -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
JLib:
+@@ -53,12 +53,12 @@
+ g++ $(CFLAGS) $(DEFINES) $< -o $@
+
+ HC: $(HC_OBJS) $(HC_OBJ_MAIN) ../JLib/libJLib.a
+- g++ $(LDFLAGS) $? -o $@;\
++ g++ $(LDFLAGS) $? $(LDLIBS) -o $@;\
+ mv HC ../holotz-castle
+
+ # HCed (Holotz's Castle editor).
+ HCed: $(HC_OBJS) $(HCED_OBJ_MAIN) ../JLib/libJLib.a
+- g++ $(LDFLAGS) $? -o $@;\
++ g++ $(LDFLAGS) $? $(LDLIBS) -o $@;\
+ mv HCed ../holotz-castle-editor
+
+ install:
diff --git a/games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild b/games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild
index 752d06f766d8..fa4de0ba4a00 100644
--- a/games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild
+++ b/games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild,v 1.3 2008/06/24 10:08:11 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild,v 1.4 2009/02/02 09:43:10 tupone Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="2d platform jump'n'run game"
@@ -21,9 +22,7 @@ DEPEND="virtual/opengl
S=${WORKDIR}/${P}-src
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-build.patch
}