summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-11-07 16:51:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-11-07 16:51:53 +0000
commit50c13bb89edc086613fcdd6fbc033bf14e1317e4 (patch)
treec5c529c88925450b810c32884420e3f3d675b103 /games-board/ace
parentversion bump (bug #439256) (diff)
downloadgentoo-2-50c13bb89edc086613fcdd6fbc033bf14e1317e4.tar.gz
gentoo-2-50c13bb89edc086613fcdd6fbc033bf14e1317e4.tar.bz2
gentoo-2-50c13bb89edc086613fcdd6fbc033bf14e1317e4.zip
add patch from Julian Ospald to link with gold linker (bug #435826)
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-board/ace')
-rw-r--r--games-board/ace/ChangeLog6
-rw-r--r--games-board/ace/ace-1.4.ebuild11
-rw-r--r--games-board/ace/files/ace-1.4-gold.patch144
3 files changed, 157 insertions, 4 deletions
diff --git a/games-board/ace/ChangeLog b/games-board/ace/ChangeLog
index bbc326622c87..9021bd1c5b6b 100644
--- a/games-board/ace/ChangeLog
+++ b/games-board/ace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/ace
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ChangeLog,v 1.25 2012/09/24 18:51:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ChangeLog,v 1.26 2012/11/07 16:51:53 mr_bones_ Exp $
+
+ 07 Nov 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/ace-1.4-gold.patch, ace-1.4.ebuild:
+ add patch from Julian Ospald to link with gold linker (bug #435826)
24 Sep 2012; Michael Sterrett <mr_bones_@gentoo.org> ace-1.4.ebuild:
add slot for libpng
diff --git a/games-board/ace/ace-1.4.ebuild b/games-board/ace/ace-1.4.ebuild
index 3c4a33390900..4aea8e3f2730 100644
--- a/games-board/ace/ace-1.4.ebuild
+++ b/games-board/ace/ace-1.4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ace-1.4.ebuild,v 1.2 2012/09/24 18:51:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ace-1.4.ebuild,v 1.3 2012/11/07 16:51:53 mr_bones_ Exp $
EAPI=2
-inherit eutils games
+inherit autotools base eutils games
DESCRIPTION="DJ Delorie's Ace of Penguins solitaire games"
HOMEPAGE="http://www.delorie.com/store/ace/"
@@ -19,7 +19,12 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
x11-proto/xproto"
-PATCHES=( "${FILESDIR}"/${P}-no-xpm.patch "${FILESDIR}"/${P}-libpng15.patch )
+PATCHES=( "${FILESDIR}"/${P}-no-xpm.patch "${FILESDIR}"/${P}-libpng15.patch "${FILESDIR}"/${P}-gold.patch )
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
src_configure() {
egamesconf \
diff --git a/games-board/ace/files/ace-1.4-gold.patch b/games-board/ace/files/ace-1.4-gold.patch
new file mode 100644
index 000000000000..62665d61b880
--- /dev/null
+++ b/games-board/ace/files/ace-1.4-gold.patch
@@ -0,0 +1,144 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Tue Sep 25 13:18:57 UTC 2012
+Subject: build system
+
+fix gold linker compilation
+https://bugs.gentoo.org/show_bug.cgi?id=435826
+
+--- configure.in
++++ configure.in
+@@ -44,6 +44,9 @@
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
++AC_PATH_PROG([PKGCONFIG], [pkg-config])
++AS_IF([test "x$PKGCONFIG" = "x"],
++ [AC_MSG_ERROR([pkg-config not found!])])
+
+ AC_CHECK_PROGS(BUILD_CC,gcc cc ${CC},gcc)
+ AC_CHECK_PROG(AR,${AR:-ar},${AR:-ar},ar)
+@@ -55,6 +58,10 @@
+ dnl doesn't work if gd isn't where the compiler can find it
+ dnl AC_CHECK_LIB(gd, gdImageCreateFromGif)
+
++PKG_CHECK_MODULES([X], [x11])
++PKG_CHECK_MODULES([Z], [zlib])
++PKG_CHECK_MODULES([PNG], [libpng])
++
+ dnl Checks for header files.
+
+ AC_PATH_XTRA
+@@ -69,57 +76,6 @@
+ AC_FUNC_UTIME_NULL
+ AC_CHECK_FUNCS(gettimeofday mkdir strdup strstr)
+
+-opt_gd=
+-AC_ARG_WITH(z,[ --with-z=DIR location of the ZLIB library],opt_z=$withval)
+-AC_ARG_WITH(png,[ --with-png=DIR location of the PNG library],opt_png=$withval)
+-
+-case "$with_z" in
+- yes|no) AC_MSG_ERROR([
+-*** Directory must be specified for --with-z])
+- ;;
+- "")
+- Z_CFLAGS=
+- Z_LIBS=-lz
+- ;;
+- *)
+- if test -f $with_z/include/z.h
+- then
+- Z_CFLAGS=-I$with_z/include
+- else
+- Z_CFLAGS=-I$with_z
+- fi
+- if test -f $with_z/lib/libz.a
+- then
+- Z_LIBS=$with_z/lib/libz.a
+- else
+- Z_LIBS=$with_z/libz.a
+- fi
+- ;;
+-esac
+-
+-case "$with_png" in
+- yes|no) AC_MSG_ERROR([
+-*** Directory must be specified for --with-png])
+- ;;
+- "")
+- PNG_CFLAGS=
+- PNG_LIBS=
+- ;;
+- *)
+- if test -f $with_png/lib/png.h
+- then
+- PNG_CFLAGS=-I$with_png/lib
+- else
+- PNG_CFLAGS=-I$with_png/include/X11
+- fi
+- if test -f $with_png/lib/libPng.a
+- then
+- PNG_LIBS="-L$with_png/lib"
+- else
+- PNG_LIBS="-L$with_png"
+- fi
+- ;;
+-esac
+
+ AC_SUBST(Z_CFLAGS)
+ AC_SUBST(Z_LIBS)
+@@ -127,6 +83,9 @@
+ AC_SUBST(PNG_CFLAGS)
+ AC_SUBST(PNG_LIBS)
+
++AC_SUBST(X_LIBS)
++AC_SUBST(X_CFLAGS)
++
+ AC_SUBST(PDA)
+
+ AC_OUTPUT(Makefile lib/Makefile games/Makefile tests/Makefile)
+--- lib/Makefile.am
++++ lib/Makefile.am
+@@ -5,18 +5,19 @@
+
+ CLEANFILES = images.c images.d
+
+-INCLUDES = $(X_CFLAGS) @PDA@
+-AM_LDFLAGS = $(X_LIBS)
++INCLUDES = $(X_CFLAGS) $(PNG_CFLAGS) $(Z_CFLAGS) @PDA@
+
+ BUILD_CC = @BUILD_CC@
+ AR = @AR@
+ STRIP = @STRIP@
+
+-libcards_la_LDFLAGS = -version-info 1:0:0 $(AM_LDFLAGS)
++libcards_la_LDFLAGS = -version-info 1:0:0
+
+ libcards_la_SOURCES = table.c help.c stack.c imagelib.c xwin.c \
+ images.c table_rn.c funcs.c
+
++libcards_la_LIBADD = $(X_LIBS) $(PNG_LIBS) $(Z_LIBS)
++
+ # table_ai.c table_ck.c table_dc.c table_dg.c \
+ #table_dp.c table_in.c table_ky.c table_rd.c table_rs.c
+
+--- games/Makefile.am
++++ games/Makefile.am
+@@ -30,8 +30,7 @@
+
+ STRIP = @STRIP@
+
+-INCLUDES = -I$(srcdir)/../lib $(X_CFLAGS) @PDA@
+-AM_LDFLAGS = $(X_LIBS)
++INCLUDES = -I$(srcdir)/../lib @PDA@
+
+ canfield_SOURCES = canfield.c canfield-img.c
+ freecell_SOURCES = freecell.c freecell-help.c freecell-img.c
+@@ -52,7 +51,7 @@
+ solitaire-help.c solitaire-img.c spider-help.c spider-img.c \
+ taipedit-help.c taipedit-img.c taipei-help.c taipei-img.c
+
+-LDADD = ../lib/libcards.la -lpng -lz -lX11 -lm
++LDADD = ../lib/libcards.la -lm
+
+ EXTRA_DIST = $(wildcard *.png) $(wildcard *.tp)
+