summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-01-23 19:45:38 +0000
committerUlrich Müller <ulm@gentoo.org>2014-01-23 19:45:38 +0000
commit2f020ead587d6e6ade6496e3253d07c18e440cd6 (patch)
tree769cf5db08339f93130a01ad1c84e5a630be5d29 /games-board/capicity
parentRemove obsolete dev-perl/PDL[proj] entry. (diff)
downloadgentoo-2-2f020ead587d6e6ade6496e3253d07c18e440cd6.tar.gz
gentoo-2-2f020ead587d6e6ade6496e3253d07c18e440cd6.tar.bz2
gentoo-2-2f020ead587d6e6ade6496e3253d07c18e440cd6.zip
QA: Package move to all-lowercase name, according to naming policy.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'games-board/capicity')
-rw-r--r--games-board/capicity/ChangeLog59
-rw-r--r--games-board/capicity/capicity-1.0.ebuild68
-rw-r--r--games-board/capicity/metadata.xml5
3 files changed, 132 insertions, 0 deletions
diff --git a/games-board/capicity/ChangeLog b/games-board/capicity/ChangeLog
new file mode 100644
index 000000000000..1e84c92f5f1b
--- /dev/null
+++ b/games-board/capicity/ChangeLog
@@ -0,0 +1,59 @@
+# ChangeLog for games-board/capicity
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/capicity/ChangeLog,v 1.1 2014/01/23 19:45:38 ulm Exp $
+
+*capicity-1.0 (23 Jan 2014)
+
+ 23 Jan 2014; Ulrich Müller <ulm@gentoo.org> +capicity-1.0.ebuild,
+ +metadata.xml:
+ QA: Package move to all-lowercase name, according to naming policy.
+
+*CapiCity-1.0 (23 Jan 2014)
+
+ 23 Jan 2014; Julian Ospald <hasufell@gentoo.org> +CapiCity-1.0.ebuild,
+ +metadata.xml:
+ version bump and rename of games-board/capitalism
+
+ 02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> capitalism-0.5.1.ebuild:
+ Move Qt dependencies to the new category
+
+ 15 Jan 2011; Markus Meier <maekke@gentoo.org> capitalism-0.5.1.ebuild:
+ x86 stable, bug #350445
+
+*capitalism-0.5.1 (03 Dec 2010)
+
+ 03 Dec 2010; Tupone Alfredo <tupone@gentoo.org> +capitalism-0.5.1.ebuild,
+ +files/capitalism-0.5.1-qt47.patch:
+ Version bump to 0.5.1 Bug #306013 by hitachi
+
+ 30 Nov 2010; Markus Meier <maekke@gentoo.org> capitalism-0.2-r1.ebuild:
+ x86 stable, bug #347203
+
+*capitalism-0.2-r1 (23 Oct 2010)
+
+ 23 Oct 2010; Markos Chandras <hwoarang@gentoo.org>
+ +capitalism-0.2-r1.ebuild, +files/capitalism-0.2-qt47.patch:
+ Patch to build against Qt-4.7. Bug #338497. Migrated to qt4-r2
+
+ 08 Feb 2010; Christian Faulhammer <fauli@gentoo.org>
+ capitalism-0.2.ebuild:
+ stable x86, bug 302369
+
+*capitalism-0.2 (27 Dec 2009)
+
+ 27 Dec 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +capitalism-0.2.ebuild:
+ Version bump.
+
+ 24 Dec 2009; Pacho Ramos <pacho@gentoo.org> capitalism-0.1.ebuild:
+ amd64 stable, bug 295904
+
+ 09 Dec 2009; Christian Faulhammer <fauli@gentoo.org>
+ capitalism-0.1.ebuild:
+ stable x86, bug 295904
+
+*capitalism-0.1 (05 Nov 2009)
+
+ 05 Nov 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +capitalism-0.1.ebuild:
+ Initial commit.
diff --git a/games-board/capicity/capicity-1.0.ebuild b/games-board/capicity/capicity-1.0.ebuild
new file mode 100644
index 000000000000..d290347da985
--- /dev/null
+++ b/games-board/capicity/capicity-1.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/capicity/capicity-1.0.ebuild,v 1.1 2014/01/23 19:45:38 ulm Exp $
+
+EAPI=5
+inherit eutils gnome2-utils qmake-utils games
+
+DESCRIPTION="A monopd compatible boardgame to play Monopoly-like games (previously named capitalism)"
+HOMEPAGE="http://linux-ecke.de/CapiCity/"
+SRC_URI="dedicated? ( mirror://sourceforge/project/capitalism/Capi%20City/${PV}/Capid_${PV}.tar.gz )
+ !dedicated? ( mirror://sourceforge/project/capitalism/Capi%20City/${PV}/CapiCity_${PV}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated"
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtscript:4
+ !dedicated? ( dev-qt/qtgui:4 )"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ default
+ S=${WORKDIR}/$(usex dedicated Capid CapiCity)_${PV}
+}
+
+src_configure() {
+ if use dedicated ; then
+ eqmake4 Capid.pro
+ else
+ eqmake4 CapiCity.pro
+ fi
+}
+
+src_install() {
+ local res
+
+ if use dedicated ; then
+ dogamesbin Capid
+ dodoc doc/*
+ else
+ dogamesbin CapiCity
+ dodoc changelog README
+
+ for res in 16 22 24 32 48 64; do
+ newicon -s ${res} icons/${res}x${res}.png ${PN}.png
+ done
+
+ make_desktop_entry CapiCity "Capi City"
+ fi
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ use dedicated || gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ use dedicated || gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ use dedicated || gnome2_icon_cache_update
+}
diff --git a/games-board/capicity/metadata.xml b/games-board/capicity/metadata.xml
new file mode 100644
index 000000000000..cad5a2aa1773
--- /dev/null
+++ b/games-board/capicity/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+</pkgmetadata>