summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-11 15:35:26 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-11 15:35:26 +0000
commitac69885e77bc08651a3429458204518f760067a0 (patch)
treee057eaba59fca66a13e34c01761ac734359ed830 /games-board/ggz-gtk-client
parentAdd games-board/ggz-gtk-client:gaim (diff)
downloadgentoo-2-ac69885e77bc08651a3429458204518f760067a0.tar.gz
gentoo-2-ac69885e77bc08651a3429458204518f760067a0.tar.bz2
gentoo-2-ac69885e77bc08651a3429458204518f760067a0.zip
Add gaim use flag and fix install paths
(Portage version: 2.1.2_pre2-r8)
Diffstat (limited to 'games-board/ggz-gtk-client')
-rw-r--r--games-board/ggz-gtk-client/ChangeLog6
-rw-r--r--games-board/ggz-gtk-client/files/ggz-gtk-client-0.0.13-gaim.patch59
-rw-r--r--games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild50
3 files changed, 101 insertions, 14 deletions
diff --git a/games-board/ggz-gtk-client/ChangeLog b/games-board/ggz-gtk-client/ChangeLog
index 4234e572ec94..322fac9d14ef 100644
--- a/games-board/ggz-gtk-client/ChangeLog
+++ b/games-board/ggz-gtk-client/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/ggz-gtk-client
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ggz-gtk-client/ChangeLog,v 1.14 2006/07/18 21:48:42 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/ggz-gtk-client/ChangeLog,v 1.15 2006/10/11 15:35:26 nyhm Exp $
+
+ 11 Oct 2006; Tristan Heaven <nyhm@gentoo.org>
+ +files/ggz-gtk-client-0.0.13-gaim.patch, ggz-gtk-client-0.0.13.ebuild:
+ Add gaim use flag and fix install paths
18 Jul 2006; Michael Hanselmann <hansmi@gentoo.org>
ggz-gtk-client-0.0.13.ebuild:
diff --git a/games-board/ggz-gtk-client/files/ggz-gtk-client-0.0.13-gaim.patch b/games-board/ggz-gtk-client/files/ggz-gtk-client-0.0.13-gaim.patch
new file mode 100644
index 000000000000..3f7e0045fb44
--- /dev/null
+++ b/games-board/ggz-gtk-client/files/ggz-gtk-client-0.0.13-gaim.patch
@@ -0,0 +1,59 @@
+--- configure.ac
++++ configure.ac
+@@ -28,8 +28,23 @@
+
+ dnl Gaim plugin check
+ dnl =================
+-AC_GAIM
+-
++AC_ARG_ENABLE([gaim],
++ AC_HELP_STRING([--enable-gaim], [build gaim plugin]),,
++ [enable_gaim=no])
++
++if test x$enable_gaim = xyes ; then
++ PKG_CHECK_MODULES(GAIM, [gaim])
++
++ GAIM_LIBDIR=`pkg-config --variable=libdir gaim`
++ GAIM_DATADIR=`pkg-config --variable=datadir gaim`
++ GAIMPLUGIN=gaim-plugin
++
++ AC_SUBST(GAIM_CFLAGS)
++ AC_SUBST(GAIM_LIBS)
++ AC_SUBST(GAIM_LIBDIR)
++ AC_SUBST(GAIM_DATADIR)
++ AC_SUBST(GAIMPLUGIN)
++fi
+
+ dnl Check for header files
+ dnl ======================
+@@ -118,7 +133,7 @@
+ echo " GDB Debugging......$enable_debug_gdb"
+ echo " Dmalloc Debugging..$enable_debug_mem"
+ echo ""
+-echo " Gaim plugin........$have_gaim"
++echo " Gaim plugin........$enable_gaim"
+ echo ""
+ echo "At the prompt type \"make\" to compile the GGZ gtk client"
+ echo ""
+
+--- gaim-plugin/Makefile.am
++++ gaim-plugin/Makefile.am
+@@ -1,15 +1,15 @@
+ ## Process this file with automake to produce Makefile.in
+ # $Id: ggz-gtk-client-0.0.13-gaim.patch,v 1.1 2006/10/11 15:35:26 nyhm Exp $
+
+-plugindir = $(libdir)/gaim
++plugindir = @GAIM_LIBDIR@/gaim
+
+ plugin_LTLIBRARIES = ggzgaim.la
+
+ ggzgaim_la_SOURCES = simple.c
+ ggzgaim_la_LDFLAGS = -module -avoid-version @GTK_CFLAGS@ $(LIBGGZ_LDFLAGS)
+-ggzgaim_la_LIBADD = @GTK_LIBS@ $(LIB_GGZ)
++ggzgaim_la_LIBADD = @GTK_LIBS@ @GAIM_LIBS@ $(LIB_GGZ)
+
+-AM_CPPFLAGS = @GTK_CFLAGS@ $(LIBGGZ_INCLUDES)
++AM_CPPFLAGS = @GTK_CFLAGS@ @GAIM_CFLAGS@ $(LIBGGZ_INCLUDES)
+
+ EXTRA_DIST = ggz.xpm
+
diff --git a/games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild b/games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild
index cfd235410b44..1c69eb7a4cba 100644
--- a/games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild
+++ b/games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild,v 1.5 2006/09/28 20:57:25 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild,v 1.6 2006/10/11 15:35:26 nyhm Exp $
-inherit eutils games
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+inherit autotools eutils games
DESCRIPTION="The gtk client for the GGZ Gaming Zone"
HOMEPAGE="http://www.ggzgamingzone.org/"
@@ -12,26 +14,48 @@ SRC_URI="http://ftp.belnet.be/packages/ggzgamingzone/ggz/${PV}/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-amd64 ppc x86"
-IUSE=""
+IUSE="gaim"
+RESTRICT="userpriv"
-DEPEND="~dev-games/ggz-client-libs-0.0.13
- =x11-libs/gtk+-2*"
+RDEPEND="~dev-games/ggz-client-libs-${PV}
+ =x11-libs/gtk+-2*
+ virtual/libintl
+ gaim? ( =net-im/gaim-1.5* )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig"
-src_compile() {
- local myconf="--enable-gtk=gtk2"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gaim.patch
+
+ sed -i '/desktopdir/s:$(datadir):/usr/share:' \
+ Makefile.am || die "sed Makefile.am failed"
+
+ eautoreconf
+
+ sed -i 's:$(includedir):/usr/include:' \
+ ggz-gtk/Makefile.in || die "sed Makefile.in failed"
+ sed -i '/locale/s:$(prefix):/usr:' \
+ po/Makefile.in || die "sed configure.ac failed"
+}
+
+src_compile() {
egamesconf \
- --enable-gtk=gtk2 \
--disable-debug \
+ $(use_enable gaim) \
|| die
- emake || die
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ dodir /usr/include
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rmdir "${D}/${GAMES_PREFIX}"/include
+
dodoc AUTHORS ChangeLog NEWS QuickStart.GGZ README* TODO
- domenu ${D}/usr/share/games/applications/ggz-gtk.desktop
- rm -rf ${D}/usr/share/games
prepgamesdirs
}
-