summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-05-14 01:37:41 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-05-14 01:37:41 +0000
commitbad2a4e30f4e33b1d3b632c04b01f827e9346f5c (patch)
tree635ac9d5f7670e9dd8a6574f1896876ded36e529 /games-board/gmchess
parentupdate to latest Debian patch (bug #387575) with ebuild patch from Ben Kohler (diff)
downloadgentoo-2-bad2a4e30f4e33b1d3b632c04b01f827e9346f5c.tar.gz
gentoo-2-bad2a4e30f4e33b1d3b632c04b01f827e9346f5c.tar.bz2
gentoo-2-bad2a4e30f4e33b1d3b632c04b01f827e9346f5c.zip
EAPI=5; fix file locations (bug #412705)
(Portage version: 2.1.11.62/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-board/gmchess')
-rw-r--r--games-board/gmchess/ChangeLog11
-rw-r--r--games-board/gmchess/files/gmchess-0.29.6-gentoo.patch46
-rw-r--r--games-board/gmchess/gmchess-0.29.6-r1.ebuild59
3 files changed, 113 insertions, 3 deletions
diff --git a/games-board/gmchess/ChangeLog b/games-board/gmchess/ChangeLog
index 9d2d9568fbf5..fb742f3afc57 100644
--- a/games-board/gmchess/ChangeLog
+++ b/games-board/gmchess/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/gmchess
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gmchess/ChangeLog,v 1.4 2012/02/16 19:15:48 phajdan.jr Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/gmchess/ChangeLog,v 1.5 2013/05/14 01:37:41 mr_bones_ Exp $
+
+*gmchess-0.29.6-r1 (14 May 2013)
+
+ 14 May 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/gmchess-0.29.6-gentoo.patch, +gmchess-0.29.6-r1.ebuild:
+ EAPI=5; fix file locations (bug #412705)
16 Feb 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> gmchess-0.29.6.ebuild:
x86 stable wrt bug #401815
@@ -16,4 +22,3 @@
31 Dec 2011; Michael Sterrett <mr_bones_@gentoo.org> +gmchess-0.29.6.ebuild,
+metadata.xml:
initial commit - ebuild submitted by Samuel BAUER via bug #391733
-
diff --git a/games-board/gmchess/files/gmchess-0.29.6-gentoo.patch b/games-board/gmchess/files/gmchess-0.29.6-gentoo.patch
new file mode 100644
index 000000000000..0952cda306b1
--- /dev/null
+++ b/games-board/gmchess/files/gmchess-0.29.6-gentoo.patch
@@ -0,0 +1,46 @@
+diff -ru gmchess-0.29.6.orig/configure.in gmchess-0.29.6/configure.in
+--- gmchess-0.29.6.orig/configure.in 2011-11-28 07:22:56.000000000 -0500
++++ gmchess-0.29.6/configure.in 2013-05-13 21:30:38.103817044 -0400
+@@ -4,7 +4,7 @@
+ AC_PREREQ([2.63])
+ AC_INIT(gmchess, 0.29.6, lerosua@gmail.com)
+ AC_CONFIG_SRCDIR([src/Pgnfile.cc])
+-AM_CONFIG_HEADER([config.h])
++AC_CONFIG_HEADERS([config.h])
+ AM_INIT_AUTOMAKE(gmchess,0.29.6)
+
+
+diff -ru gmchess-0.29.6.orig/data/gmchess.desktop.in gmchess-0.29.6/data/gmchess.desktop.in
+--- gmchess-0.29.6.orig/data/gmchess.desktop.in 2009-09-07 08:08:47.000000000 -0400
++++ gmchess-0.29.6/data/gmchess.desktop.in 2013-05-13 21:30:19.444462390 -0400
+@@ -1,4 +1,3 @@
+-
+ [Desktop Entry]
+ Name=Chinese chess
+ Name[zh_CN]=天书棋谈
+@@ -10,4 +9,3 @@
+ Type=Application
+ Categories=GNOME;GTK;Game;BoardGame;
+ StartupNotify=true
+-Encoding=UTF-8
+diff -ru gmchess-0.29.6.orig/src/engine/eleeye.cpp gmchess-0.29.6/src/engine/eleeye.cpp
+--- gmchess-0.29.6.orig/src/engine/eleeye.cpp 2011-10-26 08:01:39.000000000 -0400
++++ gmchess-0.29.6/src/engine/eleeye.cpp 2013-05-13 21:30:19.445462355 -0400
+@@ -35,7 +35,7 @@
+ #elif __linux__
+ #include <dlfcn.h>
+ #define WINAPI
+- const char *const cszLibEvalFile = "../lib/libeval.so.0";
++ const char *const cszLibEvalFile = "GAMES_LIBDIR/libeval.so.0";
+ #elif __APPLE__
+ #include <dlfcn.h>
+ const char *const cszLibEvalFile = "/usr/local/lib/libeval.0.dylib";
+@@ -125,7 +125,7 @@
+ if (BootLine() != UCCI_COMM_UCCI) {
+ return 0;
+ }
+- LocatePath(Search.szBookFile, "../share/gmchess/book.dat");
++ LocatePath(Search.szBookFile, "GAMES_DATADIR/book.dat");
+ //LocatePath(Search.szBookFile, "book.dat");
+ LocatePath(szLibEvalFile, cszLibEvalFile);
+ hModule = LoadEvalApi(szLibEvalFile);
diff --git a/games-board/gmchess/gmchess-0.29.6-r1.ebuild b/games-board/gmchess/gmchess-0.29.6-r1.ebuild
new file mode 100644
index 000000000000..c2b29bebf959
--- /dev/null
+++ b/games-board/gmchess/gmchess-0.29.6-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/gmchess/gmchess-0.29.6-r1.ebuild,v 1.1 2013/05/14 01:37:41 mr_bones_ Exp $
+
+EAPI=5
+inherit autotools libtool gnome2-utils games
+
+DESCRIPTION="Chinese chess with gtkmm and c++"
+HOMEPAGE="http://code.google.com/p/gmchess/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+RESTRICT="test"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-cpp/gtkmm:2.4"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:GAMES_LIBDIR:${GAMES_LIBDIR}:" \
+ -e "s:GAMES_DATADIR:${GAMES_DATADIR}:" \
+ src/engine/eleeye.cpp || die
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-static \
+ --localedir='/usr/share/locale'
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ itlocaledir='/usr/share/locale' \
+ pixmapsdir='/usr/share/pixmaps' \
+ desktopdir='/usr/share/applications' \
+ install
+ dodoc AUTHORS NEWS README
+ prune_libtool_files
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}