summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-05-30 15:53:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-05-30 15:53:23 +0000
commit60f8173cd9b9c6d3dbd461f6a750f413079a8bc9 (patch)
tree63001bed55dd991b702d05ed28ef7a27e8b484fc /games-board/pioneers
parenthandle mingw64 targets in the libc cross-compiler logic #417793 by Matt Whitlock (diff)
downloadgentoo-2-60f8173cd9b9c6d3dbd461f6a750f413079a8bc9.tar.gz
gentoo-2-60f8173cd9b9c6d3dbd461f6a750f413079a8bc9.tar.bz2
gentoo-2-60f8173cd9b9c6d3dbd461f6a750f413079a8bc9.zip
version bump
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'games-board/pioneers')
-rw-r--r--games-board/pioneers/ChangeLog7
-rw-r--r--games-board/pioneers/pioneers-14.1.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/games-board/pioneers/ChangeLog b/games-board/pioneers/ChangeLog
index c0a76b0e3169..2503c8c5fccb 100644
--- a/games-board/pioneers/ChangeLog
+++ b/games-board/pioneers/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/pioneers
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pioneers/ChangeLog,v 1.25 2012/05/04 04:30:10 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pioneers/ChangeLog,v 1.26 2012/05/30 15:53:23 mr_bones_ Exp $
+
+*pioneers-14.1 (30 May 2012)
+
+ 30 May 2012; Michael Sterrett <mr_bones_@gentoo.org> +pioneers-14.1.ebuild:
+ version bump
04 May 2012; Jeff Horelick <jdhore@gentoo.org> pioneers-0.12.3.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/games-board/pioneers/pioneers-14.1.ebuild b/games-board/pioneers/pioneers-14.1.ebuild
new file mode 100644
index 000000000000..ac601f4ba45e
--- /dev/null
+++ b/games-board/pioneers/pioneers-14.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pioneers/pioneers-14.1.ebuild,v 1.1 2012/05/30 15:53:23 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils gnome2
+
+DESCRIPTION="A clone of the popular board game The Settlers of Catan"
+HOMEPAGE="http://pio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pio/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/glib-2.6:2
+ >=gnome-base/libgnome-2.10
+ >=x11-libs/gtk+-2.6:2
+ >=app-text/scrollkeeper-0.3.8
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ gnome2_src_compile $(use_enable nls)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README TODO NEWS" \
+ gnome2_src_install scrollkeeper_localstate_dir="${D}"/var/lib/scrollkeeper/
+}