summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-06-05 05:01:29 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-06-05 05:01:29 +0000
commit50943b45da8f1488ff7b1b88a0ba80ec68e6fd53 (patch)
treeb7eff1a1d258929578177213fb4f17c0571cc3c7 /games-board/pouetchess
parentMarked ~hppa (bug #163285). (diff)
downloadgentoo-2-50943b45da8f1488ff7b1b88a0ba80ec68e6fd53.tar.gz
gentoo-2-50943b45da8f1488ff7b1b88a0ba80ec68e6fd53.tar.bz2
gentoo-2-50943b45da8f1488ff7b1b88a0ba80ec68e6fd53.zip
Add segfaults patch from Debian for bug #180427
(Portage version: 2.1.2.9)
Diffstat (limited to 'games-board/pouetchess')
-rw-r--r--games-board/pouetchess/ChangeLog8
-rw-r--r--games-board/pouetchess/files/digest-pouetchess-0.2.0-r13
-rw-r--r--games-board/pouetchess/files/pouetchess-0.2.0-segfaults.patch44
-rw-r--r--games-board/pouetchess/pouetchess-0.2.0-r1.ebuild72
4 files changed, 126 insertions, 1 deletions
diff --git a/games-board/pouetchess/ChangeLog b/games-board/pouetchess/ChangeLog
index 915904c682ba..35375f5b2712 100644
--- a/games-board/pouetchess/ChangeLog
+++ b/games-board/pouetchess/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/pouetchess
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pouetchess/ChangeLog,v 1.6 2007/04/29 22:17:57 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pouetchess/ChangeLog,v 1.7 2007/06/05 05:01:29 nyhm Exp $
+
+*pouetchess-0.2.0-r1 (05 Jun 2007)
+
+ 05 Jun 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/pouetchess-0.2.0-segfaults.patch, +pouetchess-0.2.0-r1.ebuild:
+ Add segfaults patch from Debian for bug #180427
29 Apr 2007; Tristan Heaven <nyhm@gentoo.org>
files/pouetchess-0.2.0-sconstruct-sandbox.patch:
diff --git a/games-board/pouetchess/files/digest-pouetchess-0.2.0-r1 b/games-board/pouetchess/files/digest-pouetchess-0.2.0-r1
new file mode 100644
index 000000000000..d5dc5c702be3
--- /dev/null
+++ b/games-board/pouetchess/files/digest-pouetchess-0.2.0-r1
@@ -0,0 +1,3 @@
+MD5 c0454aca11ead9be724d769c521120b1 pouetchess_src_0.2.0.tar.gz 1055338
+RMD160 29611b78ef75b3707ad98752055da775335c0490 pouetchess_src_0.2.0.tar.gz 1055338
+SHA256 fe966ff1b0aa2dd6d0ca2b62692f5b788e3a286050a6a374e58ca0612f68b2ef pouetchess_src_0.2.0.tar.gz 1055338
diff --git a/games-board/pouetchess/files/pouetchess-0.2.0-segfaults.patch b/games-board/pouetchess/files/pouetchess-0.2.0-segfaults.patch
new file mode 100644
index 000000000000..46b27b71d47e
--- /dev/null
+++ b/games-board/pouetchess/files/pouetchess-0.2.0-segfaults.patch
@@ -0,0 +1,44 @@
+--- src/faile/search.c
++++ src/faile/search.c
+@@ -805,6 +805,7 @@
+ for (j = 0; j < indent; j++) {
+ fputc (' ', output);
+ }
++ void print_move (move_s moves[], int m, FILE *stream);
+ print_move (&moves[0], i, output);
+ fprintf (output, "\n");
+
+--- src/faile/utils.c
++++ src/faile/utils.c
+@@ -125,7 +125,7 @@
+ rank (target) < 1 || rank (target) > 8 ||
+ file (target) < 1 || file (target) > 8)
+ {
+- sprintf (str, "*** FAILE INTERNAL ERROR ***");
++ sprintf (str, "xxxx");
+ return;
+ }
+
+--- src/main.cpp
++++ src/main.cpp
+@@ -184,6 +184,9 @@
+ // first scene is SCENE_INIT.
+ pGlobalInfos->SetCurrentScene(GAME_SCENE_INIT);
+
++ /* @FB 02/08/06 */
++ pGlobalInfos->ReleaseKeys();
++
+ // main game loop
+ while( pGlobalInfos->IsGameRunning() )
+ {
+--- src/scene_main_game.cpp
++++ src/scene_main_game.cpp
+@@ -245,7 +245,7 @@
+
+ if (pGlobalInfos->OnLeftMouseButtonDown())
+ {
+- if (chessboard->clickOnChessBoard(mouseX,mouseY,&sqX,&sqY));
++ if (chessboard->clickOnChessBoard(mouseX,mouseY,&sqX,&sqY))
+ {
+ // if a piece was already selected, this means the player want to move this piece
+ if (SquareXSelected>-1 && SquareZSelected>-1)
diff --git a/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild b/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..6d3afabc0bf0
--- /dev/null
+++ b/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild,v 1.1 2007/06/05 05:01:29 nyhm Exp $
+
+inherit eutils toolchain-funcs games
+
+MY_PN=${PN/c/C}
+DESCRIPTION="3D and open source chess game"
+HOMEPAGE="http://pouetchess.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_src_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="debug"
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ dev-util/scons"
+
+S=${WORKDIR}/${PN}_src_${PV}
+
+pkg_setup() {
+ games_pkg_setup
+ einfo "If you experience problems building pouetchess with nvidia drivers,"
+ einfo "you can try:"
+ einfo "eselect opengl set xorg-x11"
+ einfo "emerge pouetchess"
+ einfo "eselect opengl set nvidia"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${P}-sconstruct-sandbox.patch \
+ "${FILESDIR}"/${P}-nvidia_glext.patch \
+ "${FILESDIR}"/${P}-segfaults.patch
+
+ # Fix for LibSDL >= 1.2.10 detection
+ sed -i \
+ -e "s:sdlver.split('.') >= \['1','2','8'\]:sdlver.split('.') >= [1,2,8]:" \
+ pouetChess.py \
+ || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC CXX
+ scons configure \
+ strip=false \
+ prefix="${GAMES_PREFIX}" \
+ datadir="${GAMES_DATADIR}"/${PN} \
+ $(use debug && echo debug=1) \
+ || die "scons configure failed"
+ scons || die "scons failed"
+}
+
+src_install() {
+ dogamesbin bin/${MY_PN} || die "dogamesbin failed"
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/* || die "doins failed"
+
+ dodoc ChangeLog README
+
+ doicon data/icons/${MY_PN}.png
+ make_desktop_entry ${MY_PN} ${MY_PN} ${MY_PN}.png "KDE;Qt;Game;BoardGame"
+
+ prepgamesdirs
+}