summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-21 20:24:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-21 20:24:26 +0000
commitb7038b3ff1778412120a4b8c57e60795433dcd70 (patch)
tree68b7d9daffaece950d1a6bc477d532cbd853e27f /games-board/scid
parentFix bug 54541: set ttymouse=xterm2 when running in xterm. Additionally comment (diff)
downloadgentoo-2-b7038b3ff1778412120a4b8c57e60795433dcd70.tar.gz
gentoo-2-b7038b3ff1778412120a4b8c57e60795433dcd70.tar.bz2
gentoo-2-b7038b3ff1778412120a4b8c57e60795433dcd70.zip
version bump (bug #49346) - ebuild provided by Gene Ruebsamen
Diffstat (limited to 'games-board/scid')
-rw-r--r--games-board/scid/ChangeLog7
-rw-r--r--games-board/scid/Manifest2
-rw-r--r--games-board/scid/files/digest-scid-3.6.15
-rw-r--r--games-board/scid/scid-3.6.1.ebuild53
4 files changed, 66 insertions, 1 deletions
diff --git a/games-board/scid/ChangeLog b/games-board/scid/ChangeLog
index 40eaecb3d76a..54f8319b61f8 100644
--- a/games-board/scid/ChangeLog
+++ b/games-board/scid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/scid
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/scid/ChangeLog,v 1.6 2004/03/30 18:38:43 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/scid/ChangeLog,v 1.7 2004/06/21 20:24:26 mr_bones_ Exp $
+
+*scid-3.6.1 (21 Jun 2004)
+
+ 21 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> scid-3.6.1.ebuild:
+ version bump (bug #49346) - ebuild provided by Gene Ruebsamen
30 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> scid-3.5.ebuild:
buggy makefiles bug #46110
diff --git a/games-board/scid/Manifest b/games-board/scid/Manifest
index d817ba1ddfcb..78ec0d8511ff 100644
--- a/games-board/scid/Manifest
+++ b/games-board/scid/Manifest
@@ -1,4 +1,6 @@
MD5 818ed65224c401f9c57243091d1ed079 ChangeLog 987
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 984d392c2ec4975e90d12a1ae17ba87d scid-3.5.ebuild 1401
+MD5 2a78430dd7679c1f33fc5dd30cc7e432 scid-3.6.1.ebuild 1356
MD5 5077b69510a8f93737858b5f66a24167 files/digest-scid-3.5 307
+MD5 98ccde6f6d31a508fa3128d9b6e8d489 files/digest-scid-3.6.1 308
diff --git a/games-board/scid/files/digest-scid-3.6.1 b/games-board/scid/files/digest-scid-3.6.1
new file mode 100644
index 000000000000..123605e26f00
--- /dev/null
+++ b/games-board/scid/files/digest-scid-3.6.1
@@ -0,0 +1,5 @@
+MD5 3c9483a7990a2629a35a787c1c29eee0 scid-3.6.1.tar.gz 2272946
+MD5 1f585e7012627e9ebd82a17d5c5766dd scid-extras-08232002.tar.bz2 1209029
+MD5 e60ed5c51ba07adba2f9b3e2f8bb43a9 photos.zip 1007488
+MD5 c8c01faf59786c228772e998911242b1 ratings.zip 969347
+MD5 88fa5d5d38b1b5c34ede70f89d82703d scidlet40k.zip 242632
diff --git a/games-board/scid/scid-3.6.1.ebuild b/games-board/scid/scid-3.6.1.ebuild
new file mode 100644
index 000000000000..d4f2d7865457
--- /dev/null
+++ b/games-board/scid/scid-3.6.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/scid/scid-3.6.1.ebuild,v 1.1 2004/06/21 20:24:26 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="a free chess database application"
+HOMEPAGE="http://scid.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scid/${P}.tar.gz
+ http://www.visi.com/~veldy/gentoo/scid-extras-08232002.tar.bz2
+ mirror://sourceforge/scid/photos.zip
+ mirror://sourceforge/scid/ratings.zip
+ mirror://sourceforge/scid/scidlet40k.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 alpha ppc sparc amd64"
+IUSE=""
+
+DEPEND="virtual/glibc
+ virtual/x11
+ >=dev-lang/tk-8.3
+ >=sys-libs/zlib-1.1.3"
+RDEPEND="${DEPEND}
+ >=dev-lang/python-2.1"
+
+src_compile() {
+ ./configure \
+ COMPILE=c++ \
+ LINK=c++ \
+ BINDIR=/usr/bin \
+ OPTIMIZE="${CXXFLAGS}" \
+ TCL_INCLUDE=""
+
+ # buggy makefiles bug #46110
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dogamesbin pgnfix pgnscid sc_addmove sc_eco sc_epgn sc_import sc_remote \
+ sc_spell sc_tree scid scidpgn scmerge spliteco tcscid tkscid scidlet \
+ || die "dogamesbin failed"
+
+ dodoc CHANGES README THANKS
+ dohtml help/*.html
+
+ cd "${WORKDIR}"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins scidlet40k.sbk gm.spf historic.spf ratings.ssp scid.eco \
+ || die "doins failed"
+
+ prepgamesdirs
+}