summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-02-22 13:54:59 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-02-22 13:54:59 +0000
commitdce6a02b3da95df13c5a591511bf0af5fe26e353 (patch)
tree6e22bb0271abb083d7bf77198db47da0c485d012 /games-board/scid
parentChanged LICENSE from GPL-2 to BSD. Fixes bug 398565. Remove old. (diff)
downloadgentoo-2-dce6a02b3da95df13c5a591511bf0af5fe26e353.tar.gz
gentoo-2-dce6a02b3da95df13c5a591511bf0af5fe26e353.tar.bz2
gentoo-2-dce6a02b3da95df13c5a591511bf0af5fe26e353.zip
Parallel make should work now. Bug #296958
(Portage version: 2.1.10.48/cvs/Linux i686)
Diffstat (limited to 'games-board/scid')
-rw-r--r--games-board/scid/ChangeLog8
-rw-r--r--games-board/scid/files/scid-4.2.2-parallelmake.patch11
-rw-r--r--games-board/scid/scid-4.2.2.ebuild7
3 files changed, 21 insertions, 5 deletions
diff --git a/games-board/scid/ChangeLog b/games-board/scid/ChangeLog
index 6462e12173ba..6479b050ce7e 100644
--- a/games-board/scid/ChangeLog
+++ b/games-board/scid/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/scid
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/scid/ChangeLog,v 1.31 2010/10/18 13:48:42 tupone Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/scid/ChangeLog,v 1.32 2012/02/22 13:54:59 tupone Exp $
+
+ 22 Feb 2012; Tupone Alfredo <tupone@gentoo.org> scid-4.2.2.ebuild,
+ +files/scid-4.2.2-parallelmake.patch:
+ Parallel make should work now. Bug #296958 by Diego Elio Petteno'
18 Oct 2010; Tupone Alfredo <tupone@gentoo.org> scid-4.2.2.ebuild:
Respect LDFLAGS. Bug #332833 by flameeyes@gentoo.org
diff --git a/games-board/scid/files/scid-4.2.2-parallelmake.patch b/games-board/scid/files/scid-4.2.2-parallelmake.patch
new file mode 100644
index 000000000000..e5bcae6c9cde
--- /dev/null
+++ b/games-board/scid/files/scid-4.2.2-parallelmake.patch
@@ -0,0 +1,11 @@
+--- Makefile.conf.old 2012-02-22 14:12:51.280071808 +0100
++++ Makefile.conf 2012-02-22 14:13:15.432372323 +0100
+@@ -379,7 +379,7 @@
+
+ scmerge: src/scmerge.o src/misc.o src/index.o src/date.o src/namebase.o \
+ src/gfile.o src/bytebuf.o src/textbuf.o src/myassert.o \
+- src/stralloc.o src/position.o
++ src/stralloc.o src/position.o $(OBJS)
+ $(LINK) -o scmerge src/scmerge.o $(OBJS) $(ZLIB) $(TCL_LIBRARY)
+
+ pgnscid: src/pgnscid.o $(OBJS)
diff --git a/games-board/scid/scid-4.2.2.ebuild b/games-board/scid/scid-4.2.2.ebuild
index c54617b668ea..a1ea112d33b8 100644
--- a/games-board/scid/scid-4.2.2.ebuild
+++ b/games-board/scid/scid-4.2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/scid/scid-4.2.2.ebuild,v 1.8 2010/10/18 13:48:42 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/scid/scid-4.2.2.ebuild,v 1.9 2012/02/22 13:54:59 tupone Exp $
EAPI=2
PYTHON_DEPEND="2"
@@ -34,7 +34,8 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-parallelmake.patch
sed -i \
-e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
tcl/config.tcl \