summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-03-18 02:56:31 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-03-18 02:56:31 +0000
commit47724e51cd1d49e75198923870610add929a126c (patch)
tree5e2699af2bcb58f09a6e012650b61f6acfe9c43a /games-board
parentAdd ~amd64 keyword (diff)
downloadgentoo-2-47724e51cd1d49e75198923870610add929a126c.tar.gz
gentoo-2-47724e51cd1d49e75198923870610add929a126c.tar.bz2
gentoo-2-47724e51cd1d49e75198923870610add929a126c.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/openyahtzee/ChangeLog7
-rw-r--r--games-board/openyahtzee/openyahtzee-1.8.1.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/games-board/openyahtzee/ChangeLog b/games-board/openyahtzee/ChangeLog
index b60d9aec739e..bee116134c5d 100644
--- a/games-board/openyahtzee/ChangeLog
+++ b/games-board/openyahtzee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/openyahtzee
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/openyahtzee/ChangeLog,v 1.5 2008/02/29 19:01:35 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/openyahtzee/ChangeLog,v 1.6 2008/03/18 02:56:31 nyhm Exp $
+
+*openyahtzee-1.8.1 (18 Mar 2008)
+
+ 18 Mar 2008; Tristan Heaven <nyhm@gentoo.org> +openyahtzee-1.8.1.ebuild:
+ Version bump
29 Feb 2008; Carsten Lohrke <carlo@gentoo.org> openyahtzee-1.7.ebuild,
openyahtzee-1.8.ebuild:
diff --git a/games-board/openyahtzee/openyahtzee-1.8.1.ebuild b/games-board/openyahtzee/openyahtzee-1.8.1.ebuild
new file mode 100644
index 000000000000..26cfab0560e2
--- /dev/null
+++ b/games-board/openyahtzee/openyahtzee-1.8.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/openyahtzee/openyahtzee-1.8.1.ebuild,v 1.1 2008/03/18 02:56:31 nyhm Exp $
+
+inherit wxwidgets games
+
+DESCRIPTION="A full-featured wxWidgets version of the classic dice game Yahtzee"
+HOMEPAGE="http://openyahtzee.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="=x11-libs/wxGTK-2.8*
+ =dev-db/sqlite-3*"
+
+pkg_setup() {
+ games_pkg_setup
+ WX_GTK_VER=2.8 need-wxwidgets unicode
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i "s:wx-config:${WX_CONFIG}:" src/Makefile.in || die "sed failed"
+}
+
+src_compile() {
+ egamesconf --datadir=/usr/share || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog TODO
+ prepgamesdirs
+}