summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-11-07 04:11:59 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-11-07 04:11:59 +0000
commit6369c7a1004a55942b24d463b5bf3060ee8fb52d (patch)
tree40cc9cfc00403be683bf4a1b4e5f3b98f0895285 /games-board
parentVersion bump. Linux 2.6.24-rc2 (diff)
downloadgentoo-2-6369c7a1004a55942b24d463b5bf3060ee8fb52d.tar.gz
gentoo-2-6369c7a1004a55942b24d463b5bf3060ee8fb52d.tar.bz2
gentoo-2-6369c7a1004a55942b24d463b5bf3060ee8fb52d.zip
tidy
(Portage version: 2.1.3.16)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/freedoko/freedoko-0.7.3.ebuild32
1 files changed, 18 insertions, 14 deletions
diff --git a/games-board/freedoko/freedoko-0.7.3.ebuild b/games-board/freedoko/freedoko-0.7.3.ebuild
index 74249948770b..3b44960343ff 100644
--- a/games-board/freedoko/freedoko-0.7.3.ebuild
+++ b/games-board/freedoko/freedoko-0.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/freedoko/freedoko-0.7.3.ebuild,v 1.5 2007/03/12 13:47:01 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/freedoko/freedoko-0.7.3.ebuild,v 1.6 2007/11/07 04:11:59 mr_bones_ Exp $
inherit eutils games
@@ -32,28 +32,32 @@ S=${WORKDIR}/FreeDoko_${PV}
src_unpack() {
unpack FreeDoko_${PV}.src.zip
cd "${S}"
- edos2unix "${S}"/src/Makefile.rules
- epatch "${FILESDIR}"/portage-cxx.patch
- epatch "${FILESDIR}"/Fix_Cardset_Make.patch
+ edos2unix src/Makefile.rules
+ epatch \
+ "${FILESDIR}"/portage-cxx.patch \
+ "${FILESDIR}"/Fix_Cardset_Make.patch
use !doc && epatch "${FILESDIR}"/nodoc.patch
use !net && epatch "${FILESDIR}"/nonet.patch
- sed -i -e 's/linux binary/Gentoo '${ARCH}' binary/g' Makefile
+ sed -i \
+ -e 's/linux binary/Gentoo '${ARCH}' binary/g' \
+ Makefile \
+ || die "sed failed"
- cd ${S}/data/cardsets
+ cd data/cardsets
use xskatcards && unpack xskat.zip
use kdecards && unpack kdecarddecks.zip
use pysolcards && unpack pysol.zip
if use xskatcards || use kdecards || use pysolcards ; then
- use altenburgcards || rm -r Altenburg
+ use altenburgcards || rm -r Altenburg
fi
if use !altenburgcards && use !xskatcards && use !kdecards && use !pysolcards ; then
- ewarn "You did not choose any cardset!"
- ewarn "I will install the cardset xskat"
- ewarn "You may change your mind and hit"
- ewarn "CTRL+C NOW to choose the cardsets"
- ewarn "with the USE-Flags"
- ebeep
- rm -r Altenburg && unpack xskat.zip
+ ewarn "You did not choose any cardset!"
+ ewarn "I will install the cardset xskat"
+ ewarn "You may change your mind and hit"
+ ewarn "CTRL+C NOW to choose the cardsets"
+ ewarn "with the USE-Flags"
+ ebeep
+ rm -r Altenburg && unpack xskat.zip
fi
}