summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-08-21 19:44:10 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-08-21 19:44:10 +0000
commit712aba0b15e9d75d27376d66b61d66f7ee22998c (patch)
tree8f9fe68d6b01e4a7fa020157f49688b6a220dde4 /games-board
parentUpstream changed hard link for emacs binary to symbolic link. Remove the syml... (diff)
downloadgentoo-2-712aba0b15e9d75d27376d66b61d66f7ee22998c.tar.gz
gentoo-2-712aba0b15e9d75d27376d66b61d66f7ee22998c.tar.bz2
gentoo-2-712aba0b15e9d75d27376d66b61d66f7ee22998c.zip
fix underlinking issues wrt #418349
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pokerth/ChangeLog6
-rw-r--r--games-board/pokerth/files/pokerth-0.9.5-underlinking.patch17
-rw-r--r--games-board/pokerth/pokerth-0.9.5.ebuild4
3 files changed, 25 insertions, 2 deletions
diff --git a/games-board/pokerth/ChangeLog b/games-board/pokerth/ChangeLog
index d10f8598e420..38bec718012d 100644
--- a/games-board/pokerth/ChangeLog
+++ b/games-board/pokerth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/pokerth
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.39 2012/08/16 08:37:46 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.40 2012/08/21 19:44:10 hasufell Exp $
+
+ 21 Aug 2012; Julian Ospald <hasufell@gentoo.org> pokerth-0.9.5.ebuild,
+ +files/pokerth-0.9.5-underlinking.patch:
+ fix underlinking issues wrt #418349
16 Aug 2012; Johannes Huber <johu@gentoo.org> pokerth-0.9.5.ebuild:
Stable for x86, wrt bug #430282
diff --git a/games-board/pokerth/files/pokerth-0.9.5-underlinking.patch b/games-board/pokerth/files/pokerth-0.9.5-underlinking.patch
new file mode 100644
index 000000000000..3ff9ab2dd685
--- /dev/null
+++ b/games-board/pokerth/files/pokerth-0.9.5-underlinking.patch
@@ -0,0 +1,17 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Thu Aug 16 22:25:12 UTC 2012
+Subject: build system
+
+fix compilation for linkers that don't permit underlinking
+
+--- pokerth_server.pro
++++ pokerth_server.pro
+@@ -114,7 +114,7 @@
+ LIBS += -lpokerth_lib \
+ -lpokerth_db \
+ -lpokerth_protocol \
+- -lcurl \
++ $$system(pkg-config --libs --static libcurl) \
+ -lircclient
+
+ win32 {
diff --git a/games-board/pokerth/pokerth-0.9.5.ebuild b/games-board/pokerth/pokerth-0.9.5.ebuild
index cf142a74483a..bfc23f64c3a7 100644
--- a/games-board/pokerth/pokerth-0.9.5.ebuild
+++ b/games-board/pokerth/pokerth-0.9.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.9.5.ebuild,v 1.3 2012/08/16 08:37:46 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.9.5.ebuild,v 1.4 2012/08/21 19:44:10 hasufell Exp $
EAPI=2
inherit flag-o-matic eutils qt4-r2 games
@@ -46,6 +46,8 @@ src_prepare() {
*pro \
|| die 'sed failed'
+ epatch "${FILESDIR}"/${P}-underlinking.patch
+
local boost_ver=$(best_version ">=dev-libs/boost-1.41")
boost_ver=${boost_ver/*boost-/}