summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-10-30 21:31:46 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-10-30 21:31:46 +0000
commite81af367beba3aa3ef4ae4a432ed4986e930c2b1 (patch)
treedffdbdd546bff33a26b8c17bfac5738438187d53 /games-board
parentRemove vulnerabe versions wrt bug #197306. (diff)
downloadgentoo-2-e81af367beba3aa3ef4ae4a432ed4986e930c2b1.tar.gz
gentoo-2-e81af367beba3aa3ef4ae4a432ed4986e930c2b1.tar.bz2
gentoo-2-e81af367beba3aa3ef4ae4a432ed4986e930c2b1.zip
Version bump to 1.8
(Portage version: 2.1.3.9)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/mah-jong/ChangeLog9
-rw-r--r--games-board/mah-jong/files/digest-mah-jong-1.83
-rw-r--r--games-board/mah-jong/mah-jong-1.8.ebuild52
3 files changed, 62 insertions, 2 deletions
diff --git a/games-board/mah-jong/ChangeLog b/games-board/mah-jong/ChangeLog
index 3d15dc3e52e8..7612818fafc3 100644
--- a/games-board/mah-jong/ChangeLog
+++ b/games-board/mah-jong/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/mah-jong
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/ChangeLog,v 1.9 2006/12/28 00:59:28 nyhm Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/ChangeLog,v 1.10 2007/10/30 21:31:45 tupone Exp $
+
+*mah-jong-1.8 (30 Oct 2007)
+
+ 30 Oct 2007; Tupone Alfredo <tupone@gentoo.org> +mah-jong-1.8.ebuild:
+ Version bump
28 Dec 2006; Tristan Heaven <nyhm@gentoo.org> mah-jong-1.7.ebuild:
Install desktop entry, bug #159205
diff --git a/games-board/mah-jong/files/digest-mah-jong-1.8 b/games-board/mah-jong/files/digest-mah-jong-1.8
new file mode 100644
index 000000000000..d12b0638a07a
--- /dev/null
+++ b/games-board/mah-jong/files/digest-mah-jong-1.8
@@ -0,0 +1,3 @@
+MD5 327379e386fea93b166dfe85b3d2f0c1 mj-1.8-src.tar.gz 370814
+RMD160 25c9375ad8fdae3d47c5e4062456608ea6e6b9f3 mj-1.8-src.tar.gz 370814
+SHA256 b27d7ec12be5efa705998de84421cfbe9f57dcaa2e3a1ebf1918f2c077c54c11 mj-1.8-src.tar.gz 370814
diff --git a/games-board/mah-jong/mah-jong-1.8.ebuild b/games-board/mah-jong/mah-jong-1.8.ebuild
new file mode 100644
index 000000000000..bc0d8a32e3e0
--- /dev/null
+++ b/games-board/mah-jong/mah-jong-1.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/mah-jong-1.8.ebuild,v 1.1 2007/10/30 21:31:45 tupone Exp $
+
+inherit eutils toolchain-funcs games
+
+MY_P="mj-${PV}-src"
+DESCRIPTION="A networked Mah Jong program, together with a computer player"
+HOMEPAGE="http://www.stevens-bradfield.com/MahJong/"
+SRC_URI="http://www.stevens-bradfield.com/MahJong/Source/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="=x11-libs/gtk+-1.2*"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e '/^.TH/ s/1/6/' xmj.man \
+ || die "sed failed"
+ sed -i \
+ -e "/^DESTDIR =/ s:=.*:= ${D}:" \
+ -e "/^BINDIR =/ s:=.*:= ${GAMES_BINDIR}:" \
+ -e '/^MANDIR =/ s:man/man1:/usr/share/man/man6:' \
+ -e '/^MANSUFFIX =/ s:1:6:' \
+ -e "/^CC =/ s:gcc:$(tc-getCC):" \
+ -e "/^CFLAGS =/ s:=:= ${CFLAGS}:" \
+ -e "/^LDLIBS =/ s:$:${LDFLAGS}:" \
+ -e '/^INSTPGMFLAGS =/ s:-s::' \
+ -e '/^CDEBUGFLAGS =/d' \
+ -e "/^TILESETPATH=/ s:NULL:\"${GAMES_DATADIR}/${PN}/\":" Makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ emake install install.man || die "emake install failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r fallbacktiles/ tiles-numbered/ tiles-small/ || die "doins failed"
+ newicon tiles-v1/tongE.xpm ${PN}.xpm
+ make_desktop_entry xmj Mah-Jong ${PN}.xpm
+ dodoc CHANGES ChangeLog *.txt
+ prepgamesdirs
+}