summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-07-27 21:20:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-07-27 21:20:11 +0000
commit7cc5691c62b3b192495af35e65618c2dfd11e89a (patch)
treeda6c733144eb2797df108b52d3a22381590193c4 /games-emulation/advancemame
parentstable bump for x86 (diff)
downloadgentoo-2-7cc5691c62b3b192495af35e65618c2dfd11e89a.tar.gz
gentoo-2-7cc5691c62b3b192495af35e65618c2dfd11e89a.tar.bz2
gentoo-2-7cc5691c62b3b192495af35e65618c2dfd11e89a.zip
version bump (bug #139799)
(Portage version: 2.1.1_pre3-r5)
Diffstat (limited to 'games-emulation/advancemame')
-rw-r--r--games-emulation/advancemame/ChangeLog8
-rw-r--r--games-emulation/advancemame/advancemame-0.106.0.ebuild92
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.106.03
3 files changed, 102 insertions, 1 deletions
diff --git a/games-emulation/advancemame/ChangeLog b/games-emulation/advancemame/ChangeLog
index b50f2260d2d3..e7f268d1d49f 100644
--- a/games-emulation/advancemame/ChangeLog
+++ b/games-emulation/advancemame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/advancemame
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.38 2006/05/09 05:32:03 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.39 2006/07/27 21:20:11 mr_bones_ Exp $
+
+*advancemame-0.106.0 (27 Jul 2006)
+
+ 27 Jul 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +advancemame-0.106.0.ebuild:
+ version bump (bug #139799)
09 May 2006; Joseph Jezak <josejx@gentoo.org> advancemame-0.104.0.ebuild:
Added fix for bug #78030.
diff --git a/games-emulation/advancemame/advancemame-0.106.0.ebuild b/games-emulation/advancemame/advancemame-0.106.0.ebuild
new file mode 100644
index 000000000000..4ec3cfc5016e
--- /dev/null
+++ b/games-emulation/advancemame/advancemame-0.106.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.106.0.ebuild,v 1.1 2006/07/27 21:20:11 mr_bones_ Exp $
+
+inherit eutils flag-o-matic games
+
+DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
+HOMEPAGE="http://advancemame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
+
+LICENSE="GPL-2 XMAME"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="alsa expat fbcon oss sdl slang static svga truetype zlib"
+
+RDEPEND="app-arch/unzip
+ app-arch/zip
+ sdl? ( media-libs/libsdl )
+ slang? ( sys-libs/slang )
+ alsa? ( media-libs/alsa-lib )
+ expat? ( >=dev-libs/expat-1.95.6 )
+ zlib? ( sys-libs/zlib )
+ truetype? ( media-libs/freetype )
+ svga? ( >=media-libs/svgalib-1.9 )"
+DEPEND="${RDEPEND}
+ x86? ( >=dev-lang/nasm-0.98 )
+ virtual/os-headers"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e 's/"-s"//' \
+ configure \
+ || die "sed failed"
+
+ use x86 && \
+ ln -s $(which nasm) "${T}/${CHOST}-nasm"
+ use sdl && \
+ ln -s $(which sdl-config) "${T}/${CHOST}-sdl-config"
+ use truetype && \
+ ln -s $(which freetype-config) "${T}/${CHOST}-freetype-config"
+}
+
+src_compile() {
+ # Fix for bug #78030
+ if use ppc; then
+ append-ldflags "-Wl,--relax"
+ fi
+
+ PATH="${PATH}:${T}"
+ egamesconf \
+ $(use_enable alsa) \
+ $(use_enable expat) \
+ $(use_enable fbcon fb) \
+ $(use_enable oss) \
+ $(use_enable sdl) \
+ $(use_enable slang) \
+ $(use_enable static) \
+ $(use_enable svga svgalib) \
+ $(use_enable truetype freetype) \
+ $(use_enable zlib) \
+ $(use_enable x86 asm) \
+ --with-emu=${PN/advance} \
+ || die
+ STRIPPROG=true emake || die "emake failed"
+}
+
+src_install() {
+ local f
+
+ for f in adv* ; do
+ if [ -L "${f}" ] ; then
+ dogamesbin "${f}" || die "dogamesbin failed"
+ fi
+ done
+
+ insinto "${GAMES_DATADIR}/advance"
+ doins support/event.dat
+ keepdir "${GAMES_DATADIR}/advance/"{artwork,diff,image,rom,sample,snap}
+
+ dodoc HISTORY README RELEASE
+ cd doc
+ dodoc *.txt
+ dohtml *.html
+ for f in *.1 ; do
+ newman ${f} ${f/1/6}
+ done
+
+ prepgamesdirs
+}
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.106.0 b/games-emulation/advancemame/files/digest-advancemame-0.106.0
new file mode 100644
index 000000000000..dc1a5ed83e2c
--- /dev/null
+++ b/games-emulation/advancemame/files/digest-advancemame-0.106.0
@@ -0,0 +1,3 @@
+MD5 aa097a4a9046124e17aa83a215e454ea advancemame-0.106.0.tar.gz 16284344
+RMD160 f18a3a328dc2634ade1ca64731d4108d06364f94 advancemame-0.106.0.tar.gz 16284344
+SHA256 2752b16ccbff2eb04b36ab4152901b9e483ef84f780b80596fb5fd1495bf6425 advancemame-0.106.0.tar.gz 16284344