summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-10-17 03:37:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-10-17 03:37:45 +0000
commit834721362f1986e12cf7cede11db8621b7c6eb2d (patch)
tree619908be100aeb974c28cffb6d3c8b82f2e5dea1 /games-emulation/advancemame
parentMarked ppc stable. (diff)
downloadgentoo-2-834721362f1986e12cf7cede11db8621b7c6eb2d.tar.gz
gentoo-2-834721362f1986e12cf7cede11db8621b7c6eb2d.tar.bz2
gentoo-2-834721362f1986e12cf7cede11db8621b7c6eb2d.zip
version bump
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'games-emulation/advancemame')
-rw-r--r--games-emulation/advancemame/ChangeLog8
-rw-r--r--games-emulation/advancemame/Manifest2
-rw-r--r--games-emulation/advancemame/advancemame-0.101.0.ebuild83
-rw-r--r--games-emulation/advancemame/files/0.101.0-pic.patch13
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.101.01
5 files changed, 106 insertions, 1 deletions
diff --git a/games-emulation/advancemame/ChangeLog b/games-emulation/advancemame/ChangeLog
index 379c5b98e609..fb92708aee84 100644
--- a/games-emulation/advancemame/ChangeLog
+++ b/games-emulation/advancemame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/advancemame
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.34 2005/10/10 02:02:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.35 2005/10/17 03:37:45 mr_bones_ Exp $
+
+*advancemame-0.101.0 (17 Oct 2005)
+
+ 17 Oct 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/0.101.0-pic.patch, +advancemame-0.101.0.ebuild:
+ version bump
*advancemame-0.100.0 (10 Oct 2005)
diff --git a/games-emulation/advancemame/Manifest b/games-emulation/advancemame/Manifest
index b22c1ba94e56..6fdb756e741c 100644
--- a/games-emulation/advancemame/Manifest
+++ b/games-emulation/advancemame/Manifest
@@ -2,8 +2,10 @@ MD5 9fb91056beb8b98def1946df1dd1c091 advancemame-0.97.0.ebuild 1992
MD5 1cd2f47f08128d77ce8d0f1ef3e05192 advancemame-0.99.0.ebuild 1995
MD5 972b8c9f939a33a7074e0819fb55455c metadata.xml 962
MD5 6c8ebaf2682fcb3a3e4f5d1040ea6a52 advancemame-0.100.0.ebuild 1996
+MD5 eef8ea94c0d763dfc4db0db1a62b4dbf advancemame-0.101.0.ebuild 1983
MD5 73210106ed2497874205595599dc4568 ChangeLog 6351
MD5 63958a71d7c2fd25aad23a633abb03de files/digest-advancemame-0.100.0 73
+MD5 6cb88ba34b78dc9a265b2b68bf084a66 files/digest-advancemame-0.101.0 73
MD5 893791a430019a7eb1c0eaf15758a93f files/0.95.0-pic.patch 344
MD5 893791a430019a7eb1c0eaf15758a93f files/0.99.0-pic.patch 344
MD5 893791a430019a7eb1c0eaf15758a93f files/0.100.0-pic.patch 344
diff --git a/games-emulation/advancemame/advancemame-0.101.0.ebuild b/games-emulation/advancemame/advancemame-0.101.0.ebuild
new file mode 100644
index 000000000000..5b3fc6ca2339
--- /dev/null
+++ b/games-emulation/advancemame/advancemame-0.101.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.101.0.ebuild,v 1.1 2005/10/17 03:37:45 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
+HOMEPAGE="http://advancemame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
+
+LICENSE="GPL-2 XMAME"
+SLOT="0"
+KEYWORDS="~amd64 -ppc x86"
+IUSE="alsa expat fbcon oss sdl slang static svga truetype zlib"
+
+RDEPEND="app-arch/unzip
+ app-arch/zip
+ sdl? ( media-libs/libsdl )
+ slang? ( sys-libs/slang )
+ alsa? ( media-libs/alsa-lib )
+ expat? ( >=dev-libs/expat-1.95.6 )
+ zlib? ( sys-libs/zlib )
+ truetype? ( media-libs/freetype )
+ svga? ( >=media-libs/svgalib-1.9 )"
+DEPEND="${RDEPEND}
+ x86? ( >=dev-lang/nasm-0.98 )
+ virtual/os-headers"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #epatch "${FILESDIR}/${PV}-pic.patch" #74899
+
+ use x86 && \
+ ln -s $(which nasm) "${T}/${CHOST}-nasm"
+ use sdl && \
+ ln -s $(which sdl-config) "${T}/${CHOST}-sdl-config"
+ use truetype && \
+ ln -s $(which freetype-config) "${T}/${CHOST}-freetype-config"
+}
+
+src_compile() {
+ PATH="${PATH}:${T}"
+ egamesconf \
+ $(use_enable alsa) \
+ $(use_enable expat) \
+ $(use_enable fbcon fb) \
+ $(use_enable oss) \
+ $(use_enable sdl) \
+ $(use_enable slang) \
+ $(use_enable static) \
+ $(use_enable svga svgalib) \
+ $(use_enable truetype freetype) \
+ $(use_enable zlib) \
+ $(use_enable x86 asm) \
+ --with-emu=${PN/advance} \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ local f
+
+ for f in adv* ; do
+ if [ -L "${f}" ] ; then
+ dogamesbin "${f}" || die "dogamesbin failed"
+ fi
+ done
+
+ insinto "${GAMES_DATADIR}/advance"
+ doins support/event.dat
+ keepdir "${GAMES_DATADIR}/advance/"{artwork,diff,image,rom,sample,snap}
+
+ dodoc HISTORY README RELEASE
+ cd doc
+ dodoc *.txt
+ dohtml *.html
+ for f in *.1 ; do
+ newman ${f} ${f/1/6}
+ done
+
+ prepgamesdirs
+}
diff --git a/games-emulation/advancemame/files/0.101.0-pic.patch b/games-emulation/advancemame/files/0.101.0-pic.patch
new file mode 100644
index 000000000000..049befbfac2c
--- /dev/null
+++ b/games-emulation/advancemame/files/0.101.0-pic.patch
@@ -0,0 +1,13 @@
+--- ./advance/blit/blit.c.orig 2004-12-19 01:01:46.039956536 -0500
++++ ./advance/blit/blit.c 2004-12-19 01:01:19.566981040 -0500
+@@ -28,6 +28,10 @@
+ * do so, delete this exception statement from your version.
+ */
+
++#if defined(USE_ASM_INLINE) && defined(__PIC__)
++# undef USE_ASM_INLINE
++#endif
++
+ #include "portable.h"
+
+ #include "blit.h"
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.101.0 b/games-emulation/advancemame/files/digest-advancemame-0.101.0
new file mode 100644
index 000000000000..1eb23307b253
--- /dev/null
+++ b/games-emulation/advancemame/files/digest-advancemame-0.101.0
@@ -0,0 +1 @@
+MD5 9d0b7b0a9daba8c4333e168e39cd8f71 advancemame-0.101.0.tar.gz 15671000