summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
commitae044aeba549da343d278a26bb72bac844e5a5e4 (patch)
treeb16ea879113ef2bd09bb78bb00e8338b088d3afb /games-emulation/blight_input/blight_input-0.0.4.ebuild
parentNew package - rename. (diff)
downloadgentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.tar.gz
gentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.tar.bz2
gentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.zip
welcome to games-emulation
Diffstat (limited to 'games-emulation/blight_input/blight_input-0.0.4.ebuild')
-rw-r--r--games-emulation/blight_input/blight_input-0.0.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-emulation/blight_input/blight_input-0.0.4.ebuild b/games-emulation/blight_input/blight_input-0.0.4.ebuild
new file mode 100644
index 000000000000..a653a1d25829
--- /dev/null
+++ b/games-emulation/blight_input/blight_input-0.0.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/blight_input/blight_input-0.0.4.ebuild,v 1.1 2003/09/09 16:26:49 vapier Exp $
+
+DESCRIPTION="An input plugin for the mupen64 N64 emulator"
+SRC_URI="http://deltaanime.ath.cx/~blight/n64/blight_input_plugin/${P}.tar.gz"
+HOMEPAGE="http://mupen64.emulation64.com/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 -ppc -sparc"
+
+DEPEND="media-libs/libsdl
+ media-libs/freetype"
+
+src_compile() {
+ cd ${S}/SDL_ttf2
+ rm config.cache
+ cp SDL_ttf.h ${S}
+ econf || die
+ emake || die "emake failed in ${S}/SDL_ttf2"
+ cd ${S}
+ emake || die "emake failed in ${S}"
+}
+
+src_install() {
+ dodir /usr/lib/mupen64/plugins
+ insinto /usr/lib/mupen64/plugins
+ doins blight_input.so
+}