summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-08-28 01:53:28 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-08-28 01:53:28 +0000
commit482aea86344d8300eefd8486a345b970e56cb065 (patch)
tree9bf3b86071ebaa99bb326f6194c1b99c002111b7 /games-emulation/daphne
parentMarked stable on mips. (diff)
downloadgentoo-2-482aea86344d8300eefd8486a345b970e56cb065.tar.gz
gentoo-2-482aea86344d8300eefd8486a345b970e56cb065.tar.bz2
gentoo-2-482aea86344d8300eefd8486a345b970e56cb065.zip
Fix compilation on gcc-4.1
(Portage version: 2.1-r2)
Diffstat (limited to 'games-emulation/daphne')
-rw-r--r--games-emulation/daphne/ChangeLog8
-rw-r--r--games-emulation/daphne/daphne-0.99.6-r2.ebuild8
-rw-r--r--games-emulation/daphne/files/daphne-0.99.6-gcc41.patch22
-rw-r--r--games-emulation/daphne/files/digest-daphne-0.99.6-r22
4 files changed, 35 insertions, 5 deletions
diff --git a/games-emulation/daphne/ChangeLog b/games-emulation/daphne/ChangeLog
index e177aa7ff786..1ea0c4d6d4ba 100644
--- a/games-emulation/daphne/ChangeLog
+++ b/games-emulation/daphne/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/daphne
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/ChangeLog,v 1.9 2005/07/10 02:33:40 mr_bones_ Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/ChangeLog,v 1.10 2006/08/28 01:53:27 tupone Exp $
+
+ 28 Aug 2006; <tupone@gentoo.org> +files/daphne-0.99.6-gcc41.patch,
+ daphne-0.99.6-r2.ebuild:
+ Fix compilation on gcc-4.1
10 Jul 2005; Michael Sterrett <mr_bones_@gentoo.org>
daphne-0.99.6-r2.ebuild:
diff --git a/games-emulation/daphne/daphne-0.99.6-r2.ebuild b/games-emulation/daphne/daphne-0.99.6-r2.ebuild
index c7be23184166..7321347619e6 100644
--- a/games-emulation/daphne/daphne-0.99.6-r2.ebuild
+++ b/games-emulation/daphne/daphne-0.99.6-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-0.99.6-r2.ebuild,v 1.9 2005/07/10 02:33:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-0.99.6-r2.ebuild,v 1.10 2006/08/28 01:53:27 tupone Exp $
inherit eutils flag-o-matic games
@@ -26,7 +26,9 @@ src_unpack() {
replace-cpu-flags i686 pentium3 pentium4 i586 #18807
- cd "${S}/src"
+ cd "${S}"
+ epatch "${FILESDIR}/${P}"-gcc41.patch
+ cd src
sed \
-e "/^DFLAGS/d" \
-e "/-fexpensive-optimizations/d " \
diff --git a/games-emulation/daphne/files/daphne-0.99.6-gcc41.patch b/games-emulation/daphne/files/daphne-0.99.6-gcc41.patch
new file mode 100644
index 000000000000..b136ebd387f8
--- /dev/null
+++ b/games-emulation/daphne/files/daphne-0.99.6-gcc41.patch
@@ -0,0 +1,22 @@
+--- src/game/game.h.old 2006-08-27 18:45:27.000000000 +0200
++++ src/game/game.h 2006-08-27 18:45:43.000000000 +0200
+@@ -121,7 +121,7 @@
+ int get_video_col_offset();
+ SDL_Surface *get_video_overlay(int index); // returns pointer to video overlay specified, or NULL if index is out of range
+ SDL_Surface *get_active_video_overlay(); // returns the current active video overlay (that is currently being drawn)
+- SDL_Surface *game::get_finished_video_overlay(); // returns the last complete video overlay (that isn't currently being drawn)
++ SDL_Surface *get_finished_video_overlay(); // returns the last complete video overlay (that isn't currently being drawn)
+ bool is_overlay_size_dynamic(); // returns m_overlay_size_is_dynamic
+
+ void enable_cheat();
+--- src/ldp-out/pioneer.h.old 2006-08-27 18:47:55.000000000 +0200
++++ src/ldp-out/pioneer.h 2006-08-27 18:48:12.000000000 +0200
+@@ -45,7 +45,7 @@
+ bool pioneer_audio1;
+ bool pioneer_audio2;
+ bool check_result(Uint32, bool);
+- bool pioneer::getstring(char *, int, Uint32,bool);
++ bool getstring(char *, int, Uint32,bool);
+ void printmodel();
+ };
+
diff --git a/games-emulation/daphne/files/digest-daphne-0.99.6-r2 b/games-emulation/daphne/files/digest-daphne-0.99.6-r2
index 115b93db4360..344ba83b7d7b 100644
--- a/games-emulation/daphne/files/digest-daphne-0.99.6-r2
+++ b/games-emulation/daphne/files/digest-daphne-0.99.6-r2
@@ -1 +1,3 @@
MD5 7602c8c1c7d54f61e23e55fe55b44ffd daphne-0.99.6-src.tar.gz 2685633
+RMD160 b4e7902887e6dad03d9ad0b8f9fc5b4b34ca9166 daphne-0.99.6-src.tar.gz 2685633
+SHA256 ca8e4365d3af7dd484ce14d30eeffafef7947e41956fa12ec7120308ff3658f9 daphne-0.99.6-src.tar.gz 2685633