summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-12-22 01:46:04 +0000
committerHanno Böck <hanno@gentoo.org>2009-12-22 01:46:04 +0000
commit9deb341129b743a942fd428c45850031895d515d (patch)
treee40f64133545e8523c1a79158649b5e5f250277b /games-emulation/desmume/desmume-0.9.5.ebuild
parentadd patch from Tim Hentenaar to fix compile warning from lua (bug #296697) (diff)
downloadgentoo-2-9deb341129b743a942fd428c45850031895d515d.tar.gz
gentoo-2-9deb341129b743a942fd428c45850031895d515d.tar.bz2
gentoo-2-9deb341129b743a942fd428c45850031895d515d.zip
desmume bump
(Portage version: 2.2_rc60/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation/desmume/desmume-0.9.5.ebuild')
-rw-r--r--games-emulation/desmume/desmume-0.9.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-emulation/desmume/desmume-0.9.5.ebuild b/games-emulation/desmume/desmume-0.9.5.ebuild
new file mode 100644
index 000000000000..a6e5ce2829e8
--- /dev/null
+++ b/games-emulation/desmume/desmume-0.9.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/desmume/desmume-0.9.5.ebuild,v 1.1 2009/12/22 01:46:04 hanno Exp $
+
+EAPI="2"
+
+inherit games
+
+DESCRIPTION="Nintendo DS emulator"
+HOMEPAGE="http://desmume.org/"
+SRC_URI="mirror://sourceforge/desmume/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.8.0
+ gnome-base/libglade
+ x11-libs/gtkglext
+ virtual/opengl
+ sys-libs/zlib
+ dev-libs/zziplib
+ media-libs/libsdl[joystick]
+ x11-libs/agg"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ egamesconf --datadir=/usr/share || die "egamesconf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake failed"
+ dodoc AUTHORS ChangeLog README README.LIN
+ prepgamesdirs
+}