summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-19 05:06:16 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-19 05:06:16 +0000
commit9e6b8ecba20b025e2f0fdc5689e340ccc6c93143 (patch)
tree7fa595bead15c34b1dab493656edccc9e5bb5184 /games-emulation/fake64
parentunmasking on ia64 only (diff)
downloadgentoo-2-9e6b8ecba20b025e2f0fdc5689e340ccc6c93143.tar.gz
gentoo-2-9e6b8ecba20b025e2f0fdc5689e340ccc6c93143.tar.bz2
gentoo-2-9e6b8ecba20b025e2f0fdc5689e340ccc6c93143.zip
initial ebuild
Diffstat (limited to 'games-emulation/fake64')
-rw-r--r--games-emulation/fake64/ChangeLog8
-rw-r--r--games-emulation/fake64/fake64-0.0.4_pre20021020.ebuild62
-rw-r--r--games-emulation/fake64/files/digest-fake64-0.0.4_pre200210201
3 files changed, 71 insertions, 0 deletions
diff --git a/games-emulation/fake64/ChangeLog b/games-emulation/fake64/ChangeLog
new file mode 100644
index 000000000000..52719ef4af33
--- /dev/null
+++ b/games-emulation/fake64/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-emulation/fake64
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fake64/ChangeLog,v 1.1 2003/09/19 05:06:16 vapier Exp $
+
+*fake64-0.0.4_pre20021020 (19 Sep 2003)
+
+ 19 Sep 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-emulation/fake64/fake64-0.0.4_pre20021020.ebuild b/games-emulation/fake64/fake64-0.0.4_pre20021020.ebuild
new file mode 100644
index 000000000000..c5571730864c
--- /dev/null
+++ b/games-emulation/fake64/fake64-0.0.4_pre20021020.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fake64/fake64-0.0.4_pre20021020.ebuild,v 1.1 2003/09/19 05:06:16 vapier Exp $
+
+inherit games
+
+DESCRIPTION="emulator for nintendo 64"
+HOMEPAGE="http://www.fakelabs.org/code/fake64/"
+SRC_URI="http://www.fakelabs.org/code/fake64/Fake64-20.10.2002.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/x11
+ virtual/opengl
+ virtual/glu
+ media-libs/libsdl"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:@bindir@/fake64:${S}/blah:" \
+ -e 's:/etc/fake64rc:\$(DESTDIR)@sysconfdir@/fake64rc:' \
+ Makefile.am
+ sed -i "s:/etc/fake64rc:${GAMES_SYSCONFDIR}/fake64rc:" \
+ romloader/configfile.c
+ touch blah
+ ./autogen.sh || die "autogen failed"
+}
+
+src_compile() {
+ econf \
+ `use_enable x86` \
+ `use_enable mmx` \
+ `use_enable 3dnow` \
+ `use_enable sse` \
+ || die
+ emake || die
+}
+
+src_install() {
+ dodir /etc
+ emake install DESTDIR=${D} || die
+ dodoc AUTHORS COMPATIBILITY ChangeLog NEWS README TODO
+
+ cd ${D}/etc
+ sed -i "s:/usr/local/fake64/plugins:${GAMES_LIBDIR}/${PN}:" fake64rc
+ insinto ${GAMES_SYSCONFDIR}
+ doins fake64rc && rm fake64rc
+ cd ${D}/usr/fake64
+ dogamesbin bin/*
+ dosym romloader ${GAMES_BINDIR}/fake64
+ dodir ${GAMES_LIBDIR}/${PN}
+ mv plugins/* ${D}/${GAMES_LIBDIR}/${PN}/
+ cd .. && rm -rf fake64
+
+ prepgamesdirs
+}
diff --git a/games-emulation/fake64/files/digest-fake64-0.0.4_pre20021020 b/games-emulation/fake64/files/digest-fake64-0.0.4_pre20021020
new file mode 100644
index 000000000000..71578c5c9684
--- /dev/null
+++ b/games-emulation/fake64/files/digest-fake64-0.0.4_pre20021020
@@ -0,0 +1 @@
+MD5 ae66ddaff6bf33ada4cdebd1de3b2747 Fake64-20.10.2002.tar.bz2 512659