summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-07-26 21:28:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-07-26 21:28:36 +0000
commitfaf44374f083f1abd1439fc8ddf287a913f6d04d (patch)
tree861cac3c48153d4f017e07b0e85a437799a8d8c5 /games-emulation/fceux
parentMasked sunbird{,-bin} for removal. (diff)
downloadgentoo-2-faf44374f083f1abd1439fc8ddf287a913f6d04d.tar.gz
gentoo-2-faf44374f083f1abd1439fc8ddf287a913f6d04d.tar.bz2
gentoo-2-faf44374f083f1abd1439fc8ddf287a913f6d04d.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-emulation/fceux')
-rw-r--r--games-emulation/fceux/ChangeLog7
-rw-r--r--games-emulation/fceux/fceux-2.1.4a.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/games-emulation/fceux/ChangeLog b/games-emulation/fceux/ChangeLog
index 186b00628947..37e5f9356d7c 100644
--- a/games-emulation/fceux/ChangeLog
+++ b/games-emulation/fceux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/fceux
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/ChangeLog,v 1.4 2010/06/25 18:50:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/ChangeLog,v 1.5 2010/07/26 21:28:36 mr_bones_ Exp $
+
+*fceux-2.1.4a (26 Jul 2010)
+
+ 26 Jul 2010; Michael Sterrett <mr_bones_@gentoo.org> +fceux-2.1.4a.ebuild:
+ version bump
*fceux-2.1.4 (25 Jun 2010)
diff --git a/games-emulation/fceux/fceux-2.1.4a.ebuild b/games-emulation/fceux/fceux-2.1.4a.ebuild
new file mode 100644
index 000000000000..8e8b87e496fb
--- /dev/null
+++ b/games-emulation/fceux/fceux-2.1.4a.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/fceux-2.1.4a.ebuild,v 1.1 2010/07/26 21:28:36 mr_bones_ Exp $
+
+EAPI=2
+inherit games
+
+DESCRIPTION="A portable Famicom/NES emulator, an evolution of the original FCE Ultra"
+HOMEPAGE="http://fceux.com/"
+SRC_URI="mirror://sourceforge/fceultra/${P}.src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+lua +opengl"
+
+RDEPEND="lua? ( dev-lang/lua )
+ media-libs/libsdl[opengl?,video]
+ opengl? ( virtual/opengl )
+ x11-libs/gtk+:2
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-util/scons"
+RDEPEND="${RDEPEND}
+ gnome-extra/zenity"
+# Note: zenity is "almost" optional. It is possible to compile and run fceux
+# without zenity, but file dialogs will not work.
+
+S=${WORKDIR}/fceu${PV}
+
+src_compile() {
+ local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[[:space:]]*[0-9]\+\).*/\1/; p }")
+ scons \
+ ${sconsopts} \
+ CREATE_AVI=1 \
+ OPENGL=$(use opengl && echo 1 || echo 0) \
+ LUA=$(use lua && echo 1 || echo 0) \
+ || die "scons failed"
+}
+
+src_install() {
+ dogamesbin bin/fceux || die
+
+ doman documentation/fceux.6 || die
+ dodoc Authors.txt changelog.txt TODO-PROJECT
+
+ # Extra documentation
+ insinto "/usr/share/doc/${PF}/"
+ doins -r bin/fceux.chm documentation
+ rm -f "${D}/usr/share/doc/${PF}/documentation/fceux.6"
+
+ prepgamesdirs
+}