summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-20 09:17:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-20 09:17:29 +0000
commitdf9adeff4424570c52a38e6a7b7902cc409e3fba (patch)
tree0e3ca82f01c086f100edb9e35ad12c77abfc0a8c /games-emulation/generator
parentgnome 2.6 commit (Manifest recommit) (diff)
downloadgentoo-2-df9adeff4424570c52a38e6a7b7902cc409e3fba.tar.gz
gentoo-2-df9adeff4424570c52a38e6a7b7902cc409e3fba.tar.bz2
gentoo-2-df9adeff4424570c52a38e6a7b7902cc409e3fba.zip
fix bug #44709 by turning off logging; other clean ups if you can call this package "cleaner"
Diffstat (limited to 'games-emulation/generator')
-rw-r--r--games-emulation/generator/ChangeLog12
-rw-r--r--games-emulation/generator/files/logging.patch40
-rw-r--r--games-emulation/generator/generator-0.35.ebuild57
3 files changed, 89 insertions, 20 deletions
diff --git a/games-emulation/generator/ChangeLog b/games-emulation/generator/ChangeLog
index da406591f667..d27ab780f08b 100644
--- a/games-emulation/generator/ChangeLog
+++ b/games-emulation/generator/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-emulation/generator
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/ChangeLog,v 1.3 2003/12/20 18:23:37 dholm Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/ChangeLog,v 1.4 2004/03/20 09:17:29 mr_bones_ Exp $
+
+ 20 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> generator-0.35.ebuild:
+ fix bug #44709 by turning off logging
+ fixed up old hard-coded gcc flags in configure
+ take out mention of allegro and tcltk - this package looks dead upstream so
+ it doesn't look like allegro and tcltk will ever be supported.
+ changed make to emake -j1 - don't even think about trying to use parallel
+ make with these makefiles - very broken
20 Dec 2003; David Holm <dholm@gentoo.org> generator-0.35.ebuild:
Added a small ppc fix and added to ~ppc.
diff --git a/games-emulation/generator/files/logging.patch b/games-emulation/generator/files/logging.patch
new file mode 100644
index 000000000000..295d55126d0f
--- /dev/null
+++ b/games-emulation/generator/files/logging.patch
@@ -0,0 +1,40 @@
+diff -ur generator-0.35.orig/main/ui-console.c generator-0.35/main/ui-console.c
+--- generator-0.35.orig/main/ui-console.c 2001-10-19 15:35:32.000000000 -0700
++++ generator-0.35/main/ui-console.c 2004-03-20 01:06:59.000000000 -0800
+@@ -1204,6 +1204,7 @@
+ /* logging is done this way because this was the best I could come up with
+ whilst battling with macros that can only take fixed numbers of arguments */
+
++#ifndef NOLOGGING
+ #ifdef ALLEGRO
+ #define LOG_FUNC(name,level,txt) void ui_log_ ## name ## (const char *text, ...) \
+ { \
+@@ -1243,6 +1244,7 @@
+ LOG_FUNC(normal, 2, "---- ");
+ LOG_FUNC(critical, 1, "CRIT ");
+ LOG_FUNC(request, 0, "---- "); /* this generates a warning, such is life */
++#endif
+
+ /*** ui_err - log error message and quit ***/
+
+Only in generator-0.35/main: ui-console.c.orig
+diff -ur generator-0.35.orig/main/ui-gtk.c generator-0.35/main/ui-gtk.c
+--- generator-0.35.orig/main/ui-gtk.c 2003-05-03 17:09:51.000000000 -0700
++++ generator-0.35/main/ui-gtk.c 2004-03-20 01:06:59.000000000 -0800
+@@ -739,6 +739,7 @@
+ /* logging is done this way because this was the best I could come up with
+ whilst battling with macros that can only take fixed numbers of arguments */
+
++#ifndef NOLOGGING
+ #define LOG_FUNC(name,level,txt) void ui_log_ ## name ## (const char *text, ...) \
+ { \
+ va_list ap; \
+@@ -761,6 +762,7 @@
+ LOG_FUNC(normal, 2, "---- ");
+ LOG_FUNC(critical, 1, "CRIT ");
+ LOG_FUNC(request, 0, "---- "); /* this generates a warning, such is life */
++#endif
+
+ /* *INDENT-ON* */
+
+Only in generator-0.35/main: ui-gtk.c.orig
diff --git a/games-emulation/generator/generator-0.35.ebuild b/games-emulation/generator/generator-0.35.ebuild
index 74dd930ec7a2..97fd45da0925 100644
--- a/games-emulation/generator/generator-0.35.ebuild
+++ b/games-emulation/generator/generator-0.35.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/generator-0.35.ebuild,v 1.4 2004/03/10 17:32:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/generator-0.35.ebuild,v 1.5 2004/03/20 09:17:29 mr_bones_ Exp $
-inherit games gcc
+inherit eutils gcc flag-o-matic games
DESCRIPTION="Sega Genesis / Mega Drive console emulator"
HOMEPAGE="http://www.squish.net/generator/"
@@ -11,50 +11,71 @@ SRC_URI="http://www.squish.net/generator/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc"
-IUSE="svga tcltk gtk" #allegro fails to compile
+IUSE="svga gtk"
-DEPEND="gtk? ( =x11-libs/gtk+-1* media-libs/libsdl )
+DEPEND="virtual/glibc
+ gtk? (
+ =x11-libs/gtk+-1*
+ media-libs/libsdl
+ )
svga? ( media-libs/svgalib )
jpeg? ( media-libs/jpeg )
x86? ( dev-lang/nasm )"
-# allegro? ( media-libs/allegro )
-# tcltk? ( dev-lang/tk dev-lang/tcl ) #deprecated upstream
src_unpack() {
unpack ${A}
cd ${S}
+ mkdir my-bins
if [ "${ARCH}" == "ppc" ]; then
- sed -i -e 's/-minline-all-stringops//g' configure
+ sed -i \
+ -e 's/-minline-all-stringops//g' configure \
+ || die "sed configure failed"
+ fi
+
+ if [ $(gcc-major-version) -eq 3 ] ; then
+ sed -i \
+ -e "s/-malign-functions/-falign-functions/" \
+ -e "s/-malign-loops/-falign-loops/" \
+ -e "s/-malign-jumps/-falign-jumps/" configure \
+ || die "sed configure failed"
fi
+ epatch "${FILESDIR}/logging.patch"
}
src_compile() {
- mkdir my-bins
+ local myconf="--with-gcc=$(gcc-major-version)"
+
+ append-flags "-DNOLOGGING"
- local myconf="--with-gcc=`gcc-major-version`"
[ "${ARCH}" == "x86" ] \
&& myconf="${myconf} --with-raze" \
|| myconf="${myconf} --with-cmz80"
local mygui
- for mygui in `use gtk` `use svga` ; do #`use allegro` `use tcltk`
+ for mygui in `use gtk` `use svga` ; do
[ "${mygui}" == "svga" ] && mygui=svgalib
- make clean
- egamesconf ${myconf} --with-${mygui} || die
- make || die "building ${mygui}"
+
+ if [ -f Makefile ] ; then
+ make clean
+ fi
+ egamesconf \
+ ${myconf} \
+ --with-${mygui} || die
+ emake -j1 || die "building ${mygui}"
mv main/generator-${mygui} my-bins/
done
- if [ -z "`use gtk``use allegro``use svga``use tcltk`" ] ; then
- egamesconf ${myconf} --with-gtk || die
- make || die "building ${mygui}"
+ if [ -z "`use gtk``use svga`" ] ; then
+ egamesconf \
+ ${myconf} \
+ --with-gtk || die
+ emake -j1 || die "building ${mygui}"
mv main/generator-gtk my-bins/
fi
}
src_install() {
- #make install DESTDIR=${D} || die #all it does is install the binary ;)
- dogamesbin my-bins/*
+ dogamesbin my-bins/* || die "dogamesbin failed"
dodoc AUTHORS ChangeLog NEWS README TODO
prepgamesdirs
}