summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-09-28 12:45:03 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-09-28 12:45:03 +0000
commit147200b0473b5527f1790118cdcf538a6b1f1282 (patch)
tree072b51e2d989496ad179df1377ddf5f0f8e1858c /games-emulation/gnuboy/gnuboy-1.0.3.ebuild
parentFix circular dependency with libcdio as reported by Mike Lundy in bug #149383... (diff)
downloadgentoo-2-147200b0473b5527f1790118cdcf538a6b1f1282.tar.gz
gentoo-2-147200b0473b5527f1790118cdcf538a6b1f1282.tar.bz2
gentoo-2-147200b0473b5527f1790118cdcf538a6b1f1282.zip
Add missing RDEPEND on sys-apps/fbset, bug #99983
(Portage version: 2.1.2_pre1-r4)
Diffstat (limited to 'games-emulation/gnuboy/gnuboy-1.0.3.ebuild')
-rw-r--r--games-emulation/gnuboy/gnuboy-1.0.3.ebuild16
1 files changed, 5 insertions, 11 deletions
diff --git a/games-emulation/gnuboy/gnuboy-1.0.3.ebuild b/games-emulation/gnuboy/gnuboy-1.0.3.ebuild
index 064f66fbfb1f..80f9c05e96d1 100644
--- a/games-emulation/gnuboy/gnuboy-1.0.3.ebuild
+++ b/games-emulation/gnuboy/gnuboy-1.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gnuboy/gnuboy-1.0.3.ebuild,v 1.11 2006/02/10 19:39:07 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gnuboy/gnuboy-1.0.3.ebuild,v 1.12 2006/09/28 12:45:03 nyhm Exp $
inherit games
@@ -15,18 +15,12 @@ IUSE="X fbcon sdl svga"
RDEPEND="sdl? ( media-libs/libsdl )
!X? ( !svga? ( !fbcon? ( media-libs/libsdl ) ) )
- X? (
- || (
- x11-libs/libXext
- virtual/x11 ) )"
+ X? ( x11-libs/libXext )
+ fbcon? ( sys-apps/fbset )"
DEPEND="${RDEPEND}
svga? ( media-libs/svgalib )
- X? (
- || (
- (
- x11-proto/xextproto
- x11-proto/xproto )
- virtual/x11 ) )"
+ X? ( x11-proto/xextproto
+ x11-proto/xproto )"
src_compile() {
local myconf