summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-07-06 18:48:05 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-07-06 18:48:05 +0000
commit29771fef6b8ac5ef17b3a7e6465eca1f56502ff4 (patch)
tree51c8f24c62e4636cbc509714d280436908dd53d3 /games-emulation/gnuboy/gnuboy-1.0.3.ebuild
parentStable for HPPA (bug #179533). (diff)
downloadgentoo-2-29771fef6b8ac5ef17b3a7e6465eca1f56502ff4.tar.gz
gentoo-2-29771fef6b8ac5ef17b3a7e6465eca1f56502ff4.tar.bz2
gentoo-2-29771fef6b8ac5ef17b3a7e6465eca1f56502ff4.zip
Fix for recent linux-headers and exec stack
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'games-emulation/gnuboy/gnuboy-1.0.3.ebuild')
-rw-r--r--games-emulation/gnuboy/gnuboy-1.0.3.ebuild25
1 files changed, 17 insertions, 8 deletions
diff --git a/games-emulation/gnuboy/gnuboy-1.0.3.ebuild b/games-emulation/gnuboy/gnuboy-1.0.3.ebuild
index 80f9c05e96d1..0dc318d6917a 100644
--- a/games-emulation/gnuboy/gnuboy-1.0.3.ebuild
+++ b/games-emulation/gnuboy/gnuboy-1.0.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gnuboy/gnuboy-1.0.3.ebuild,v 1.12 2006/09/28 12:45:03 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gnuboy/gnuboy-1.0.3.ebuild,v 1.13 2007/07/06 18:48:05 nyhm Exp $
-inherit games
+inherit autotools eutils games
DESCRIPTION="Gameboy emulator with multiple renderers"
HOMEPAGE="http://gnuboy.unix-fu.org/"
@@ -14,14 +14,23 @@ KEYWORDS="amd64 ppc x86"
IUSE="X fbcon sdl svga"
RDEPEND="sdl? ( media-libs/libsdl )
- !X? ( !svga? ( !fbcon? ( media-libs/libsdl ) ) )
- X? ( x11-libs/libXext )
- fbcon? ( sys-apps/fbset )"
+ !X? ( !svga? ( !fbcon? ( media-libs/libsdl ) ) )
+ X? ( x11-libs/libXext )
+ fbcon? ( sys-apps/fbset )"
DEPEND="${RDEPEND}
svga? ( media-libs/svgalib )
X? ( x11-proto/xextproto
x11-proto/xproto )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${P}-exec-stack.patch \
+ "${FILESDIR}"/${P}-linux-headers.patch
+ eautoreconf
+}
+
src_compile() {
local myconf
@@ -44,8 +53,8 @@ src_compile() {
src_install() {
for f in fbgnuboy sdlgnuboy sgnuboy xgnuboy
do
- if [[ -f $f ]] ; then
- dogamesbin $f || die "dogamesbin failed"
+ if [[ -f ${f} ]] ; then
+ dogamesbin ${f} || die "dogamesbin failed"
fi
done
dodoc README docs/{CHANGES,CONFIG,CREDITS,FAQ,HACKING,WHATSNEW}