summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-22 05:24:26 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-22 05:24:26 +0000
commitd93b0687c2ec5328fefba9f987fb62ec4b0518ba (patch)
treeb3ce69bd862f4fb2fb8513db610a094e650c3fba /games-emulation/nestra/nestra-0.66-r1.ebuild
parentremove multilib cruft (diff)
downloadgentoo-2-d93b0687c2ec5328fefba9f987fb62ec4b0518ba.tar.gz
gentoo-2-d93b0687c2ec5328fefba9f987fb62ec4b0518ba.tar.bz2
gentoo-2-d93b0687c2ec5328fefba9f987fb62ec4b0518ba.zip
remove multilib cruft
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-emulation/nestra/nestra-0.66-r1.ebuild')
-rw-r--r--games-emulation/nestra/nestra-0.66-r1.ebuild31
1 files changed, 12 insertions, 19 deletions
diff --git a/games-emulation/nestra/nestra-0.66-r1.ebuild b/games-emulation/nestra/nestra-0.66-r1.ebuild
index e7f4bad00cd9..838bd2518ba2 100644
--- a/games-emulation/nestra/nestra-0.66-r1.ebuild
+++ b/games-emulation/nestra/nestra-0.66-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/nestra-0.66-r1.ebuild,v 1.4 2005/03/21 08:10:09 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/nestra-0.66-r1.ebuild,v 1.5 2005/03/22 05:24:26 vapier Exp $
inherit eutils games toolchain-funcs flag-o-matic
@@ -16,29 +16,22 @@ KEYWORDS="~amd64 x86"
IUSE=""
RDEPEND="amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.2-r7 )"
-
DEPEND="${RDEPEND}
virtual/x11"
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
pkg_setup() {
- if use amd64; then
- if has_multilib_profile; then
- ABI_ALLOW="x86"
-
- # And until we get a real multilib portage...
- ABI="x86"
-
- # Yeah, this is ugly, but so's their build system...
- append-flags "-L/emul/linux/x86/usr/lib -L/emul/linux/x86/lib -L/usr/lib32 -L/lib32"
- append-ldflags $(get_abi_LDFLAGS)
- elif has_m32 ; then
- einfo "multilib detected, adding -m32 to CFLAGS."
- append-flags -m32
- else
- die "${PN} requires multilib support in gcc. please re-emerge gcc with multilib in USE and try again"
- fi
+ use amd64 || return 0
+ if has_m32 ; then
+ append-flags -m32
+ append-ldflags -m elf_i386
+ else
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
fi
}