summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-10 01:14:17 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-10 01:14:17 +0000
commit445db69b0faf2c09472d282386e45ada984fb29b (patch)
tree77f417555cc1bb1cf69efdeb673504e745ba0070 /games-emulation/nestra
parentAdded a patch to fix fullscreen requests thanks to Bernard Cafarelli <voyageu... (diff)
downloadgentoo-2-445db69b0faf2c09472d282386e45ada984fb29b.tar.gz
gentoo-2-445db69b0faf2c09472d282386e45ada984fb29b.tar.bz2
gentoo-2-445db69b0faf2c09472d282386e45ada984fb29b.zip
Build nestra without an executable stack.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'games-emulation/nestra')
-rw-r--r--games-emulation/nestra/ChangeLog6
-rw-r--r--games-emulation/nestra/files/nestra-0.66-exec-stack.patch10
-rw-r--r--games-emulation/nestra/nestra-0.66-r1.ebuild9
3 files changed, 20 insertions, 5 deletions
diff --git a/games-emulation/nestra/ChangeLog b/games-emulation/nestra/ChangeLog
index f4445ca8cf57..e0edb6fb40ae 100644
--- a/games-emulation/nestra/ChangeLog
+++ b/games-emulation/nestra/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/nestra
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/ChangeLog,v 1.8 2006/01/10 01:00:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/ChangeLog,v 1.9 2006/01/10 01:14:17 vapier Exp $
+
+ 10 Jan 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/nestra-0.66-exec-stack.patch, nestra-0.66-r1.ebuild:
+ Build nestra without an executable stack.
10 Jan 2006; Mike Frysinger <vapier@gentoo.org> nestra-0.66-r1.ebuild:
Fix LDFLAGS support.
diff --git a/games-emulation/nestra/files/nestra-0.66-exec-stack.patch b/games-emulation/nestra/files/nestra-0.66-exec-stack.patch
new file mode 100644
index 000000000000..f5c662e22600
--- /dev/null
+++ b/games-emulation/nestra/files/nestra-0.66-exec-stack.patch
@@ -0,0 +1,10 @@
+--- x86.S.orig 2006-01-09 20:02:58.000000000 -0500
++++ x86.S 2006-01-09 20:03:38.000000000 -0500
+@@ -1458,3 +1458,7 @@
+ leal 0x1(%eax),%ebx
+ popl %eax
+ jmp i_next
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",@progbits
++#endif
diff --git a/games-emulation/nestra/nestra-0.66-r1.ebuild b/games-emulation/nestra/nestra-0.66-r1.ebuild
index d589be975546..91edf7d65a1e 100644
--- a/games-emulation/nestra/nestra-0.66-r1.ebuild
+++ b/games-emulation/nestra/nestra-0.66-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/nestra-0.66-r1.ebuild,v 1.10 2006/01/10 01:00:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/nestra-0.66-r1.ebuild,v 1.11 2006/01/10 01:14:17 vapier Exp $
inherit eutils toolchain-funcs flag-o-matic games
@@ -27,7 +27,7 @@ pkg_setup() {
export ABI=x86
if has_m32 ; then
append-flags -m32
- append-ldflags -m elf_i386
+ append-ldflags -Wl,-m,elf_i386
else
eerror "Your compiler seems to be unable to compile 32bit code."
eerror "Make sure you compile gcc with:"
@@ -40,9 +40,10 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${WORKDIR}/${PATCH}"
+ epatch "${WORKDIR}"/${PATCH} "${FILESDIR}"/${P}-exec-stack.patch
+ append-ldflags -Wl,-z,noexecstack
sed -i \
- -e "s:-L/usr/X11R6/lib::" \
+ -e "s:-L/usr/X11R6/lib:${LDFLAGS}:" \
-e 's:-O2 ::' \
-e "s:gcc:$(tc-getCC) ${CFLAGS}:" \
-e "s:ld:$(tc-getLD) $(raw-ldflags):" \