summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
commitae044aeba549da343d278a26bb72bac844e5a5e4 (patch)
treeb16ea879113ef2bd09bb78bb00e8338b088d3afb /games-emulation/psemu-cdr
parentNew package - rename. (diff)
downloadgentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.tar.gz
gentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.tar.bz2
gentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.zip
welcome to games-emulation
Diffstat (limited to 'games-emulation/psemu-cdr')
-rw-r--r--games-emulation/psemu-cdr/ChangeLog23
-rw-r--r--games-emulation/psemu-cdr/Manifest4
-rw-r--r--games-emulation/psemu-cdr/files/1.8-makefile-cflags.patch11
-rw-r--r--games-emulation/psemu-cdr/files/digest-psemu-cdr-1.81
-rw-r--r--games-emulation/psemu-cdr/psemu-cdr-1.8.ebuild52
5 files changed, 91 insertions, 0 deletions
diff --git a/games-emulation/psemu-cdr/ChangeLog b/games-emulation/psemu-cdr/ChangeLog
new file mode 100644
index 000000000000..4df1a18f562f
--- /dev/null
+++ b/games-emulation/psemu-cdr/ChangeLog
@@ -0,0 +1,23 @@
+# ChangeLog for app-emulation/psemu-cdr
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-cdr/ChangeLog,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+*psemu-cdr-1.8 (14 Aug 2003)
+
+ 14 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump + games.eclass support.
+
+*psemu-cdr-1.62 (27 Jul 2002)
+
+ 06 Aug 2002; Mark Guertin <gerk@gentoo.org> :
+ Added -ppc to keywords
+
+ 27 Jul 2002; Stuart Bouyer <stubear@gentoo.org> psemu-cdr.ebuild :
+ Added KEYWORDS="x86" and SLOT.
+
+ 2 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/games-emulation/psemu-cdr/Manifest b/games-emulation/psemu-cdr/Manifest
new file mode 100644
index 000000000000..da6d76e62b10
--- /dev/null
+++ b/games-emulation/psemu-cdr/Manifest
@@ -0,0 +1,4 @@
+MD5 cebe9fccfb101907d3a8588f1b5870c6 files/digest-psemu-cdr-1.8 58
+MD5 169244f21e87968b8b24a2156c6ea257 files/1.8-makefile-cflags.patch 317
+MD5 27a36e0fe6ec7ea32d85cdc9671d56ab ChangeLog 997
+MD5 eefa226eaccd46ac75dfc6b938e37c33 psemu-cdr-1.8.ebuild 1073
diff --git a/games-emulation/psemu-cdr/files/1.8-makefile-cflags.patch b/games-emulation/psemu-cdr/files/1.8-makefile-cflags.patch
new file mode 100644
index 000000000000..8b26c890d594
--- /dev/null
+++ b/games-emulation/psemu-cdr/files/1.8-makefile-cflags.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.orig 2003-08-14 01:09:20.989215312 -0400
++++ src/Makefile 2003-08-14 01:09:36.660832864 -0400
+@@ -25,7 +25,7 @@
+
+ OBJECTS = cdr.o cfg.o
+ LIBS = -lpthread
+-CFLAGS = -g -fPIC -Wall -O2 -fomit-frame-pointer \
++CFLAGS = -fPIC -Wall $(OPTFLAGS) \
+ -D_REENTRANT -DVERSION=$(VERSION) -DBUILD=$(BUILD)
+
+
diff --git a/games-emulation/psemu-cdr/files/digest-psemu-cdr-1.8 b/games-emulation/psemu-cdr/files/digest-psemu-cdr-1.8
new file mode 100644
index 000000000000..42e1339ca73f
--- /dev/null
+++ b/games-emulation/psemu-cdr/files/digest-psemu-cdr-1.8
@@ -0,0 +1 @@
+MD5 0144ddcd5acff5130f075a3cf7819bdd cdr-1.8.tar.gz 44115
diff --git a/games-emulation/psemu-cdr/psemu-cdr-1.8.ebuild b/games-emulation/psemu-cdr/psemu-cdr-1.8.ebuild
new file mode 100644
index 000000000000..4c338bb53c51
--- /dev/null
+++ b/games-emulation/psemu-cdr/psemu-cdr-1.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-cdr/psemu-cdr-1.8.ebuild,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="PSEmu plugin to read from CD-ROM"
+HOMEPAGE="http://www.pcsx.net/"
+SRC_URI="http://linuzappz.pcsx.net/downloads/cdr-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="gtk gtk2"
+
+DEPEND="|| (
+ gtk2? ( =x11-libs/gtk+-2* )
+ gtk? ( =x11-libs/gtk+-1* )
+ =x11-libs/gtk+-2*
+ )
+ dev-util/pkgconfig"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-makefile-cflags.patch
+}
+
+src_compile() {
+ local gtk
+ if [ `use gtk2` ] ; then
+ gtk=gtk+2
+ elif [ `use gtk` ] ; then
+ gtk=gtk
+ else
+ gtk=gtk+2
+ fi
+ cd src
+ emake OPTFLAGS="${CFLAGS}" GUI="${gtk}" || die
+}
+
+src_install() {
+ exeinto ${GAMES_LIBDIR}/psemu/plugins
+ doexe src/libcdr-*
+ exeinto ${GAMES_LIBDIR}/psemu/cfg
+ doexe src/cfg-gtk*/cfgCdr
+ insinto ${GAMES_LIBDIR}/psemu/cfg
+ doins cdr.cfg
+ dodoc ReadMe.txt
+ prepgamesdirs
+}