summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-15 23:12:31 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-15 23:12:31 +0000
commit53bb3021baf764592433ab67b2d9b03fbb41c933 (patch)
treebfb498a942e6eee2b3398b33b52dd106d55483b3 /games-emulation/vgba
parentMarking amd64 stable (diff)
downloadgentoo-2-53bb3021baf764592433ab67b2d9b03fbb41c933.tar.gz
gentoo-2-53bb3021baf764592433ab67b2d9b03fbb41c933.tar.bz2
gentoo-2-53bb3021baf764592433ab67b2d9b03fbb41c933.zip
Version bump
(Portage version: 2.1.2_pre3-r2)
Diffstat (limited to 'games-emulation/vgba')
-rw-r--r--games-emulation/vgba/ChangeLog7
-rw-r--r--games-emulation/vgba/files/digest-vgba-2.12
-rw-r--r--games-emulation/vgba/files/digest-vgba-3.03
-rw-r--r--games-emulation/vgba/vgba-3.0.ebuild33
4 files changed, 44 insertions, 1 deletions
diff --git a/games-emulation/vgba/ChangeLog b/games-emulation/vgba/ChangeLog
index 16fac0664117..f135546349a6 100644
--- a/games-emulation/vgba/ChangeLog
+++ b/games-emulation/vgba/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/vgba
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/vgba/ChangeLog,v 1.6 2006/09/19 19:17:38 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/vgba/ChangeLog,v 1.7 2006/10/15 23:12:31 nyhm Exp $
+
+*vgba-3.0 (15 Oct 2006)
+
+ 15 Oct 2006; Tristan Heaven <nyhm@gentoo.org> +vgba-3.0.ebuild:
+ Version bump
19 Sep 2006; Chris Gianelloni <wolf31o2@gentoo.org> vgba-2.1.ebuild:
Adding strip to RESTRICT for bug #137819.
diff --git a/games-emulation/vgba/files/digest-vgba-2.1 b/games-emulation/vgba/files/digest-vgba-2.1
index e3f41d2ec720..f10e453bf323 100644
--- a/games-emulation/vgba/files/digest-vgba-2.1
+++ b/games-emulation/vgba/files/digest-vgba-2.1
@@ -1 +1,3 @@
MD5 dddfce8bc65e874f77b93956115abb28 VGBA21-Linux-80x86-bin.tar.Z 297898
+RMD160 37e01e2fe1f425fad6dcbfbc0b7ac9f7e73976fb VGBA21-Linux-80x86-bin.tar.Z 297898
+SHA256 cbf5b5d29f0373c91de2b29a451dfdbd77c6f4797232ce953941d99cf55fee40 VGBA21-Linux-80x86-bin.tar.Z 297898
diff --git a/games-emulation/vgba/files/digest-vgba-3.0 b/games-emulation/vgba/files/digest-vgba-3.0
new file mode 100644
index 000000000000..1a1a3e0c2b28
--- /dev/null
+++ b/games-emulation/vgba/files/digest-vgba-3.0
@@ -0,0 +1,3 @@
+MD5 9e335c3ae6770b1cbfee8fd354321736 VGBA30-Linux-80x86-bin.tar.Z 310375
+RMD160 1bddeb2455ea7a61eaec2fff5bc3b86bc64bbf58 VGBA30-Linux-80x86-bin.tar.Z 310375
+SHA256 4f519afa5a6597048f09392a119967634d74b9b756d087a873e3f773156928f9 VGBA30-Linux-80x86-bin.tar.Z 310375
diff --git a/games-emulation/vgba/vgba-3.0.ebuild b/games-emulation/vgba/vgba-3.0.ebuild
new file mode 100644
index 000000000000..3a4ba1f2cf35
--- /dev/null
+++ b/games-emulation/vgba/vgba-3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/vgba/vgba-3.0.ebuild,v 1.1 2006/10/15 23:12:31 nyhm Exp $
+
+inherit games
+
+DESCRIPTION="Gameboy Advance (GBA) emulator for Linux"
+HOMEPAGE="http://www.komkon.org/fms/VGBA/"
+SRC_URI="http://fms.komkon.org/VGBA/VGBA${PV/.}-Linux-80x86-bin.tar.Z"
+
+LICENSE="VGBA"
+SLOT="0"
+KEYWORDS="-* ~x86"
+RESTRICT="strip"
+IUSE=""
+
+RDEPEND="x11-libs/libXext"
+
+S=${WORKDIR}
+
+src_install() {
+ into "${GAMES_PREFIX_OPT}"
+ dobin vgba || die "dobin failed"
+ dohtml VGBA.html
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "You must run X in 16bit color for the emu to work"
+ echo
+}