summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-07-15 01:49:09 +0000
committerTravis Tilley <lv@gentoo.org>2004-07-15 01:49:09 +0000
commitc50b06804b8bb1116b52748b5297e635741b13f3 (patch)
treebb0381de542ab405e1047c8f983469337bae58c5 /games-emulation/zsnes
parentbittorrent-theshadow is now bittornado (diff)
downloadgentoo-2-c50b06804b8bb1116b52748b5297e635741b13f3.tar.gz
gentoo-2-c50b06804b8bb1116b52748b5297e635741b13f3.tar.bz2
gentoo-2-c50b06804b8bb1116b52748b5297e635741b13f3.zip
added preliminary amd64 support
Diffstat (limited to 'games-emulation/zsnes')
-rw-r--r--games-emulation/zsnes/ChangeLog5
-rw-r--r--games-emulation/zsnes/zsnes-1.37_pre20040508.ebuild22
2 files changed, 22 insertions, 5 deletions
diff --git a/games-emulation/zsnes/ChangeLog b/games-emulation/zsnes/ChangeLog
index 46ff0eef9a60..b25f7fbdbf89 100644
--- a/games-emulation/zsnes/ChangeLog
+++ b/games-emulation/zsnes/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/zsnes
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/ChangeLog,v 1.7 2004/06/24 22:38:07 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/ChangeLog,v 1.8 2004/07/15 01:49:09 lv Exp $
+
+ 14 Jul 2004; Travis Tilley <lv@gentoo.org> zsnes-1.37_pre20040508.ebuild:
+ added preliminary amd64 support
26 May 2004; Michael Sterrett <mr_bones_@gentoo.org>
zsnes-1.37_pre20041220.ebuild:
diff --git a/games-emulation/zsnes/zsnes-1.37_pre20040508.ebuild b/games-emulation/zsnes/zsnes-1.37_pre20040508.ebuild
index 62497ef88673..43070be73a8b 100644
--- a/games-emulation/zsnes/zsnes-1.37_pre20040508.ebuild
+++ b/games-emulation/zsnes/zsnes-1.37_pre20040508.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.37_pre20040508.ebuild,v 1.4 2004/06/24 22:38:07 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.37_pre20040508.ebuild,v 1.5 2004/07/15 01:49:09 lv Exp $
-inherit games
+inherit games eutils flag-o-matic
DESCRIPTION="SNES (Super Nintendo) emulator that uses x86 assembly"
HOMEPAGE="http://www.zsnes.com/ http://emuhost.com/ipher/zsnes/"
@@ -10,11 +10,14 @@ SRC_URI="http://ipher.emuhost.com/files/zsnes/ZSNESS_${PV/*2004}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="-* ~x86"
+KEYWORDS="-* ~x86 ~amd64"
IUSE="opengl"
+# we need libsdl for headers on amd64, even though we'll technically be using
+# the 32bit sdl from emul-linux-x86-sdl.
RDEPEND="opengl? ( virtual/opengl )
>=media-libs/libsdl-1.2.0
+ amd64? ( app-emulation/emul-linux-x86-sdl )
sys-libs/zlib
media-libs/libpng"
DEPEND="${RDEPEND}
@@ -24,6 +27,16 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"
+multilib_check() {
+ if (has_m64 && has_m32) ; then
+ einfo "multilib detected, adding -m32 to CFLAGS. note that opengl"
+ einfo "support probably wont work quite right."
+ append-flags -m32
+ else
+ die "zsnes requires multilib support in gcc. please re-emerge gcc with multilib in USE and try again"
+ fi
+}
+
src_unpack() {
unpack ${A}
for f in * ; do
@@ -35,7 +48,8 @@ src_unpack() {
}
src_compile() {
- # Do NOT introduce custom ${CFLAGS} - Current choices are the optimal ones
+ use amd64 && multilib_check
+
cd src
egamesconf \
$(use_with opengl) \