summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-28 19:59:10 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-28 19:59:10 +0000
commit6320ef929ba70bbedc1d30db28d2268ad2826edd (patch)
tree0d8620081cc19fe9b7083cc02b3c1e536317a678 /games-emulation
parentSwitch to CPU_FLAGS_X86. (diff)
downloadgentoo-2-6320ef929ba70bbedc1d30db28d2268ad2826edd.tar.gz
gentoo-2-6320ef929ba70bbedc1d30db28d2268ad2826edd.tar.bz2
gentoo-2-6320ef929ba70bbedc1d30db28d2268ad2826edd.zip
Switch to CPU_FLAGS_X86.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64plus/ChangeLog8
-rw-r--r--games-emulation/mupen64plus/mupen64plus-1.5-r1.ebuild10
-rw-r--r--games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild10
3 files changed, 16 insertions, 12 deletions
diff --git a/games-emulation/mupen64plus/ChangeLog b/games-emulation/mupen64plus/ChangeLog
index 3ff7ca41d109..e46b82fa160d 100644
--- a/games-emulation/mupen64plus/ChangeLog
+++ b/games-emulation/mupen64plus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/mupen64plus
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/ChangeLog,v 1.24 2014/08/15 10:22:34 mgorny Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/ChangeLog,v 1.25 2015/01/28 19:59:10 mgorny Exp $
+
+ 28 Jan 2015; Michał Górny <mgorny@gentoo.org> mupen64plus-1.5-r1.ebuild,
+ mupen64plus-1.5-r2.ebuild:
+ Switch to CPU_FLAGS_X86.
15 Aug 2014; Michał Górny <mgorny@gentoo.org> metadata.xml:
Remove games team maintainership following the Council decision.
diff --git a/games-emulation/mupen64plus/mupen64plus-1.5-r1.ebuild b/games-emulation/mupen64plus/mupen64plus-1.5-r1.ebuild
index d8c9dfd53c21..5eea6c148ed3 100644
--- a/games-emulation/mupen64plus/mupen64plus-1.5-r1.ebuild
+++ b/games-emulation/mupen64plus/mupen64plus-1.5-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/mupen64plus-1.5-r1.ebuild,v 1.11 2013/03/02 21:14:43 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/mupen64plus-1.5-r1.ebuild,v 1.12 2015/01/28 19:59:10 mgorny Exp $
EAPI="2"
@@ -17,7 +17,7 @@ SRC_URI="http://mupen64plus.googlecode.com/files/${MY_P}.tar.gz mirror://gentoo/
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="+gtk libsamplerate lirc qt4 sse"
+IUSE="+gtk libsamplerate lirc qt4 cpu_flags_x86_sse"
# GTK+ is currently required by plugins even if no GUI support is enabled
RDEPEND="virtual/opengl
@@ -76,7 +76,7 @@ get_opts() {
use libsamplerate || echo -n "NO_RESAMP=1 "
use lirc && echo -n "LIRC=1 "
- use sse || echo -n "NO_ASM=1 "
+ use cpu_flags_x86_sse || echo -n "NO_ASM=1 "
echo -n GUI=
if use gtk; then
@@ -89,7 +89,7 @@ get_opts() {
}
src_compile() {
- use x86 && use sse && append-flags -fomit-frame-pointer
+ use x86 && use cpu_flags_x86_sse && append-flags -fomit-frame-pointer
emake $(get_opts) DBGSYM=1 all || die "make failed"
}
diff --git a/games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild b/games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild
index c112aeac166e..afa32ae7201a 100644
--- a/games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild
+++ b/games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild,v 1.10 2013/03/02 21:14:43 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild,v 1.11 2015/01/28 19:59:10 mgorny Exp $
EAPI="2"
@@ -17,7 +17,7 @@ SRC_URI="http://mupen64plus.googlecode.com/files/${MY_P}.tar.gz mirror://gentoo/
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="+gtk libsamplerate lirc qt4 sse"
+IUSE="+gtk libsamplerate lirc qt4 cpu_flags_x86_sse"
# GTK+ is currently required by plugins even if no GUI support is enabled
RDEPEND="virtual/opengl
@@ -83,7 +83,7 @@ get_opts() {
use libsamplerate || echo -n "NO_RESAMP=1 "
use lirc && echo -n "LIRC=1 "
- use sse || echo -n "NO_ASM=1 "
+ use cpu_flags_x86_sse || echo -n "NO_ASM=1 "
echo -n GUI=
if use gtk; then
@@ -97,7 +97,7 @@ get_opts() {
src_compile() {
tc-export CC CXX
- use x86 && use sse && append-flags -fomit-frame-pointer
+ use x86 && use cpu_flags_x86_sse && append-flags -fomit-frame-pointer
emake $(get_opts) DBGSYM=1 CC="${CC}" CXX="${CXX}" LD="${CC}" all || die "make failed"
}